summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2018-01-29 19:49:29 +0700
committerAndrey Grozin <grozin@gentoo.org>2018-01-29 19:49:29 +0700
commitaf2fc6e54f59a45a4331d1c583c9c02bce3b0b86 (patch)
tree4aa9d4f8d61de2fb8296b0b46162f5cf79e27b7e /net-misc/dropbox-cli
parentsys-libs/libosinfo: bump to 1.1.0 (diff)
downloadgentoo-af2fc6e54f59a45a4331d1c583c9c02bce3b0b86.tar.gz
gentoo-af2fc6e54f59a45a4331d1c583c9c02bce3b0b86.tar.bz2
gentoo-af2fc6e54f59a45a4331d1c583c9c02bce3b0b86.zip
net-misc/dropbox-cli: depend on pygtk and pygobject:2
Closes: https://bugs.gentoo.org/645898 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'net-misc/dropbox-cli')
-rw-r--r--net-misc/dropbox-cli/dropbox-cli-1.6.0-r1.ebuild31
-rw-r--r--net-misc/dropbox-cli/files/dropbox-cli-completion2
2 files changed, 33 insertions, 0 deletions
diff --git a/net-misc/dropbox-cli/dropbox-cli-1.6.0-r1.ebuild b/net-misc/dropbox-cli/dropbox-cli-1.6.0-r1.ebuild
new file mode 100644
index 000000000000..b2dd3a01d442
--- /dev/null
+++ b/net-misc/dropbox-cli/dropbox-cli-1.6.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1 bash-completion-r1
+
+DESCRIPTION="Cli interface for dropbox (python), part of nautilus-dropbox"
+HOMEPAGE="http://www.dropbox.com/"
+SRC_URI="https://dev.gentoo.org/~hasufell/distfiles/${P}.py.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="net-misc/dropbox
+ ${PYTHON_DEPS}
+ dev-python/pygtk[${PYTHON_USEDEP}]
+ dev-python/pygobject:2[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}
+
+src_install() {
+ newbin ${P}.py ${PN}
+ python_replicate_script "${D}"/usr/bin/${PN}
+ newbashcomp "${FILESDIR}"/${PN}-completion ${PN}
+}
diff --git a/net-misc/dropbox-cli/files/dropbox-cli-completion b/net-misc/dropbox-cli/files/dropbox-cli-completion
new file mode 100644
index 000000000000..e1e9251ca9ba
--- /dev/null
+++ b/net-misc/dropbox-cli/files/dropbox-cli-completion
@@ -0,0 +1,2 @@
+# dropbox-cli completion
+complete -W 'autostart exclude filestatus help lansync ls puburl running start status stop' dropbox-cli