summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2020-12-05 17:50:34 +0300
committerSergey Popov <pinkbyte@gentoo.org>2020-12-05 17:58:43 +0300
commit936f3aef981b99b77e8b1d0c71ad8546f27e8dd4 (patch)
tree6d520387d7f1585c8613b4adc141f7a734d8f5de /net-misc/frr
parentsci-physics/geant: version bump to 4.10.7 (diff)
downloadgentoo-936f3aef981b99b77e8b1d0c71ad8546f27e8dd4.tar.gz
gentoo-936f3aef981b99b77e8b1d0c71ad8546f27e8dd4.tar.bz2
gentoo-936f3aef981b99b77e8b1d0c71ad8546f27e8dd4.zip
net-misc/frr: correct dependencies
Add missing dependencies for tests Fix collision with net-libs/libsmi Reported-by: Toralf Förster <toralf@gentoo.org> Closes: https://bugs.gentoo.org/758383 Closes: https://bugs.gentoo.org/758389 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Sergey Popov <pinkbyte@gentoo.org>
Diffstat (limited to 'net-misc/frr')
-rw-r--r--net-misc/frr/frr-7.5.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/net-misc/frr/frr-7.5.ebuild b/net-misc/frr/frr-7.5.ebuild
index 1ed14a42b734..425a59944037 100644
--- a/net-misc/frr/frr-7.5.ebuild
+++ b/net-misc/frr/frr-7.5.ebuild
@@ -14,9 +14,10 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc fpm grpc ipv6 kernel_linux nhrp ospfapi pam rpki snmp systemd"
+IUSE="doc fpm grpc ipv6 kernel_linux nhrp ospfapi pam rpki snmp systemd test"
COMMON_DEPEND="
+ ${PYTHON_DEPS}
acct-user/frr
dev-libs/json-c:0=
>=net-libs/libyang-1.0.184
@@ -30,19 +31,18 @@ COMMON_DEPEND="
"
BDEPEND="
- ${COMMON_DEPEND}
doc? ( dev-python/sphinx )
sys-devel/flex
virtual/yacc
"
DEPEND="
- ${PYTHON_DEPS}
${COMMON_DEPEND}
+ test? ( $(python_gen_cond_dep 'dev-python/pytest[${PYTHON_USEDEP}]') )
"
RDEPEND="
- ${DEPEND}
+ ${COMMON_DEPEND}
$(python_gen_cond_dep 'dev-python/ipaddr[${PYTHON_USEDEP}]')
!!net-misc/quagga
"
@@ -53,6 +53,8 @@ PATCHES=(
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
# FRR tarballs have weird format.
S="${WORKDIR}/frr-${P}"
@@ -142,4 +144,7 @@ src_install() {
# Install init scripts
systemd_dounit tools/frr.service
newinitd "${FILESDIR}/frr-openrc-v1" frr
+
+ # Conflict files, installed by net-libs/libsmi, bug #758383
+ rm "${D}/usr/share/yang/ietf-interfaces.yang" || die
}