summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-06-17 19:38:36 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-06-17 19:43:34 +0200
commitb9f671dd3c4904ce8cfd4fc13b87d54de27053b8 (patch)
treedd52cc710c7fb6b5a1c1aab00690f389f0fb2fe0 /net-misc/gallery-dl
parentdev-lang/eisl: bump to 3.00 (diff)
downloadgentoo-b9f671dd3c4904ce8cfd4fc13b87d54de27053b8.tar.gz
gentoo-b9f671dd3c4904ce8cfd4fc13b87d54de27053b8.tar.bz2
gentoo-b9f671dd3c4904ce8cfd4fc13b87d54de27053b8.zip
net-misc/gallery-dl: bump to 1.25.6
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'net-misc/gallery-dl')
-rw-r--r--net-misc/gallery-dl/Manifest1
-rw-r--r--net-misc/gallery-dl/gallery-dl-1.25.6.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/net-misc/gallery-dl/Manifest b/net-misc/gallery-dl/Manifest
index 1d4ce4e2e34a..94195f9340c9 100644
--- a/net-misc/gallery-dl/Manifest
+++ b/net-misc/gallery-dl/Manifest
@@ -2,3 +2,4 @@ DIST gallery-dl-1.25.1.gh.tar.gz 543977 BLAKE2B ab6437ebb4f840fb3fac27a3f0d25362
DIST gallery-dl-1.25.2.gh.tar.gz 546468 BLAKE2B ee40766e581afa8ab1119d656131a1e467fc1b6b5d92491ee384428ee4a02fd2b0b261657f175cb6d6bc8e79a622a14b7308ccb0e129535e7718503a6828ae53 SHA512 99bc319427c067f039df7f34988b44da2db028afc33188454879c46abbacfaac6fb8a5d0d0aec1fd4d7ba97862b100675cab55094b9d8979a5240f516fe4b855
DIST gallery-dl-1.25.4.gh.tar.gz 555479 BLAKE2B c209d494014db2978722e70ad6442244ddd283c0e7169a90256eaf6ddaf6ffbe2a85129369d5207eb31512ca13298fe290b3f5fa41e9949db402ee6637ff139c SHA512 163033515925f13b8d19c98a45ef50e316be92cbaf439322a47d074a783519c389a685005b7f33a9d384791315d53cb2d59af030ab96ff8eaed7caa31f0e8e17
DIST gallery-dl-1.25.5.gh.tar.gz 563928 BLAKE2B d8308233fc4e59da466825f5063556bffb31f8f710a75dca23b710244c1702569ffc46f41d0721e6bdcfd1ce5471d30872f8f931388db82a7ce918564d84ae75 SHA512 ed2e18a9220eb68bd93009b12212c4052893277cb585ded8b5c513c764d3efec348c0340360b5ccac6f98527fb0a9ddb93167e942e3151419169a4ad7353157f
+DIST gallery-dl-1.25.6.gh.tar.gz 567710 BLAKE2B 85f4fe19a09d1569e431e18c821db6d7f581760f2065138a36f2c8523c632aac0f6bd2fc18154f9a9524e158525b604b67240fe139a97f1407d2178e9f668d99 SHA512 2ae93401598ca46458c22bca7f2a53fe611519c24c88156c6566b45a5073336e92310b7c60939782b619ede59c8b2862a0ed9811dd7f9307f8a080e5fbfdf3bc
diff --git a/net-misc/gallery-dl/gallery-dl-1.25.6.ebuild b/net-misc/gallery-dl/gallery-dl-1.25.6.ebuild
new file mode 100644
index 000000000000..b3da2a9c870f
--- /dev/null
+++ b/net-misc/gallery-dl/gallery-dl-1.25.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite,ssl,xml(+)"
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Download image galleries and collections from several image hosting sites"
+HOMEPAGE="https://github.com/mikf/gallery-dl"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mikf/${PN}.git"
+else
+ SRC_URI="https://github.com/mikf/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+# Tests require network access.
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND=">=dev-python/requests-2.11.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests setup.py
+
+python_compile_all() {
+ emake PYTHON=${EPYTHON} data/completion/{,_}gallery-dl man
+}
+
+pkg_postinst() {
+ optfeature "Pixiv Ugoira to WebM conversion" media-video/ffmpeg
+ optfeature "video downloads" net-misc/yt-dlp
+}