summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenning Schild <henning@hennsch.de>2023-01-02 20:54:35 +0100
committerSam James <sam@gentoo.org>2023-01-04 05:48:13 +0000
commit68b0afea5d7cf758f1b2d39763b65396a8c65f78 (patch)
tree0e8043a61ab711628fe99575339c6135b1eabf11 /net-misc/icaclient
parentapp-text/mupdf-1.21.1: patch aliasing violation (diff)
downloadgentoo-68b0afea5d7cf758f1b2d39763b65396a8c65f78.tar.gz
gentoo-68b0afea5d7cf758f1b2d39763b65396a8c65f78.tar.bz2
gentoo-68b0afea5d7cf758f1b2d39763b65396a8c65f78.zip
net-misc/icaclient: fix broken BDEPEND and add error handling
When one wants to use "hdx" that does not really work as expected due to a typo. Also include the missing "|| die"s that have been pointed out in a previous review. Signed-off-by: Henning Schild <henning@hennsch.de> Closes: https://github.com/gentoo/gentoo/pull/28940 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/icaclient')
-rw-r--r--net-misc/icaclient/icaclient-22.12.0.12-r1.ebuild (renamed from net-misc/icaclient/icaclient-22.12.0.12.ebuild)10
1 files changed, 5 insertions, 5 deletions
diff --git a/net-misc/icaclient/icaclient-22.12.0.12.ebuild b/net-misc/icaclient/icaclient-22.12.0.12-r1.ebuild
index 399b2a4f22b1..c29d64d2492d 100644
--- a/net-misc/icaclient/icaclient-22.12.0.12.ebuild
+++ b/net-misc/icaclient/icaclient-22.12.0.12-r1.ebuild
@@ -40,7 +40,7 @@ REQUIRES_EXCLUDE="${REQUIRES_EXCLUDE}
libgstreamer-0.10.so.0
"
-BEPEND="
+BDEPEND="
hdx? ( >=media-plugins/hdx-realtime-media-engine-2.9.500.2802-r1 )
"
@@ -121,12 +121,12 @@ src_prepare() {
default
rm lib/UIDialogLibWebKit.so || die
- cp nls/en/module.ini .
+ cp nls/en/module.ini . || die
if use hdx; then
- "${BROOT}${ICAROOT}"/rtme/RTMEconfig -install -ignoremm
- mv new_module.ini module.ini
+ "${BROOT}${ICAROOT}"/rtme/RTMEconfig -install -ignoremm || die
+ mv new_module.ini module.ini || die
fi
- mv module.ini config/
+ mv module.ini config/ || die
}
src_install() {