summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-05-03 19:09:58 -0500
committerAustin English <wizardedit@gentoo.org>2016-05-03 19:09:58 -0500
commitfdf3d9adf167bf95a221c6d3eb4f3789970a9c71 (patch)
treed657bd6ac08dff5c98589394e851499f26724c8e /net-misc/midentd
parentnet-misc/mdidentd: remove old version (diff)
downloadgentoo-fdf3d9adf167bf95a221c6d3eb4f3789970a9c71.tar.gz
gentoo-fdf3d9adf167bf95a221c6d3eb4f3789970a9c71.tar.bz2
gentoo-fdf3d9adf167bf95a221c6d3eb4f3789970a9c71.zip
net-misc/midentd: use #!/sbin/openrc-run instead of #!/sbin/runscript
Gentoo-Bug: https://bugs.gentoo.org/573846 Package-Manager: portage-2.2.26
Diffstat (limited to 'net-misc/midentd')
-rw-r--r--net-misc/midentd/files/midentd.rc4
-rw-r--r--net-misc/midentd/midentd-2.3.1-r2.ebuild43
2 files changed, 45 insertions, 2 deletions
diff --git a/net-misc/midentd/files/midentd.rc b/net-misc/midentd/files/midentd.rc
index ed89ba4d0fa0..12ed1a6cc7c7 100644
--- a/net-misc/midentd/files/midentd.rc
+++ b/net-misc/midentd/files/midentd.rc
@@ -1,5 +1,5 @@
-#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
diff --git a/net-misc/midentd/midentd-2.3.1-r2.ebuild b/net-misc/midentd/midentd-2.3.1-r2.ebuild
new file mode 100644
index 000000000000..07d4e6d98418
--- /dev/null
+++ b/net-misc/midentd/midentd-2.3.1-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="ident daemon with masquerading and fake replies support"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-lang/perl"
+
+src_prepare() {
+ default
+
+ eapply "${FILESDIR}"/${PV}-pidfile.patch
+ sed -i \
+ -e 's:/usr/local:/usr:' \
+ -e 's:service ident:service auth:' \
+ -e 's:disable = no:disable = yes:' \
+ midentd.xinetd || die
+}
+
+src_install() {
+ dosbin midentd midentd.logcycle
+
+ insinto /etc/xinetd.d
+ newins midentd.xinetd midentd
+ newinitd "${FILESDIR}"/midentd.rc midentd
+ newconfd "${FILESDIR}"/midentd.conf.d midentd
+
+ dodoc CHANGELOG README
+
+ dodir /var/log
+ touch "${D}"/var/log/midentd.log
+ fowners nobody:nobody /var/log/midentd.log
+}