summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Browning <JamesB.fe80@gmail.com>2024-06-04 12:01:28 -0700
committerSam James <sam@gentoo.org>2024-06-14 09:01:48 +0100
commitd7d9ffd7751437e145b5b867efa14f39c9393fc7 (patch)
tree1d05681aa2e3bee3c802e602edec80b5d0280252 /net-misc/ntpsec
parentnet-misc/ntpsec: Replace egg-info with a Flit pyproject.toml file (diff)
downloadgentoo-d7d9ffd7751437e145b5b867efa14f39c9393fc7.tar.gz
gentoo-d7d9ffd7751437e145b5b867efa14f39c9393fc7.tar.bz2
gentoo-d7d9ffd7751437e145b5b867efa14f39c9393fc7.zip
net-misc/ntpsec: Replace n(+1) used whole tree builds with 1
Signed-off-by: James Browning <JamesB.fe80@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/ntpsec')
-rw-r--r--net-misc/ntpsec/ntpsec-1.2.2a-r1.ebuild17
-rw-r--r--net-misc/ntpsec/ntpsec-1.2.3-r1.ebuild19
-rw-r--r--net-misc/ntpsec/ntpsec-9999.ebuild19
3 files changed, 41 insertions, 14 deletions
diff --git a/net-misc/ntpsec/ntpsec-1.2.2a-r1.ebuild b/net-misc/ntpsec/ntpsec-1.2.2a-r1.ebuild
index 9db716210dab..7ac251bca9f3 100644
--- a/net-misc/ntpsec/ntpsec-1.2.2a-r1.ebuild
+++ b/net-misc/ntpsec/ntpsec-1.2.2a-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-DISTUTILS_EXT=1
+#DISTUTILS_USE_PEP517="flit"
PYTHON_COMPAT=( python3_{10..11} )
PYTHON_REQ_USE='threads(+)'
DISTUTILS_USE_SETUPTOOLS=no
@@ -108,7 +108,6 @@ src_configure() {
--notests
--nopyc
--nopyo
- --enable-pylib ext
--refclock="${CLOCKSTRING}"
#--build-epoch="$(date +%s)"
$(use doc || echo "--disable-doc")
@@ -165,14 +164,24 @@ src_install() {
# move doc files to /usr/share/doc/"${P}"
use doc && mv -v "${ED}"/usr/share/doc/"${PN}" "${ED}"/usr/share/doc/"${P}"/html
-}
-python_install() {
waf-utils_src_install --notests
+ ln -svf pylib build/main/ntp
+ wheel_name=$(
+ cd build/main && \
+ gpep517 build-wheel --output-fd 3 --wheel-dir ../.. 3>&1 >&2
+ )
+ python_foreach_impl python_install
python_fix_shebang "${ED}"
python_optimize
}
+python_install() {
+ ${PYTHON} -m gpep517 \
+ install-wheel "${wheel_name}" \
+ --optimize all --destdir "${D}"
+}
+
pkg_postinst() {
einfo "If you want to serve time on your local network, then"
einfo "you should disable all the ref_clocks unless you have"
diff --git a/net-misc/ntpsec/ntpsec-1.2.3-r1.ebuild b/net-misc/ntpsec/ntpsec-1.2.3-r1.ebuild
index 760ab7ded80c..f68a9031ad40 100644
--- a/net-misc/ntpsec/ntpsec-1.2.3-r1.ebuild
+++ b/net-misc/ntpsec/ntpsec-1.2.3-r1.ebuild
@@ -3,8 +3,8 @@
EAPI=8
-DISTUTILS_EXT=1
-PYTHON_COMPAT=( python3_{10..12} )
+#DISTUTILS_USE_PEP517="flit"
+PYTHON_COMPAT=( python3_{10..13} )
PYTHON_REQ_USE='threads(+)'
DISTUTILS_USE_SETUPTOOLS=no
@@ -108,7 +108,6 @@ src_configure() {
--notests
--nopyc
--nopyo
- --enable-pylib ext
--refclock="${CLOCKSTRING}"
#--build-epoch="$(date +%s)"
$(use doc || echo "--disable-doc")
@@ -164,14 +163,24 @@ src_install() {
# move doc files to /usr/share/doc/"${P}"
use doc && mv -v "${ED}"/usr/share/doc/"${PN}" "${ED}"/usr/share/doc/"${P}"/html
-}
-python_install() {
waf-utils_src_install --notests
+ ln -svf pylib build/main/ntp
+ wheel_name=$(
+ cd build/main && \
+ gpep517 build-wheel --output-fd 3 --wheel-dir ../.. 3>&1 >&2
+ )
+ python_foreach_impl python_install
python_fix_shebang "${ED}"
python_optimize
}
+python_install() {
+ ${PYTHON} -m gpep517 \
+ install-wheel "${wheel_name}" \
+ --optimize all --destdir "${D}"
+}
+
pkg_postinst() {
einfo "If you want to serve time on your local network, then"
einfo "you should disable all the ref_clocks unless you have"
diff --git a/net-misc/ntpsec/ntpsec-9999.ebuild b/net-misc/ntpsec/ntpsec-9999.ebuild
index 79ca14fe71f2..01362d1ff984 100644
--- a/net-misc/ntpsec/ntpsec-9999.ebuild
+++ b/net-misc/ntpsec/ntpsec-9999.ebuild
@@ -3,8 +3,8 @@
EAPI=8
-DISTUTILS_EXT=1
-PYTHON_COMPAT=( python3_{10..12} )
+#DISTUTILS_USE_PEP517="flit"
+PYTHON_COMPAT=( python3_{10..13} )
PYTHON_REQ_USE='threads(+)'
DISTUTILS_USE_SETUPTOOLS=no
@@ -108,7 +108,6 @@ src_configure() {
--notests
--nopyc
--nopyo
- --enable-pylib ext
--refclock="${CLOCKSTRING}"
#--build-epoch="$(date +%s)"
$(use doc || echo "--disable-doc")
@@ -164,14 +163,24 @@ src_install() {
# move doc files to /usr/share/doc/"${P}"
use doc && mv -v "${ED}"/usr/share/doc/"${PN}" "${ED}"/usr/share/doc/"${P}"/html
-}
-python_install() {
waf-utils_src_install --notests
+ ln -svf pylib build/main/ntp
+ wheel_name=$(
+ cd build/main && \
+ gpep517 build-wheel --output-fd 3 --wheel-dir ../.. 3>&1 >&2
+ )
+ python_foreach_impl python_install
python_fix_shebang "${ED}"
python_optimize
}
+python_install() {
+ ${PYTHON} -m gpep517 \
+ install-wheel "${wheel_name}" \
+ --optimize all --destdir "${D}"
+}
+
pkg_postinst() {
einfo "If you want to serve time on your local network, then"
einfo "you should disable all the ref_clocks unless you have"