summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Lin <jeffrey@icurse.nl>2020-02-22 22:52:03 -0500
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-10 18:45:59 +0200
commit660919de09814e5a72fa3e99d232ed0295379567 (patch)
treebb93941b5bb51cc1a39c31c1750c7a6e3efcc536 /net-misc/nyx
parentnet-misc/nyx: require dev-lang/python[sqlite] (diff)
downloadgentoo-660919de09814e5a72fa3e99d232ed0295379567.tar.gz
gentoo-660919de09814e5a72fa3e99d232ed0295379567.tar.bz2
gentoo-660919de09814e5a72fa3e99d232ed0295379567.zip
net-misc/nyx: EAPI 7; add pypy3 support
Signed-off-by: Jeffrey Lin <jeffrey@icurse.nl> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-misc/nyx')
-rw-r--r--net-misc/nyx/nyx-2.1.0-r1.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/net-misc/nyx/nyx-2.1.0-r1.ebuild b/net-misc/nyx/nyx-2.1.0-r1.ebuild
index a95caeb5ea5f..39a256ecefe0 100644
--- a/net-misc/nyx/nyx-2.1.0-r1.ebuild
+++ b/net-misc/nyx/nyx-2.1.0-r1.ebuild
@@ -1,11 +1,13 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=(python{3_6,3_7,3_8})
+EAPI=7
+
+PYTHON_COMPAT=(python3_{6,7,8} pypy3)
PYTHON_REQ_USE='sqlite(-)'
+DISTUTILS_USE_SETUPTOOLS=rdepend
-inherit vcs-snapshot distutils-r1
+inherit distutils-r1
DESCRIPTION="Utility to monitor real time Tor status information"
HOMEPAGE="https://nyx.torproject.org"
@@ -22,8 +24,6 @@ SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="
net-libs/stem[${PYTHON_USEDEP}]
net-vpn/tor"