summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2024-07-11 10:04:57 +0000
committerYixun Lan <dlan@gentoo.org>2024-07-11 10:05:27 +0000
commit976d22540700d71c20b40d13537df3956be1b1be (patch)
treedc15d79bec50d4591e148a08d36a0be2c6835aec /net-misc/ofono
parentdev-ruby/multi_json: update EAPI 7 -> 8, add ruby33 (diff)
downloadgentoo-976d22540700d71c20b40d13537df3956be1b1be.tar.gz
gentoo-976d22540700d71c20b40d13537df3956be1b1be.tar.bz2
gentoo-976d22540700d71c20b40d13537df3956be1b1be.zip
net-misc/ofono: add 2.9
Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'net-misc/ofono')
-rw-r--r--net-misc/ofono/Manifest1
-rw-r--r--net-misc/ofono/ofono-2.9.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/net-misc/ofono/Manifest b/net-misc/ofono/Manifest
index 18448a795f89..3d4f5395c13a 100644
--- a/net-misc/ofono/Manifest
+++ b/net-misc/ofono/Manifest
@@ -1,2 +1,3 @@
DIST ofono-2.1.tar.xz 1097624 BLAKE2B 574293a73061470eec322df7fa62d581e8e8d2c5b81e896bff52173a986733f448686186bc0400ccf256fb931e26a1fef6a664dafa8f64935f936c9347e4a054 SHA512 7227939c488c2a62f640d5a8279e0698935aa1df5a2a349e195df9a8d9d9123c73a7f1177aae022b4c805d266c24a9770784193100adffa45f6c36a3ed847bb1
DIST ofono-2.3.tar.xz 1216872 BLAKE2B e32ea09dbc8f0aa2ca3f322ffc34d9f9d06d862792b05a0f96ddba4ebe4038199ab40a4065582d68a35d2a5725646626bc36c8f9e83d89a42be8d76271144751 SHA512 0c53c2c441d28f89140192fe808769b3b27ef1ebf75e9ee9f9bfa53d0d102a47d11fcb364077ca88cdc598e8368924f477024b44a2adf795efe40b52ffe92dce
+DIST ofono-2.9.tar.xz 1302044 BLAKE2B d468c179ead13ab75b5e9872c671bea3c5f7cd59242516ba432c323aefc423ea18fd401a236a7abacf0ff0f2c74c8921828496b8a74269a1dc246f893c89036b SHA512 181f4aad276ea5c5888c6b89187e27b65d42f002d1dd72091f377033bda82bada17364c49773d4a1fd62ea7940d27d7f796da561595b606abbf4b4ec220ae031
diff --git a/net-misc/ofono/ofono-2.9.ebuild b/net-misc/ofono/ofono-2.9.ebuild
new file mode 100644
index 000000000000..e405fffeba77
--- /dev/null
+++ b/net-misc/ofono/ofono-2.9.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+
+DESCRIPTION="Open Source mobile telephony (GSM/UMTS) daemon"
+HOMEPAGE="https://git.kernel.org/pub/scm/network/ofono/ofono.git"
+SRC_URI="https://mirrors.edge.kernel.org/pub/linux/network/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+atmodem bluetooth +datafiles doc dundee examples +isimodem +phonesim +qmimodem tools +udev upower"
+
+REQUIRED_USE="dundee? ( bluetooth )"
+
+RDEPEND=">=sys-apps/dbus-1.6
+ >=dev-libs/glib-2.68
+ net-misc/mobile-broadband-provider-info
+ bluetooth? ( >=net-wireless/bluez-4.99 )
+ udev? ( virtual/udev )
+ examples? ( dev-python/dbus-python )
+ tools? ( virtual/libusb:1 )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( ChangeLog AUTHORS )
+
+src_configure() {
+ econf \
+ $(use_enable udev) \
+ $(use_enable isimodem) \
+ $(use_enable atmodem) \
+ $(use_enable datafiles) \
+ $(use_enable dundee) \
+ $(use_enable bluetooth) \
+ $(use_enable phonesim) \
+ $(use_enable qmimodem) \
+ $(use_enable tools) \
+ $(use_enable examples test) \
+ $(use_enable upower) \
+ --disable-maintainer-mode \
+ --disable-rilmodem
+ --localstatedir=/var \
+ --with-systemdunitdir="$(systemd_get_systemunitdir)"
+}
+
+src_install() {
+ default
+
+ if use tools ; then
+ dobin tools/auto-enable \
+ tools/huawei-audio \
+ tools/lookup-apn \
+ tools/get-location \
+ tools/tty-redirector
+ fi
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ use doc && dodoc doc/*.txt
+}