summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2023-02-02 02:17:21 +0200
committerSam James <sam@gentoo.org>2023-02-02 04:49:56 +0000
commitb20b5bab12d0085e0c1e92c34ab1a1c39c2b01ce (patch)
tree06b18d2e09965b766c3cd8e045239c4735828ad9 /net-misc/openvswitch
parentnet-misc/openvswitch: keyword 2.17.2-r1 for ~ppc64 (diff)
downloadgentoo-b20b5bab12d0085e0c1e92c34ab1a1c39c2b01ce.tar.gz
gentoo-b20b5bab12d0085e0c1e92c34ab1a1c39c2b01ce.tar.bz2
gentoo-b20b5bab12d0085e0c1e92c34ab1a1c39c2b01ce.zip
net-misc/openvswitch: add USE=unwind
Building net-misc/openvswitch on a host with sys-libs/libunwind installed results in several binaries being linked to libunwind.so. As net-misc/openvswitch lacks a dependency on sys-libs/libunwind, installing a binpkg created on such host will result in broken binaries. There is no configure option to disable libunwind, and upstream enables the dependency unconditionally in their RPM spec, but as we support architectures that do not support libunwind, this is not an option. Add a USE flag to toggle libunwind via the autoconf macro. Closes: https://bugs.gentoo.org/892389 Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> Closes: https://github.com/gentoo/gentoo/pull/29385 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/openvswitch')
-rw-r--r--net-misc/openvswitch/openvswitch-2.17.2-r2.ebuild (renamed from net-misc/openvswitch/openvswitch-2.17.2-r1.ebuild)5
1 files changed, 4 insertions, 1 deletions
diff --git a/net-misc/openvswitch/openvswitch-2.17.2-r1.ebuild b/net-misc/openvswitch/openvswitch-2.17.2-r2.ebuild
index c26ee73a3019..c17e37e3f3bb 100644
--- a/net-misc/openvswitch/openvswitch-2.17.2-r1.ebuild
+++ b/net-misc/openvswitch/openvswitch-2.17.2-r2.ebuild
@@ -15,7 +15,7 @@ SRC_URI="https://www.openvswitch.org/releases/${P}.tar.gz"
LICENSE="Apache-2.0 GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm64 ~ppc64 x86"
-IUSE="debug modules monitor +ssl"
+IUSE="debug modules monitor +ssl unwind"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
# Check python/ovs/version.py in tarball for dev-python/ovs dep
@@ -26,6 +26,7 @@ RDEPEND="${PYTHON_DEPS}
dev-python/zope-interface[${PYTHON_USEDEP}]
')
debug? ( dev-lang/perl )
+ unwind? ( sys-libs/libunwind:= )
ssl? ( dev-libs/openssl:= )"
DEPEND="${RDEPEND}
sys-apps/util-linux[caps]"
@@ -82,6 +83,8 @@ src_configure() {
local linux_config
use modules && linux_config="--with-linux=${KV_OUT_DIR}"
+ export ac_cv_lib_unwind_unw_backtrace="$(usex unwind)"
+
# Need PYTHON3 variable for bug #860240
PYTHON3="${PYTHON}" CONFIG_SHELL="${BROOT}"/bin/bash SHELL="${BROOT}"/bin/bash econf ${linux_config} \
--with-rundir=/var/run/openvswitch \