summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/youtube-viewer
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/youtube-viewer')
-rw-r--r--net-misc/youtube-viewer/Manifest1
-rw-r--r--net-misc/youtube-viewer/metadata.xml18
-rw-r--r--net-misc/youtube-viewer/youtube-viewer-3.1.1.ebuild91
-rw-r--r--net-misc/youtube-viewer/youtube-viewer-9999.ebuild74
4 files changed, 184 insertions, 0 deletions
diff --git a/net-misc/youtube-viewer/Manifest b/net-misc/youtube-viewer/Manifest
new file mode 100644
index 000000000000..286ca46daceb
--- /dev/null
+++ b/net-misc/youtube-viewer/Manifest
@@ -0,0 +1 @@
+DIST youtube-viewer-3.1.1.tar.gz 210183 SHA256 416289dac7c4bb29ad046e41bbf49faaca31f1827379e9e0082f5b282186531d SHA512 1c7236cde68f21a80bb1f3ac29e19f86f52732c784adb70f6fc07177d74ada3a6ae1652e604fc12f62ce8ddf0c172593dd85a419a6d7d804f980fc09afda90f0 WHIRLPOOL 9045cc344bd627806526594daafbd8e17cfefa0e7aaf456c5c3a0c7ebec4bdd53f8ec708e051b37706ac3e1e29af3379e1df8ea21bfd370ca367950e6accf886
diff --git a/net-misc/youtube-viewer/metadata.xml b/net-misc/youtube-viewer/metadata.xml
new file mode 100644
index 000000000000..860e12f9fbde
--- /dev/null
+++ b/net-misc/youtube-viewer/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <email>trizenx@gmail.com</email>
+ </maintainer>
+ <bugs-to>https://github.com/trizen/youtube-viewer/issues</bugs-to>
+ </upstream>
+ <longdescription lang="en">
+ Youtube Viewer is a CLI application dedicated for searching and streaming
+ Youtube Videos with MPlayer. It has been written in Perl and plays videos
+ from Youtube at the best quality available without using a flash player.
+ </longdescription>
+</pkgmetadata>
diff --git a/net-misc/youtube-viewer/youtube-viewer-3.1.1.ebuild b/net-misc/youtube-viewer/youtube-viewer-3.1.1.ebuild
new file mode 100644
index 000000000000..09c815ed4d5f
--- /dev/null
+++ b/net-misc/youtube-viewer/youtube-viewer-3.1.1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit gnome2-utils eutils perl-module vcs-snapshot
+
+DESCRIPTION="A command line utility for viewing youtube-videos in Mplayer"
+HOMEPAGE="http://trizen.googlecode.com"
+SRC_URI="https://github.com/trizen/youtube-viewer/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-1+ )"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="gtk"
+
+RDEPEND="
+ >=dev-lang/perl-5.16.0
+ dev-perl/Data-Dump
+ dev-perl/libwww-perl
+ || ( media-video/mplayer[X,network]
+ media-video/mplayer2[X,network]
+ media-video/mpv[X] )
+ virtual/perl-File-Spec
+ virtual/perl-Getopt-Long
+ virtual/perl-Term-ANSIColor
+ virtual/perl-Text-ParseWords
+ virtual/perl-Text-Tabs+Wrap
+ gtk? (
+ dev-perl/File-ShareDir
+ >=dev-perl/gtk2-perl-1.244.0
+ virtual/freedesktop-icon-theme
+ x11-libs/gdk-pixbuf:2[X,jpeg]
+ )"
+DEPEND="dev-perl/Module-Build"
+
+SRC_TEST="do"
+
+S=${WORKDIR}/${P}/WWW-YoutubeViewer
+
+src_prepare() {
+ perl-module_src_prepare
+}
+
+# build system installs files on "perl Build.PL" too
+# do all the work in src_install
+src_configure() { :; }
+src_compile() { :; }
+
+src_install() {
+ local myconf
+ if use gtk ; then
+ myconf="--gtk-youtube-viewer"
+ fi
+ perl-module_src_configure
+ perl-module_src_install
+
+ if use gtk ; then
+ domenu share/gtk-youtube-viewer.desktop
+ doicon share/icons/gtk-youtube-viewer.png
+ fi
+}
+
+pkg_preinst() {
+ use gtk && gnome2_icon_savelist
+ perl_set_version
+}
+
+pkg_postinst() {
+ use gtk && gnome2_icon_cache_update
+ einfo
+ elog "optional dependencies:"
+ elog " dev-perl/LWP-Protocol-https or dev-perl/libwww-perl[ssl]"
+ elog " and virtual/perl-MIME-Base64"
+ elog " (for HTTPS protocol and login support)"
+ elog " dev-perl/Term-ReadLine-Gnu (for a better STDIN support)"
+ elog " dev-perl/Text-CharWidth (print the results in a fixed-width"
+ elog " format (--fixed-width, -W))"
+ elog " dev-perl/XML-Fast (faster XML to HASH conversion)"
+ elog " net-misc/gcap (for retrieving Youtube closed captions)"
+ elog " virtual/perl-File-Temp (for posting comments)"
+ elog " virtual/perl-Scalar-List-Utils (to shuffle the playlists"
+ elog " (--shuffle, -s))"
+ elog " virtual/perl-threads (threads support)"
+ einfo
+}
+
+pkg_postrm() {
+ use gtk && gnome2_icon_cache_update
+}
diff --git a/net-misc/youtube-viewer/youtube-viewer-9999.ebuild b/net-misc/youtube-viewer/youtube-viewer-9999.ebuild
new file mode 100644
index 000000000000..d95aa2258bce
--- /dev/null
+++ b/net-misc/youtube-viewer/youtube-viewer-9999.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit perl-module git-2
+
+DESCRIPTION="A command line utility for viewing youtube-videos in Mplayer"
+HOMEPAGE="http://trizen.googlecode.com"
+SRC_URI=""
+EGIT_REPO_URI="git://github.com/trizen/${PN}.git"
+
+LICENSE="|| ( Artistic GPL-1+ )"
+SLOT="0"
+KEYWORDS=""
+IUSE="gtk"
+
+RDEPEND="
+ >=dev-lang/perl-5.16.0
+ dev-perl/Data-Dump
+ dev-perl/libwww-perl
+ || ( media-video/mplayer[X,network]
+ media-video/mplayer2[X,network]
+ media-video/mpv[X] )
+ virtual/perl-File-Spec
+ virtual/perl-Getopt-Long
+ virtual/perl-Term-ANSIColor
+ virtual/perl-Text-ParseWords
+ virtual/perl-Text-Tabs+Wrap
+ gtk? (
+ dev-perl/File-ShareDir
+ >=dev-perl/gtk2-perl-1.244.0
+ virtual/freedesktop-icon-theme
+ x11-libs/gdk-pixbuf:2[X,jpeg]
+ )"
+DEPEND="dev-perl/Module-Build"
+
+EGIT_SOURCEDIR="${WORKDIR}"
+S=${WORKDIR}/WWW-YoutubeViewer
+
+SRC_TEST="do"
+
+# build system installs files on "perl Build.PL" too
+# do all the work in src_install
+src_configure() { :; }
+src_compile() { :; }
+
+src_install() {
+ local myconf
+ if use gtk ; then
+ myconf="--gtk-youtube-viewer"
+ fi
+ perl-module_src_configure
+ perl-module_src_install
+}
+
+pkg_postinst() {
+ einfo
+ elog "optional dependencies:"
+ elog " dev-perl/LWP-Protocol-https or dev-perl/libwww-perl[ssl]"
+ elog " and virtual/perl-MIME-Base64"
+ elog " (for HTTPS protocol and login support)"
+ elog " dev-perl/Term-ReadLine-Gnu (for a better STDIN support)"
+ elog " dev-perl/Text-CharWidth (print the results in a fixed-width"
+ elog " format (--fixed-width, -W))"
+ elog " dev-perl/XML-Fast (faster XML to HASH conversion)"
+ elog " net-misc/gcap (for retrieving Youtube closed captions)"
+ elog " virtual/perl-File-Temp (for posting comments)"
+ elog " virtual/perl-Scalar-List-Utils (to shuffle the playlists"
+ elog " (--shuffle, -s))"
+ elog " virtual/perl-threads (threads support)"
+ einfo
+}