summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-05-12 01:23:08 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-05-12 04:59:38 -0400
commit48f62d10e443582aaf93b220b9cd0f36d9dee351 (patch)
tree66e3d9a8a69dfe076a8a2e4ef368f46ecf57f541 /net-misc/ytfzf
parentmedia-gfx/ueberzug: add blocker for media-gfx/ueberzugpp (diff)
downloadgentoo-48f62d10e443582aaf93b220b9cd0f36d9dee351.tar.gz
gentoo-48f62d10e443582aaf93b220b9cd0f36d9dee351.tar.bz2
gentoo-48f62d10e443582aaf93b220b9cd0f36d9dee351.zip
net-misc/ytfzf: add 2.6.0
Replace IUSE=X by a more generic IUSE=thumbnails and allow either ueberzugpp or ueberzug. X is not quite right given pp supports other outputs like kitty (ytfzf -t -T kitty). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-misc/ytfzf')
-rw-r--r--net-misc/ytfzf/Manifest1
-rw-r--r--net-misc/ytfzf/metadata.xml3
-rw-r--r--net-misc/ytfzf/ytfzf-2.6.0.ebuild58
3 files changed, 61 insertions, 1 deletions
diff --git a/net-misc/ytfzf/Manifest b/net-misc/ytfzf/Manifest
index 8c3723d8cc1e..e70e98462a8c 100644
--- a/net-misc/ytfzf/Manifest
+++ b/net-misc/ytfzf/Manifest
@@ -1 +1,2 @@
DIST ytfzf-2.5.5.tar.gz 3278740 BLAKE2B e80ee83cbd80fd3d53dd4e3f9aca4fed71b6bbebc6b0f0d8c85263efa4dfd184e45998719df966279365378669624119035f069c4d2b2d5f820e5304bd36604d SHA512 811fbc1de1b23bddd988c74212f0d6b314e5a7998ebc06e0481d42a5e6afa530f10a0e749a293a76799eff1fc380ebd54210f5e152c6d8ab07fd39327544c9d7
+DIST ytfzf-2.6.0.tar.gz 3277853 BLAKE2B f99de6c473ee728d42290a647df9e0404dea92854203f306401d916e920814517dee3ddde8c8ff06cb7ff29f5a9b8f438867a1d9bc02aa6e208d030ad8b786a7 SHA512 fb9a1bd161a735a9c464948d6ba3664982eadd25456d5d565c57e478574949324dbf556620fb837c00bc4946c65336ec895f7c59e1169631effadf70085773c4
diff --git a/net-misc/ytfzf/metadata.xml b/net-misc/ytfzf/metadata.xml
index b6a91b9d9370..153b2385848c 100644
--- a/net-misc/ytfzf/metadata.xml
+++ b/net-misc/ytfzf/metadata.xml
@@ -7,7 +7,8 @@
</maintainer>
<stabilize-allarches/>
<use>
- <flag name="minimal">Skip <pkg>app-shells/fzf</pkg> and <pkg>media-video/mpv</pkg> dependencies (requires custom settings)</flag>
+ <flag name="minimal">Skip all optional dependencies (may no longer work out-of-the-box and require custom setting up)</flag>
+ <flag name="thumbnails">Pull <pkg>media-gfx/ueberzugpp</pkg> or <pkg>media-gfx/ueberzug</pkg> for viewing thumbnails (default method when using -t)</flag>
</use>
<upstream>
<remote-id type="github">pystardust/ytfzf</remote-id>
diff --git a/net-misc/ytfzf/ytfzf-2.6.0.ebuild b/net-misc/ytfzf/ytfzf-2.6.0.ebuild
new file mode 100644
index 000000000000..62121ae8df88
--- /dev/null
+++ b/net-misc/ytfzf/ytfzf-2.6.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+DESCRIPTION="Posix script to find and watch youtube videos from the terminal"
+HOMEPAGE="https://github.com/pystardust/ytfzf/"
+SRC_URI="https://github.com/pystardust/ytfzf/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal +thumbnails"
+
+RDEPEND="
+ app-misc/jq
+ net-misc/curl[ssl]
+ app-alternatives/awk
+ !minimal? (
+ app-shells/fzf
+ media-video/mpv[lua]
+ net-misc/yt-dlp
+ thumbnails? (
+ || (
+ media-gfx/ueberzugpp
+ media-gfx/ueberzug
+ )
+ )
+ )"
+
+src_compile() { :; }
+
+src_install() {
+ local emakeargs=(
+ DESTDIR="${D}"
+ PREFIX="${EPREFIX}"/usr
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF}
+ )
+
+ emake "${emakeargs[@]}" addons doc install
+ einstalldocs
+
+ rm -r "${ED}"/usr/share/licenses || die
+}
+
+pkg_postinst() {
+ optfeature "external menu support" x11-misc/dmenu
+ optfeature "desktop notifications" x11-libs/libnotify
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "Note that ${PN} supports many methods to display menus/thumbnails."
+ elog "This ebuild primarily covers defaults and major features, additional"
+ elog "dependencies may be needed for others. Set USE=minimal if want full"
+ elog "control over optional dependencies (e.g. fzf is optional if use dmenu)."
+ fi
+}