summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-12-29 18:45:58 -0500
committerIonen Wolkens <ionen@gentoo.org>2021-12-29 19:15:57 -0500
commitc781bd6c988e76b21300a1d7c4a143ff1749ccd6 (patch)
treeae2d3720d5e55b910177a073edab8673b2efecaa /net-misc/ytfzf
parentnet-analyzer/pinger: further musl build fixes (diff)
downloadgentoo-c781bd6c988e76b21300a1d7c4a143ff1749ccd6.tar.gz
gentoo-c781bd6c988e76b21300a1d7c4a143ff1749ccd6.tar.bz2
gentoo-c781bd6c988e76b21300a1d7c4a143ff1749ccd6.zip
net-misc/ytfzf: add 2.0
The postinst elog about incompatibility may not very useful given this package hasn't existed in ::gentoo long yet, but may have some worth for people upgrading from an overlay install. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-misc/ytfzf')
-rw-r--r--net-misc/ytfzf/Manifest1
-rw-r--r--net-misc/ytfzf/ytfzf-2.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/net-misc/ytfzf/Manifest b/net-misc/ytfzf/Manifest
index 0bb9d14394f6..169ad433b577 100644
--- a/net-misc/ytfzf/Manifest
+++ b/net-misc/ytfzf/Manifest
@@ -1 +1,2 @@
DIST ytfzf-1.2.0_p20211208.tar.gz 3230303 BLAKE2B eb1cc05945bc91226d9a3f893edfcfcc5d8544ac2607d6bec7bfc5dd4a8f4b0c01e7387a73d82d148e908e727a1f2809765c9e21e13ca9e7de947c68c1a28f10 SHA512 f87dea2afb706ec9ea23fab3fa02833ddeff7261807f8e2e77471829fe05d293644c6b1d75660cbaae798cfdaede5553d1eabcf6b608a08a7a9d2de825ab92a2
+DIST ytfzf-2.0.tar.gz 3227372 BLAKE2B fa67fdc44174e1a0bbbf581f51fc0010230a6de37a38f54bd6c3b5dc1a8ae19790486db90ab0ab1f15fa1a70b544dd7888ec88c6f53ec5c2543235f64dc1ab94 SHA512 43c43b6a446335a7eef9d206864069df1e075d49151b359ead47de6e7234efc1042ce0557233e53c303d3c38572fd33a955e229c457561211250ddd0df5ccb0e
diff --git a/net-misc/ytfzf/ytfzf-2.0.ebuild b/net-misc/ytfzf/ytfzf-2.0.ebuild
new file mode 100644
index 000000000000..66efd3b37f84
--- /dev/null
+++ b/net-misc/ytfzf/ytfzf-2.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+DESCRIPTION="Posix script to find and watch youtube videos from the terminal"
+HOMEPAGE="https://github.com/pystardust/ytfzf/"
+SRC_URI="https://github.com/pystardust/ytfzf/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal"
+
+# fzf/mpv/yt-dlp "can" be optfeatures depending on configuration, but depend
+# on them so it works as expected out-of-the-box while allowing to disable.
+RDEPEND="
+ app-misc/jq
+ net-misc/curl[ssl]
+ !minimal? (
+ app-shells/fzf
+ media-video/mpv[lua]
+ net-misc/yt-dlp
+ )"
+
+src_compile() { :; }
+
+src_install() {
+ dobin ytfzf
+ doman docs/man/${PN}.{1,5}
+ dodoc README.md docs/conf.sh
+}
+
+pkg_postinst() {
+ optfeature "external menu support" x11-misc/dmenu
+ optfeature "in-terminal thumbnails on X11" media-gfx/ueberzug
+ optfeature "in-terminal thumbnails on wayland" media-gfx/chafa
+ optfeature "desktop notifications" x11-libs/libnotify
+
+ if [[ ${REPLACING_VERSIONS} ]] && ver_test ${REPLACING_VERSIONS} -lt 2.0; then
+ elog "Note that >=${PN}-2.0 is a major rewrite and is not compatible with"
+ elog "configuration and some command arguments of older versions, see the"
+ elog "newly added ${PN}(1) and ${PN}(5) man pages for more information."
+ fi
+}