summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/zssh
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/zssh')
-rw-r--r--net-misc/zssh/Manifest1
-rw-r--r--net-misc/zssh/files/zssh-1.5a-gentoo-include.diff11
-rw-r--r--net-misc/zssh/metadata.xml15
-rw-r--r--net-misc/zssh/zssh-1.5c-r1.ebuild46
4 files changed, 73 insertions, 0 deletions
diff --git a/net-misc/zssh/Manifest b/net-misc/zssh/Manifest
new file mode 100644
index 000000000000..000795dfacbe
--- /dev/null
+++ b/net-misc/zssh/Manifest
@@ -0,0 +1 @@
+DIST zssh-1.5c.tgz 344964 SHA256 a2e840f82590690d27ea1ea1141af509ee34681fede897e58ae8d354701ce71b SHA512 799ce3bbea5e94a800f61e6c38879746a579992396304861b7584b6bad967214b811b6bf9aecb36d9d60a15857377cb2fee80b495ad69778903fc45593efeebd WHIRLPOOL c0e8b06f04ccf0522267317308d4b87cf78eafd6fafaed1e330f9fec7b59561defd1a74652cc53ab2a662a299c021059fe49c1c252b50cb6dd6735086bf0333b
diff --git a/net-misc/zssh/files/zssh-1.5a-gentoo-include.diff b/net-misc/zssh/files/zssh-1.5a-gentoo-include.diff
new file mode 100644
index 000000000000..4fc670ac8055
--- /dev/null
+++ b/net-misc/zssh/files/zssh-1.5a-gentoo-include.diff
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Fri Sep 20 10:34:40 2002
++++ Makefile.in Fri Sep 20 10:34:56 2002
+@@ -19,7 +19,7 @@
+ AR = @AR@
+ RANLIB = @RANLIB@
+ CC = @CC@
+-CFLAGS = @CFLAGS@ @DEFS@ @EXTRA_CFLAGS@
++CFLAGS = @CFLAGS@ @DEFS@ @EXTRA_CFLAGS@ -I.
+ CPPFLAGS = @CPPFLAGS@
+ LIBS = @LIBS@ @EXTRA_LIBS@
+ LDFLAGS = @LDFLAGS@
diff --git a/net-misc/zssh/metadata.xml b/net-misc/zssh/metadata.xml
new file mode 100644
index 000000000000..39a20f0e4817
--- /dev/null
+++ b/net-misc/zssh/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>zlogene@gentoo.org</email>
+ <name>Mikle Kolyada</name>
+ </maintainer>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">zssh</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-misc/zssh/zssh-1.5c-r1.ebuild b/net-misc/zssh/zssh-1.5c-r1.ebuild
new file mode 100644
index 000000000000..f52dbbebfd18
--- /dev/null
+++ b/net-misc/zssh/zssh-1.5c-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="An ssh wrapper enabling zmodem up/download in ssh"
+HOMEPAGE="http://zssh.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc sparc x86"
+IUSE="nls readline"
+
+DEPEND="readline? (
+ sys-libs/ncurses
+ sys-libs/readline:0
+ )"
+RDEPEND="${DEPEND}
+ net-misc/openssh
+ net-dialup/lrzsz"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.5a-gentoo-include.diff"
+
+ # Fix linking with sys-libs/ncurses[tinfo], bug #527036
+ sed -i -e 's/-ltermcap/-ltinfo/g' configure || die
+
+ epatch_user
+}
+
+src_configure() {
+ tc-export AR CC RANLIB
+ econf \
+ $(use_enable nls) \
+ $(use_enable readline)
+}
+
+src_install() {
+ dobin ${PN} ztelnet
+ doman ${PN}.1 ztelnet.1
+ dodoc CHANGES FAQ README TODO
+}