summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-05-08 13:46:06 +0200
committerJeroen Roovers <jer@gentoo.org>2017-05-08 13:47:23 +0200
commit390309eca50d56f29f54440d1207d75bb89adb41 (patch)
treeca45cf02d554ef729d37d47c334ace022ecd0a38 /net-misc
parentdev-util/drone: Update snapshot (diff)
downloadgentoo-390309eca50d56f29f54440d1207d75bb89adb41.tar.gz
gentoo-390309eca50d56f29f54440d1207d75bb89adb41.tar.bz2
gentoo-390309eca50d56f29f54440d1207d75bb89adb41.zip
net-misc/youtube-dl: Version bump.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2017.05.07.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index 332996048dd1..7304840eb23b 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,3 +1,4 @@
DIST youtube-dl-2017.03.16.tar.gz 2631620 SHA256 55df3cbda9cf86e49baf54040340ec74c692bb3d6da3d2f5a1bc1238017dd492 SHA512 f3b8942f6b2be3b1cfd4bddfb74c17bad48c8ef4bea34114970ecb9d65b5a3dcbe71beba6d7c2dbda168371bbb2e8bbaddce58039bd9d158bf23950a2a88123c WHIRLPOOL 8345da00074e62ec9a9c244cb9ef64930fbd0e5e9e5bc1709bfcf56517cc6312031a09523c3016db2a1542c16a0297bea9d6883a201ae94e347e358307e92422
DIST youtube-dl-2017.04.26.tar.gz 2691549 SHA256 c320c8301a63ad97c099359c8b205d14c130b4f816dd92f0f5e68481628cfc47 SHA512 45b6e48828da72d4d014ba1605c94efbf7d082ad8527f49ec1333c4d7c210bcb64e68cbd140f505f318890693ed0b45c351d29344eb2162d00613674e60fbdb3 WHIRLPOOL a27b6944d033c9362c4891cc4d1ee8482383675378463f8a706cb9ba61d6245a4147ca7a4124d784aaebc585b052853bba645dec0e1b02446ebfc18af9c9fc97
DIST youtube-dl-2017.05.01.tar.gz 2698645 SHA256 58e2151634a66fa9ab4a98978fa72bf15990ec1c088ac7e4393cca00c9a32e53 SHA512 8a48dfb4b3d0f1cb24f9602fbe85e640fdec5c43d3aad87adec0dc3f4441852bfe1940e77bd1cf42f2a745ece9cbb08c8a1432128ae8ad7fa0f4be4351775c9e WHIRLPOOL 7d5330817166feb99de4c2776618186d804b16823d736ddc5e5887c9017e30022b8104a93dc9e701c03248e22217b66bcdb207b545783fc8e6cfc55576049f89
+DIST youtube-dl-2017.05.07.tar.gz 2714748 SHA256 45308c76b5e49b657ec7fa23b6b09e4d832355b54c86da79f09586b9664f6be0 SHA512 38a22c83a7f2d101a4afbee80d0c859dd37ad488b9e9bc22fb1043d8cae63ec063eaf880eafd066571e5d60e4778420b6113074cc55b323b0259657d5f5e8e54 WHIRLPOOL 5cc328da1181d8514d5dbdb126eb64d316b265baab7b2dee7eaa54383d4f4cc5fee1b57e84dcdc7933e6c98c03aafea9f46f4e35e4a5eaa018f66ba5eee20353
diff --git a/net-misc/youtube-dl/youtube-dl-2017.05.07.ebuild b/net-misc/youtube-dl/youtube-dl-2017.05.07.ebuild
new file mode 100644
index 000000000000..867867e73614
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2017.05.07.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="+offensive test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+python_prepare_all() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink camwithher chaturbate eporner
+ eroprofile extremetube fourtube foxgay goshgay hellporno
+ hentaistigma hornbunny keezmovies lovehomeporn mofosex motherless
+ myvidster porn91 porncom pornflip pornhd pornotube pornovoisines
+ pornoxo ruleporn sexu slutload spankbang spankwire sunporno thisav
+ tube8 vporn watchindianporn xbef xnxx xtube xvideos xxxymovies
+ youjizz youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ drtuber pornhub redtube tnaflix xhamster
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/completions
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+}