summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Juerges <aliens.satin0y@icloud.com>2022-06-10 17:45:34 +0100
committerSam James <sam@gentoo.org>2022-06-14 15:39:36 +0100
commit65161376f2f02556fa4f72e5fbaf491116de81c6 (patch)
treead8c0e13935bc6c7e499c08dac79f3b3bf28ae54 /net-misc
parentwww-client/seamonkey: Stabilize 2.53.12 amd64, #851636 (diff)
downloadgentoo-65161376f2f02556fa4f72e5fbaf491116de81c6.tar.gz
gentoo-65161376f2f02556fa4f72e5fbaf491116de81c6.tar.bz2
gentoo-65161376f2f02556fa4f72e5fbaf491116de81c6.zip
net-misc/omniORB: add 4.3.0
Closes: https://bugs.gentoo.org/846158 Signed-off-by: Thomas Juerges <aliens.satin0y@icloud.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/omniORB/Manifest1
-rw-r--r--net-misc/omniORB/metadata.xml5
-rw-r--r--net-misc/omniORB/omniORB-4.3.0.ebuild92
3 files changed, 97 insertions, 1 deletions
diff --git a/net-misc/omniORB/Manifest b/net-misc/omniORB/Manifest
index 875a1e7dc30f..55791e76cfe8 100644
--- a/net-misc/omniORB/Manifest
+++ b/net-misc/omniORB/Manifest
@@ -1 +1,2 @@
DIST omniORB-4.2.4.tar.bz2 2713397 BLAKE2B 5759b2563dca421b9a994bb13c30ce6dd98324a2357c4908130a42ce5baec357b881c22b4dff27809607ebde27e7cd65305a91aa5cbdb6d68a19df1f36524e72 SHA512 0b142b127175f16f844823e5adf5593b290528646e13a4c30f6cbd92d159d3998a81b952717039c3f0e386f79404ddd18a3de35fc45fa88383d1d9e51064d988
+DIST omniORB-4.3.0.tar.bz2 2762061 BLAKE2B f9103080011a7e683b7e63f6553e8a60947820a331d7c4e3559c961a7f36b17e235c5808e7b282d0227343e6e794106b9f2b93bf138b1a919716d1338e1c9cc2 SHA512 b081c1acbea3c7bee619a288fec209a0705b7d436f8e5fd4743675046356ef271a8c75882334fcbde4ff77d15f54d2da55f6cfcd117b01e42919d04fd29bfe2f
diff --git a/net-misc/omniORB/metadata.xml b/net-misc/omniORB/metadata.xml
index fb1b00f74288..f58b8859174e 100644
--- a/net-misc/omniORB/metadata.xml
+++ b/net-misc/omniORB/metadata.xml
@@ -1,7 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!--maintainer-needed-->
+ <maintainer type="person" proxied="yes">
+ <email>aliens.satin0y@icloud.com</email>
+ <name>Thomas Juerges</name>
+ </maintainer>
<upstream>
<remote-id type="sourceforge">omniorb</remote-id>
</upstream>
diff --git a/net-misc/omniORB/omniORB-4.3.0.ebuild b/net-misc/omniORB/omniORB-4.3.0.ebuild
new file mode 100644
index 000000000000..c8db25246d5a
--- /dev/null
+++ b/net-misc/omniORB/omniORB-4.3.0.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit python-single-r1
+
+MY_P="${P/_p/-}"
+DESCRIPTION="A robust, high-performance CORBA 2 ORB"
+HOMEPAGE="http://omniorb.sourceforge.net/"
+SRC_URI="mirror://sourceforge/omniorb/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2 GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ppc ppc64 ~sparc x86"
+IUSE="doc ipv6 ssl"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ ssl? ( dev-libs/openssl:0= )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ # The OPTC(XX)FLAGS variables aren't present in these files, but we
+ # will set them when we call emake.
+ sed \
+ -e 's/^CXXDEBUGFLAGS.*/CXXDEBUGFLAGS = $(OPTCXXFLAGS)/' \
+ -e 's/^CDEBUGFLAGS.*/CDEBUGFLAGS = $(OPTCFLAGS)/' \
+ -i mk/beforeauto.mk.in mk/unix.mk || \
+ die "failed to switch CFLAGS variables in the makefile includes"
+
+ # The out-of-source build is suggested by upstream.
+ mkdir build || die "failed to create build directory"
+}
+
+src_configure() {
+ cd build || die "failed to change into the build directory"
+
+ ECONF_SOURCE=".." econf \
+ --disable-static \
+ --with-omniORB-config=/etc/omniorb/omniORB.cfg \
+ --with-omniNames-logdir=/var/log/omniORB \
+ --libdir="/usr/$(get_libdir)" \
+ $(use_enable ipv6) \
+ $(use_with ssl openssl "/usr")
+}
+
+src_compile() {
+ cd build || die "failed to change into the build directory"
+ emake OPTCFLAGS="${CFLAGS}" OPTCXXFLAGS="${CXXFLAGS}"
+}
+
+src_install() {
+ cd build || die "failed to change into the build directory"
+ default
+
+ rm "${ED}/usr/bin/omniidlrun.py" || \
+ die "failed to remove redundant omniidlrun.py"
+
+ cd "${S}" || die "failed to change into the ${S} directory"
+
+ dodoc CREDITS doc/*.html ReleaseNotes.txt update.log
+ dodoc -r doc/omniORB
+
+ if use doc; then
+ dodoc doc/*.pdf
+ fi
+
+ cat <<- EOF > "${T}/90omniORB"
+ PATH="/usr/share/omniORB/bin/scripts"
+ OMNIORB_CONFIG="/etc/omniorb/omniORB.cfg"
+ EOF
+ doenvd "${T}/90omniORB"
+ doinitd "${FILESDIR}"/omniNames
+
+ cp "sample.cfg" "${T}/omniORB.cfg" || die
+ cat <<- EOF >> "${T}/omniORB.cfg"
+ # resolve the omniNames running on localhost
+ InitRef = NameService=corbaname::localhost
+ EOF
+ insinto /etc/omniorb
+ doins "${T}"/omniORB.cfg
+
+ keepdir /var/log/omniORB
+
+ python_optimize
+ python_fix_shebang "${ED}"/usr/bin/omniidl
+}