summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-05-28 12:22:15 -0400
committerAaron Bauman <bman@gentoo.org>2018-05-28 19:01:57 -0400
commit4270b232024ff6dc96ad21c609be5988253fc005 (patch)
treea258526fc532b4c0266ac2c2581694d74babc583 /net-p2p/dbhub
parentnet-misc/taptap: bump EAPI (diff)
downloadgentoo-4270b232024ff6dc96ad21c609be5988253fc005.tar.gz
gentoo-4270b232024ff6dc96ad21c609be5988253fc005.tar.bz2
gentoo-4270b232024ff6dc96ad21c609be5988253fc005.zip
net-p2p/dbhub: bump EAPI
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'net-p2p/dbhub')
-rw-r--r--net-p2p/dbhub/dbhub-0.451-r1.ebuild20
-rw-r--r--net-p2p/dbhub/files/dbhub-gentoo.patch4
-rw-r--r--net-p2p/dbhub/files/dbhub-no-dynaloader.patch4
3 files changed, 14 insertions, 14 deletions
diff --git a/net-p2p/dbhub/dbhub-0.451-r1.ebuild b/net-p2p/dbhub/dbhub-0.451-r1.ebuild
index 7b53906e3d64..167df3c1edba 100644
--- a/net-p2p/dbhub/dbhub-0.451-r1.ebuild
+++ b/net-p2p/dbhub/dbhub-0.451-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=2
-inherit autotools eutils
+EAPI=6
+inherit autotools
DESCRIPTION="Hub software for Direct Connect, fork of opendchub"
HOMEPAGE="http://www.dbhub.org"
@@ -18,10 +18,14 @@ DEPEND="perl? ( dev-lang/perl )
RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}/${PN}-gentoo.patch"
+ "${FILESDIR}/${PN}-no-dynaloader.patch"
+ "${FILESDIR}/${PN}-fix-buffer-overflows.patch"
+)
+
src_prepare() {
- epatch "${FILESDIR}"/${PN}-gentoo.patch \
- "${FILESDIR}"/${PN}-no-dynaloader.patch \
- "${FILESDIR}"/${PN}-fix-buffer-overflows.patch
+ default
eautoreconf
}
@@ -32,7 +36,3 @@ src_configure() {
$(use_enable switch_user) \
$(use_enable debug)
}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-}
diff --git a/net-p2p/dbhub/files/dbhub-gentoo.patch b/net-p2p/dbhub/files/dbhub-gentoo.patch
index 6e992cdb0129..509db33e61a9 100644
--- a/net-p2p/dbhub/files/dbhub-gentoo.patch
+++ b/net-p2p/dbhub/files/dbhub-gentoo.patch
@@ -1,5 +1,5 @@
---- configure.ac
-+++ configure.ac
+--- a/configure.ac
++++ b/configure.ac
@@ -115,7 +115,7 @@
AC_MSG_CHECKING([Perl LD Objs])
AC_MSG_RESULT([$perl_ldd])
diff --git a/net-p2p/dbhub/files/dbhub-no-dynaloader.patch b/net-p2p/dbhub/files/dbhub-no-dynaloader.patch
index 493b83a2943e..f71bb19a0a64 100644
--- a/net-p2p/dbhub/files/dbhub-no-dynaloader.patch
+++ b/net-p2p/dbhub/files/dbhub-no-dynaloader.patch
@@ -1,7 +1,7 @@
http://bugs.gentoo.org/276928
---- configure.ac
-+++ configure.ac
+--- a/configure.ac
++++ b/configure.ac
@@ -122,7 +122,6 @@
#endif
]])