summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2023-02-09 08:56:14 -0500
committerCraig Andrews <candrews@gentoo.org>2023-02-09 08:57:02 -0500
commit09c690dfb0e53f09d41d40906794d5350548d415 (patch)
tree698d6e28c88af580443c75ba74c61eae20b79543 /net-p2p
parentnet-libs/ngtcp2: add 0.13.1 (diff)
downloadgentoo-09c690dfb0e53f09d41d40906794d5350548d415.tar.gz
gentoo-09c690dfb0e53f09d41d40906794d5350548d415.tar.bz2
gentoo-09c690dfb0e53f09d41d40906794d5350548d415.zip
net-p2p/cpuminer-opt: add 3.21.1
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/cpuminer-opt/Manifest1
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-3.21.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/net-p2p/cpuminer-opt/Manifest b/net-p2p/cpuminer-opt/Manifest
index 6be87c58fe98..020dfb2d29e4 100644
--- a/net-p2p/cpuminer-opt/Manifest
+++ b/net-p2p/cpuminer-opt/Manifest
@@ -1,3 +1,4 @@
DIST cpuminer-opt-3.20.1.tar.gz 1857399 BLAKE2B db41052f1020069b26839d12b5ac64c0dba352cb752faee1be86edfc2d21958d4ddc726d2c91c2fd1b9b5d5f08336592fd31e1a92fc37424f0d9137c082d8322 SHA512 98412c233749c87bb9629087c87350b559209f59e3ee7921b764dc0bb631b3a018368f33b4cde84d16725d67ac460f49d0aab0e838597e55f1ba47f8032cb4da
DIST cpuminer-opt-3.20.3.tar.gz 1789988 BLAKE2B 97e6a4d6a12250cc50e678d0f3bf8dc154c30727d3a1b7ec4a4557a5af1e9bbf5c3d13f6f558aa9cd159c60f4482a3301f13cc1d8f86ef4f1c116d2eb8c8d52e SHA512 d14d148acd6e8e5a1247a64997ec6339f162f4343a2609c0188d4ee7c767e7a265af1555141ac657e43f73262391bf23f9ee26ec98c95ca837c42cd020e55d95
DIST cpuminer-opt-3.21.0.tar.gz 1794017 BLAKE2B 6a24575fba887d2dd58445233cb2461207451871cdbd95e61ebc89d4e164d36295bc98cd895cd3a9df2be553548ec9adbd9b55d958f27ef1780bbbf2b4e0b4fd SHA512 829e0febc70b6275be64c50502b9d261c6604b539d89b3f9e6aabdc5b54d557c80573e9885b09230d60dc25b8eb0df94e04e7165164b4691e6a81a653b4cbca3
+DIST cpuminer-opt-3.21.1.tar.gz 1791951 BLAKE2B 15137a43082f5538ac058cf5f8cf6834cd6452b3c397ab61bf2164c8859ea88de78ae73cc5533a94c050db25a2ccd777b224afd362c406e6458463c990abd259 SHA512 89f2fdbdefb27c6fbc45dab41eee7592378b0a518ef91977dabb812658b9bbdad01f5875e37cbee62fa25ee45f943f55092d89b2edd0c8196dc1566d758d3948
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-3.21.1.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-3.21.1.ebuild
new file mode 100644
index 000000000000..dd862b295bd0
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-3.21.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_sse2 curl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:=
+ dev-libs/jansson:=
+ >=net-misc/curl-7.15[ssl]
+ dev-libs/openssl:0=
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf --with-crypto --with-curl
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ doins cpuminer-conf.json
+}
+
+src_test() {
+ ./cpuminer --cputest || die
+}