summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2024-06-11 10:47:16 +0200
committerJohn Helmert III <ajak@gentoo.org>2024-06-27 12:22:58 -0700
commit31e7e74c41a01265c18a2549b9a80fc5cf2b5e7a (patch)
treed80f498347c775846adccb065a6a6eb56ff296c9 /net-p2p
parentapp-admin/conky: add 1.21.3 (diff)
downloadgentoo-31e7e74c41a01265c18a2549b9a80fc5cf2b5e7a.tar.gz
gentoo-31e7e74c41a01265c18a2549b9a80fc5cf2b5e7a.tar.bz2
gentoo-31e7e74c41a01265c18a2549b9a80fc5cf2b5e7a.zip
net-p2p/kubo: add 0.29.0
Signed-off-by: David Roman <davidroman96@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/37118 Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/kubo/Manifest1
-rw-r--r--net-p2p/kubo/kubo-0.29.0.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/net-p2p/kubo/Manifest b/net-p2p/kubo/Manifest
index afb3b7945563..0e82d8139fd9 100644
--- a/net-p2p/kubo/Manifest
+++ b/net-p2p/kubo/Manifest
@@ -1,2 +1,3 @@
DIST kubo-0.26.0.tar.gz 16129891 BLAKE2B 199e3fb3d7982eb3bca35c7139a15f4c4f32a54bde2c9ae2e5b594524668d146296001ccfb29d1ded5eec0e82a02b4e16a4bbb7a82bcc4787ee06820f02d4687 SHA512 21bcfd605d0aa0b55afafa5c717b6b0f8c657722a207ae0cb901815b7881266ae528acc85d74e70f5fafec9407c68cd5dcb2e02ab9fbe61c05f648888e15e0e5
DIST kubo-0.28.0.tar.gz 16070929 BLAKE2B f0febdee1e2313c83369c07b520fe285e10a73322d87f3891dd8edc97d6fa3d8dab7644d6108d060ef652fe34ed7cacf75f756e48f1e022d16b12bc30d298c0b SHA512 e6ef309084b8f09b56e5bceae37cf220c7e015003a8660f132d4e79709c7bd29ae8d8bb02736dab6a447b3acccc7dd0bd7043955df0a787a72fb3b9dfe9c42f5
+DIST kubo-0.29.0.tar.gz 16229764 BLAKE2B 91a6d322987bf7316f4acaf984ea57ea69617925e56adf4cee06be4d08a3a77f8f197aed42aa16cd438485df657de02cd647d3319c7c1afd09c0b8410fab30e6 SHA512 f23496452c3382629fddafce039acdff51c085280b15b807923bc4474b3ec540a39f9906ba7dcba621fef6237336ee2eb1bed10f81cac7a1dfccb21b7c3fecfb
diff --git a/net-p2p/kubo/kubo-0.29.0.ebuild b/net-p2p/kubo/kubo-0.29.0.ebuild
new file mode 100644
index 000000000000..0d66c3d3aeb2
--- /dev/null
+++ b/net-p2p/kubo/kubo-0.29.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module shell-completion systemd
+
+DESCRIPTION="Main implementation of IPFS"
+HOMEPAGE="https://ipfs.io/ https://github.com/ipfs/kubo/"
+SRC_URI="https://github.com/ipfs/${PN}/releases/download/v${PV}/kubo-source.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"
+
+LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 ISC MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ acct-group/ipfs
+ acct-user/ipfs
+ sys-fs/fuse:0
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md README.md docs/ )
+
+src_compile() {
+ local mygoargs
+ mygoargs=(
+ -tags release
+ )
+
+ ego build "${mygoargs[@]}" -o ipfs ./cmd/ipfs
+ ego build "${mygoargs[@]}" -o ipfswatch ./cmd/ipfswatch
+
+ IPFS_PATH="" ./ipfs commands completion bash > ipfs-completion.bash || die
+ IPFS_PATH="" ./ipfs commands completion fish > ipfs-completion.fish || die
+ IPFS_PATH="" ./ipfs commands completion zsh > ipfs-completion.zsh || die
+}
+
+src_test() {
+ ego test ./cmd/ipfs/... ./cmd/ipfswatch/...
+}
+
+src_install() {
+ dobin ipfs
+ dobin ipfswatch
+ newbashcomp ipfs-completion.bash ipfs
+ newfishcomp ipfs-completion.fish ipfs
+ newzshcomp ipfs-completion.zsh _ipfs
+ einstalldocs
+
+ systemd_dounit "${FILESDIR}/ipfs.service"
+ systemd_newunit "${FILESDIR}/ipfs-at.service" "ipfs@.service"
+
+ newinitd "${FILESDIR}/ipfs.init" ipfs
+ newconfd "${FILESDIR}/ipfs.confd" ipfs
+
+ keepdir /var/log/ipfs
+ fowners -R ipfs:ipfs /var/log/ipfs
+}
+
+pkg_postinst() {
+ elog 'To be able to use the ipfs service you will need to create the ipfs repository'
+ elog '(eg: su -s /bin/sh -c "ipfs init -e" ipfs)'
+ elog 'or change IPFS_PATH of /etc/conf.d/ipfs with another with proper permissions.'
+
+ # See https://bugs.gentoo.org/838238
+ ewarn 'In case kubo CPU usage is too high run the next workaround'
+ ewarn 'su -s /bin/sh -c "ipfs config profile apply lowpower" ipfs'
+ ewarn 'Be aware that this will make your node less visible to other peers'
+}