summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaolo Pedroni <paolo.pedroni@iol.it>2016-02-29 15:38:01 +0100
committerPaolo Pedroni <paolo.pedroni@iol.it>2016-02-29 15:38:01 +0100
commit65e9fb3ed91782ad6e03a001da4ba0a94371f474 (patch)
tree2caacf13688ec56617e03fa499e2181b5a591d5e /net-p2p
parentapp-text/libetonyek: Remove old (diff)
downloadgentoo-65e9fb3ed91782ad6e03a001da4ba0a94371f474.tar.gz
gentoo-65e9fb3ed91782ad6e03a001da4ba0a94371f474.tar.bz2
gentoo-65e9fb3ed91782ad6e03a001da4ba0a94371f474.zip
net-p2p/deluge: sync live ebuild with latest changes
Fixes bug #476382, #293513 and #518354
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/deluge/deluge-9999.ebuild46
1 files changed, 29 insertions, 17 deletions
diff --git a/net-p2p/deluge/deluge-9999.ebuild b/net-p2p/deluge/deluge-9999.ebuild
index 7aa1cdb941fc..41f5ba8550a0 100644
--- a/net-p2p/deluge/deluge-9999.ebuild
+++ b/net-p2p/deluge/deluge-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -25,38 +25,50 @@ fi
LICENSE="GPL-2"
SLOT="0"
IUSE="geoip gtk libnotify setproctitle sound webinterface"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
DEPEND=">=net-libs/rb_libtorrent-0.14.9[python]
+ dev-python/setuptools[${PYTHON_USEDEP}]
dev-util/intltool"
RDEPEND=">=net-libs/rb_libtorrent-0.14.9[python]
- dev-python/chardet
- dev-python/pyopenssl
- dev-python/pyxdg
- >=dev-python/twisted-core-8.1
- >=dev-python/twisted-web-8.1
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ >=dev-python/twisted-core-8.1[${PYTHON_USEDEP}]
+ >=dev-python/twisted-web-8.1[${PYTHON_USEDEP}]
geoip? ( dev-libs/geoip )
gtk? (
- sound? ( dev-python/pygame )
- dev-python/pygobject:2
- >=dev-python/pygtk-2.12
+ sound? ( dev-python/pygame[${PYTHON_USEDEP}] )
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ >=dev-python/pygtk-2.12[${PYTHON_USEDEP}]
gnome-base/librsvg
- libnotify? ( dev-python/notify-python )
+ libnotify? ( dev-python/notify-python[${PYTHON_USEDEP}] )
)
- setproctitle? ( dev-python/setproctitle )
- webinterface? ( dev-python/mako )"
+ setproctitle? ( dev-python/setproctitle[${PYTHON_USEDEP}] )
+ webinterface? ( dev-python/mako[${PYTHON_USEDEP}] )"
python_prepare_all() {
- local PATCHES=(
- "${FILESDIR}"/${PN}-1.3.5-disable_libtorrent_internal_copy.patch
- )
+# Not needed anymore: bug #518354
+# local PATCHES=(
+# "${FILESDIR}"/${PN}-1.3.5-disable_libtorrent_internal_copy.patch
+# )
distutils-r1_python_prepare_all
}
+_distutils-r1_create_setup_cfg() {
+ # bug 531370: deluge has its own plugin system. No need to relocate its egg info files.
+ # Override this call from the distutils-r1 eclass.
+ # This does not respect the distutils-r1 API. DONOT copy this example.
+ :
+}
+
python_install_all() {
distutils-r1_python_install_all
- newinitd "${FILESDIR}"/deluged.init deluged
- newconfd "${FILESDIR}"/deluged.conf deluged
+ newinitd "${FILESDIR}"/deluged.init-2 deluged
+ newconfd "${FILESDIR}"/deluged.conf-2 deluged
+ newinitd "${FILESDIR}"/deluge-web.init deluge-web
+ newconfd "${FILESDIR}"/deluge-web.conf deluge-web
systemd_dounit "${FILESDIR}"/deluged.service
systemd_dounit "${FILESDIR}"/deluge-web.service
}