summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam Wilson <sam@binarycake.ca>2024-07-10 17:33:42 -0400
committerJoonas Niilola <juippis@gentoo.org>2024-07-30 19:09:10 +0300
commit6b25229e2d5e439a2b7d6963e0277199463a698d (patch)
tree7e1c7fe643753a188873a0df2f432805836b0bc1 /net-p2p
parentnet-p2p/go-ethereum: add 1.14.6 (diff)
downloadgentoo-6b25229e2d5e439a2b7d6963e0277199463a698d.tar.gz
gentoo-6b25229e2d5e439a2b7d6963e0277199463a698d.tar.bz2
gentoo-6b25229e2d5e439a2b7d6963e0277199463a698d.zip
net-p2p/go-ethereum: fetch source from PPA
The go-ethereum team publishes the source of their dependencies to their Ubuntu PPA [^1][^2]. [^1]: https://launchpad.net/~ethereum/+archive/ubuntu/ethereum [^2]: https://geth.ethereum.org/docs/getting-started/installing-geth#ubuntu-via-ppas Signed-off-by: Sam Wilson <sam@binarycake.ca> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/go-ethereum/Manifest3
-rw-r--r--net-p2p/go-ethereum/go-ethereum-1.14.6.ebuild12
2 files changed, 11 insertions, 4 deletions
diff --git a/net-p2p/go-ethereum/Manifest b/net-p2p/go-ethereum/Manifest
index ff91f623aa82..bd8dc87f0585 100644
--- a/net-p2p/go-ethereum/Manifest
+++ b/net-p2p/go-ethereum/Manifest
@@ -2,5 +2,4 @@ DIST go-ethereum-1.10.18-deps.tar.xz 77657628 BLAKE2B fa4ebb250668489d6d72ac1284
DIST go-ethereum-1.10.18.tar.gz 13084436 BLAKE2B 4918f13b131796f928c17e6cbd3ab42095d4a52874865a2e9b9c6e8b8e4528af0152055c8d8556c795079bd2bc044e9a0fd028d4a90c66181c0cafddb41cf7ae SHA512 ba2b7091ac4ffd5bf02dbc27769ebd138b82dd9d79fb613e727f56f6cfaf969183f343511478e88fbead627141101e77206a4c2449b0ced9a7a2090b4c77d996
DIST go-ethereum-1.13.14-deps.tar.xz 70373740 BLAKE2B 6bc403f85e024fdeeab8f41ef7f2940cceee11b8f6a1f97dc53cc5dda997f3c97ddcaefac61df196508f00fe61152f21bedc8de9e380fa91245a049c0a93ab58 SHA512 0d6cc6b846dab05acabfa0fc840f2db450a3138f863bf3f99ef83040071260a42fa2dccb88877a0d340e2532241653c32efb783bc67698f316ab1c9291d75330
DIST go-ethereum-1.13.14.tar.gz 13500798 BLAKE2B f5cf0c3f72aedc7d149c5342c2edbcb4310301b4c9b164d65e1e281b8db78c79ca884e9cb41ecd72ed6fbbed34e198cb13fe7cc726856c9f323a4aacc4a2dc17 SHA512 80a410dbeb06e8a46bd5b4e962fcf030fa8787eef192dbcd01c3d98bf31e822a8c3b92c35251876e122eac3fad707faf95b5e5c0baed8e29aa024c856b6f54bc
-DIST go-ethereum-1.14.6-deps.tar.xz 175532036 BLAKE2B e70c06efb1c480e65c56f2bd7dadff18cffc8a31bb3f74994110dda6fccf769d95bf83560e606e443590eb981abcd4dd2108185414cdf68af77911252200e9c0 SHA512 ba18e585e69b7623f8277abffaaf762e0f1c35280e32b6fa7e44185f22324618bb8c2793508e648d21d7f366a2694c70384166d11fe79a1e863b209f4a065601
-DIST go-ethereum-1.14.6.tar.gz 13978474 BLAKE2B eafc01fdc2a98a7b271c5604bdb627e1fb0d72afefa03f1f677d62b5f210de240d9acb00166629071d6862d1df94bf46709f86f91a979a319e2c27feee4f9acb SHA512 8b9b887bf2d3c620079a6f92c347a57a9aec657353edbaeb74be0333e96631704f45fd7bdcd428f05de0a72963e10e0f85b51b93af224ff28c46b19eaee3fa71
+DIST go-ethereum-1.14.6.tar.xz 167669208 BLAKE2B 50aaf684de802dc7ad0a5ce71d1235d938ea6755f41cc3b5af2eb854567e1c11bd5f76f9d8dcd6cfe0263a0da529740149d2248b8a8e3a0d2774790545813b04 SHA512 cbbb7b491252efe2a8dbaf49d029e9d30384f73a9a83594827ff8dcec7ffc2952ddbf46d42acc07b939e89a4e65ee9392514e430856f5014fcb5dfa302e15e6b
diff --git a/net-p2p/go-ethereum/go-ethereum-1.14.6.ebuild b/net-p2p/go-ethereum/go-ethereum-1.14.6.ebuild
index f5562b6dbf14..2d6599e04f20 100644
--- a/net-p2p/go-ethereum/go-ethereum-1.14.6.ebuild
+++ b/net-p2p/go-ethereum/go-ethereum-1.14.6.ebuild
@@ -5,10 +5,13 @@ EAPI=8
inherit go-module
+LONG_VERSION="${PV}+build30044+noble"
DESCRIPTION="Official golang implementation of the Ethereum protocol"
HOMEPAGE="https://github.com/ethereum/go-ethereum"
-SRC_URI="https://github.com/ethereum/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+SRC_URI="https://ppa.launchpadcontent.net/ethereum/ethereum/ubuntu/pool/main/e/ethereum/ethereum_${LONG_VERSION}.tar.xz -> ${P}.tar.xz"
+# Above PPA is listed as an official source here:
+# https://geth.ethereum.org/docs/getting-started/installing-geth#ubuntu-via-ppas
+S="${WORKDIR}/ethereum-${LONG_VERSION}"
LICENSE="GPL-3+ LGPL-3+"
SLOT="0"
@@ -18,6 +21,11 @@ IUSE="devtools"
# Does all kinds of wonky stuff like connecting to Docker daemon, network activity, ...
RESTRICT+=" test"
+src_unpack() {
+ default
+ mv "${S}/.mod" "${WORKDIR}/go-mod" || die
+}
+
src_compile() {
emake $(usex devtools all geth)
}