summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2018-10-09 08:45:50 -0500
committerBen Kohler <bkohler@gentoo.org>2018-10-09 08:45:50 -0500
commit8c537ceacee34afc593a7dff3224db4131193f5a (patch)
treeb63c1c2ba8490a7ac721d9e1b34f95dab42f9399 /net-proxy/tinyproxy/tinyproxy-1.10.0-r1.ebuild
parentnet-proxy/tinyproxy: fix whitespace on 1.10.0 (diff)
downloadgentoo-8c537ceacee34afc593a7dff3224db4131193f5a.tar.gz
gentoo-8c537ceacee34afc593a7dff3224db4131193f5a.tar.bz2
gentoo-8c537ceacee34afc593a7dff3224db4131193f5a.zip
net-proxy/tinyproxy: revbump for changed paths in service files
Signed-off-by: Ben Kohler <bkohler@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'net-proxy/tinyproxy/tinyproxy-1.10.0-r1.ebuild')
-rw-r--r--net-proxy/tinyproxy/tinyproxy-1.10.0-r1.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/net-proxy/tinyproxy/tinyproxy-1.10.0-r1.ebuild b/net-proxy/tinyproxy/tinyproxy-1.10.0-r1.ebuild
new file mode 100644
index 000000000000..bb01f6269077
--- /dev/null
+++ b/net-proxy/tinyproxy/tinyproxy-1.10.0-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools systemd tmpfiles user
+
+DESCRIPTION="A lightweight HTTP/SSL proxy"
+HOMEPAGE="https://github.com/tinyproxy/tinyproxy/"
+SRC_URI="https://github.com/tinyproxy/tinyproxy/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+
+IUSE="test debug +filter-proxy reverse-proxy transparent-proxy
++upstream-proxy +xtinyproxy-header"
+
+REQUIRED_USE="test? ( xtinyproxy-header )"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} "" "" "" ${PN}
+}
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "s|nobody|${PN}|g" \
+ etc/${PN}.conf.in || die "sed failed"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable filter-proxy filter) \
+ $(use_enable reverse-proxy reverse) \
+ $(use_enable transparent-proxy transparent) \
+ $(use_enable upstream-proxy upstream) \
+ $(use_enable xtinyproxy-header xtinyproxy) \
+ --disable-silent-rules \
+ --localstatedir=/var
+}
+
+src_test() {
+ # The make check target does not run the test suite
+ emake test
+}
+
+src_install() {
+ default
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ diropts -m0775 -o ${PN} -g ${PN}
+ keepdir /var/log/${PN}
+
+ newinitd "${FILESDIR}"/${PN}-1.10.0.initd tinyproxy
+ systemd_dounit "${FILESDIR}"/${PN}-1.10.0.service
+ systemd_dotmpfilesd "${FILESDIR}"/${PN}.tmpfiles.conf
+}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.tmpfiles.conf
+
+ elog "For filtering domains and URLs, enable filter option in the configuration"
+ elog "file and add them to the filter file (one domain or URL per line)."
+}