summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKenton Groombridge <concord@gentoo.org>2022-07-03 14:37:42 -0400
committerKenton Groombridge <concord@gentoo.org>2022-07-03 15:17:44 -0400
commit46e059e4c3b8048e0ff2f3a50647d6c49d0f9226 (patch)
tree672d88617ee503366e27fbad20bba16c6af8cfa8 /net-voip
parentnet-voip/mumble: install included samples (diff)
downloadgentoo-46e059e4c3b8048e0ff2f3a50647d6c49d0f9226.tar.gz
gentoo-46e059e4c3b8048e0ff2f3a50647d6c49d0f9226.tar.bz2
gentoo-46e059e4c3b8048e0ff2f3a50647d6c49d0f9226.zip
net-voip/mumble: append -fsigned-char to CXXFLAGS
This fixes tests (and possibly runtime issues) on arches with unsigned chars. Bug: https://bugs.gentoo.org/832978 Signed-off-by: Kenton Groombridge <concord@gentoo.org>
Diffstat (limited to 'net-voip')
-rw-r--r--net-voip/mumble/mumble-1.4.230-r2.ebuild6
-rw-r--r--net-voip/mumble/mumble-9999.ebuild6
2 files changed, 10 insertions, 2 deletions
diff --git a/net-voip/mumble/mumble-1.4.230-r2.ebuild b/net-voip/mumble/mumble-1.4.230-r2.ebuild
index 50d5964ae8fe..ee18ba0d74f9 100644
--- a/net-voip/mumble/mumble-1.4.230-r2.ebuild
+++ b/net-voip/mumble/mumble-1.4.230-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake xdg
+inherit cmake flag-o-matic xdg
DESCRIPTION="Mumble is an open source, low-latency, high quality voice chat software"
HOMEPAGE="https://wiki.mumble.info"
@@ -110,6 +110,10 @@ src_configure() {
mycmakeargs+=( -DBUILD_NUMBER="$(ver_cut 3)" )
fi
+ # https://bugs.gentoo.org/832978
+ # fix tests (and possibly runtime issues) on arches with unsigned chars
+ append-cxxflags -fsigned-char
+
cmake_src_configure
}
diff --git a/net-voip/mumble/mumble-9999.ebuild b/net-voip/mumble/mumble-9999.ebuild
index 8973f0ef46ff..cbe94df0b160 100644
--- a/net-voip/mumble/mumble-9999.ebuild
+++ b/net-voip/mumble/mumble-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake xdg
+inherit cmake flag-o-matic xdg
DESCRIPTION="Mumble is an open source, low-latency, high quality voice chat software"
HOMEPAGE="https://wiki.mumble.info"
@@ -106,6 +106,10 @@ src_configure() {
mycmakeargs+=( -DBUILD_NUMBER="$(ver_cut 3)" )
fi
+ # https://bugs.gentoo.org/832978
+ # fix tests (and possibly runtime issues) on arches with unsigned chars
+ append-cxxflags -fsigned-char
+
cmake_src_configure
}