summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-30 23:58:22 +0100
committerSam James <sam@gentoo.org>2021-07-31 00:30:13 +0100
commitaac398a2b8da81e0d9ab2558e297cf0b293d8c09 (patch)
tree6516efca57f9b5e0f2519f0661f9f29f96d9f8b0 /net-vpn/tailscale
parentnet-nds/openldap: [QA] call tmpfiles_process in pkg_postinst (diff)
downloadgentoo-aac398a2b8da81e0d9ab2558e297cf0b293d8c09.tar.gz
gentoo-aac398a2b8da81e0d9ab2558e297cf0b293d8c09.tar.bz2
gentoo-aac398a2b8da81e0d9ab2558e297cf0b293d8c09.zip
net-vpn/tailscale: [QA] call tmpfiles_process in pkg_postinst
This is needed to actually apply the tmpfiles configuration we've installed in the ebuild. See tmpfiles.eclass documentation. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-vpn/tailscale')
-rw-r--r--net-vpn/tailscale/tailscale-1.10.0.ebuild4
-rw-r--r--net-vpn/tailscale/tailscale-1.2.10-r1.ebuild6
-rw-r--r--net-vpn/tailscale/tailscale-1.4.0.ebuild6
-rw-r--r--net-vpn/tailscale/tailscale-1.4.1.ebuild6
-rw-r--r--net-vpn/tailscale/tailscale-1.4.5.ebuild6
-rw-r--r--net-vpn/tailscale/tailscale-1.8.7.ebuild4
6 files changed, 28 insertions, 4 deletions
diff --git a/net-vpn/tailscale/tailscale-1.10.0.ebuild b/net-vpn/tailscale/tailscale-1.10.0.ebuild
index ea23773ccebe..e19f4d2e8726 100644
--- a/net-vpn/tailscale/tailscale-1.10.0.ebuild
+++ b/net-vpn/tailscale/tailscale-1.10.0.ebuild
@@ -1024,3 +1024,7 @@ src_install() {
newinitd "${FILESDIR}/${PN}d.initd" ${PN}
newconfd "${FILESDIR}/${PN}d.confd" ${PN}
}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+}
diff --git a/net-vpn/tailscale/tailscale-1.2.10-r1.ebuild b/net-vpn/tailscale/tailscale-1.2.10-r1.ebuild
index 15d91103c2fa..98c2720f0238 100644
--- a/net-vpn/tailscale/tailscale-1.2.10-r1.ebuild
+++ b/net-vpn/tailscale/tailscale-1.2.10-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020 Gentoo Authors
+# Copyright 2020-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -253,3 +253,7 @@ src_install() {
newinitd "${FILESDIR}/${PN}d.initd" ${PN}
newconfd "${FILESDIR}/${PN}d.confd" ${PN}
}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+}
diff --git a/net-vpn/tailscale/tailscale-1.4.0.ebuild b/net-vpn/tailscale/tailscale-1.4.0.ebuild
index 69a4661f9fad..94bf9df62b6e 100644
--- a/net-vpn/tailscale/tailscale-1.4.0.ebuild
+++ b/net-vpn/tailscale/tailscale-1.4.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020 Gentoo Authors
+# Copyright 2020-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -628,3 +628,7 @@ src_install() {
newinitd "${FILESDIR}/${PN}d.initd" ${PN}
newconfd "${FILESDIR}/${PN}d.confd" ${PN}
}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+}
diff --git a/net-vpn/tailscale/tailscale-1.4.1.ebuild b/net-vpn/tailscale/tailscale-1.4.1.ebuild
index ad7708552184..f1c534c69b6c 100644
--- a/net-vpn/tailscale/tailscale-1.4.1.ebuild
+++ b/net-vpn/tailscale/tailscale-1.4.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020 Gentoo Authors
+# Copyright 2020-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -628,3 +628,7 @@ src_install() {
newinitd "${FILESDIR}/${PN}d.initd" ${PN}
newconfd "${FILESDIR}/${PN}d.confd" ${PN}
}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+}
diff --git a/net-vpn/tailscale/tailscale-1.4.5.ebuild b/net-vpn/tailscale/tailscale-1.4.5.ebuild
index 471f008a1171..120700e29cbf 100644
--- a/net-vpn/tailscale/tailscale-1.4.5.ebuild
+++ b/net-vpn/tailscale/tailscale-1.4.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020 Gentoo Authors
+# Copyright 2020-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -628,3 +628,7 @@ src_install() {
newinitd "${FILESDIR}/${PN}d.initd" ${PN}
newconfd "${FILESDIR}/${PN}d.confd" ${PN}
}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+}
diff --git a/net-vpn/tailscale/tailscale-1.8.7.ebuild b/net-vpn/tailscale/tailscale-1.8.7.ebuild
index d258d5895192..7b4248c4540b 100644
--- a/net-vpn/tailscale/tailscale-1.8.7.ebuild
+++ b/net-vpn/tailscale/tailscale-1.8.7.ebuild
@@ -307,3 +307,7 @@ src_install() {
newinitd "${FILESDIR}/${PN}d.initd" ${PN}
newconfd "${FILESDIR}/${PN}d.confd" ${PN}
}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+}