summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2024-06-12 17:20:27 +0200
committerJason Zaman <perfinion@gentoo.org>2024-07-05 15:29:21 -0700
commit5bc1e26e89408440f0220da0afdee82e4476e153 (patch)
treeb7e65ca0ef539251bce8028d517f0a82a0c104ea /sci-astronomy
parentsci-astronomy/siril: drop 1.2.0 (diff)
downloadgentoo-5bc1e26e89408440f0220da0afdee82e4476e153.tar.gz
gentoo-5bc1e26e89408440f0220da0afdee82e4476e153.tar.bz2
gentoo-5bc1e26e89408440f0220da0afdee82e4476e153.zip
sci-astronomy/sirilic: enable py3.12
Closes: https://github.com/gentoo/gentoo/pull/37132 Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/sirilic/sirilic-1.15.8-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/sci-astronomy/sirilic/sirilic-1.15.8-r1.ebuild b/sci-astronomy/sirilic/sirilic-1.15.8-r1.ebuild
new file mode 100644
index 000000000000..dd5dcb825cc7
--- /dev/null
+++ b/sci-astronomy/sirilic/sirilic-1.15.8-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1
+
+DESCRIPTION="Preparing acquisition files for processing with the SiriL software"
+HOMEPAGE="https://gitlab.com/free-astro/sirilic"
+SRC_URI="https://gitlab.com/free-astro/sirilic/-/archive/V${PV}/${PN}-V${PV}.tar.bz2"
+S="${WORKDIR}/${PN}-V${PV}"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/wxpython-4.2:4.0[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"