summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-08-11 21:38:02 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-08-11 21:41:02 +0300
commit6bdac1509dc3d76a5f3f1742c34bab60bbaf10cf (patch)
treeaeecd931fd994a4fb7a0ae8d4416c73d6a408762 /sci-astronomy
parentgames-emulation/dolphin: Require <dev-libs/libfmt-10 (diff)
downloadgentoo-6bdac1509dc3d76a5f3f1742c34bab60bbaf10cf.tar.gz
gentoo-6bdac1509dc3d76a5f3f1742c34bab60bbaf10cf.tar.bz2
gentoo-6bdac1509dc3d76a5f3f1742c34bab60bbaf10cf.zip
sci-astronomy/funtools: fix direct CC, missing LDFLAGS, bad docs
Closes: https://bugs.gentoo.org/930757 Closes: https://bugs.gentoo.org/930760 Closes: https://bugs.gentoo.org/930759 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/funtools/funtools-1.4.8-r1.ebuild (renamed from sci-astronomy/funtools/funtools-1.4.8.ebuild)7
1 files changed, 4 insertions, 3 deletions
diff --git a/sci-astronomy/funtools/funtools-1.4.8.ebuild b/sci-astronomy/funtools/funtools-1.4.8-r1.ebuild
index c7ba18476c52..ae1f275205f0 100644
--- a/sci-astronomy/funtools/funtools-1.4.8.ebuild
+++ b/sci-astronomy/funtools/funtools-1.4.8-r1.ebuild
@@ -16,7 +16,7 @@ IUSE="doc static-libs"
RDEPEND="
dev-lang/tcl:0=
- sci-astronomy/wcstools:0=
+ sci-astronomy/wcstools
sci-visualization/gnuplot
sys-libs/zlib:0=
"
@@ -31,6 +31,7 @@ src_prepare() {
-e '/^SUBLIBS/s|wcs||g' \
-e 's/mkdir/mkdir -p/g' \
-e '/mklib/s|-o $(PACKAGE)|-o $(PACKAGE) $(LIBS)|g' \
+ -e 's|./mklib|& -linker "$(CC)" -ldflags "$(LDFLAGS)"|' \
-e "s| ar| $(tc-getAR)|g" \
-e "s|ar cruv|$(tc-getAR) cruv|g" \
-e "s|WCS_INC.*=.*|WCS_INC = $($(tc-getPKG_CONFIG) --cflags wcstools)|g" \
@@ -71,11 +72,11 @@ src_install() {
|| die
if use doc; then
- dodoc doc/*.pdf doc/*html doc/*c \
+ dodoc doc/*.pdf doc/*html doc/*c
docompress -x /usr/share/doc/${PF}/*.c
fi
if ! use static-libs; then
- find "${ED}" -name "*.a" -delete || die
+ find "${ED}" -name "*.a" -type f -delete || die
fi
}