summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-02-14 11:33:00 +0100
committerDavid Seifert <soap@gentoo.org>2021-02-14 11:33:00 +0100
commitd7ea913e51ebff7b8a80c8cac74a9ce7855e6f73 (patch)
treed043db6134ee61e07e3d5d3f4df6f446e67c703f /sci-astronomy
parentnet-print/mtink: Fix build issues (diff)
downloadgentoo-d7ea913e51ebff7b8a80c8cac74a9ce7855e6f73.tar.gz
gentoo-d7ea913e51ebff7b8a80c8cac74a9ce7855e6f73.tar.bz2
gentoo-d7ea913e51ebff7b8a80c8cac74a9ce7855e6f73.zip
sci-astronomy/swarp: Bump to 2.41.5
* Fixes gcc-10 issues and AR call Closes: https://bugs.gentoo.org/707856 Closes: https://bugs.gentoo.org/725274 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/swarp/Manifest1
-rw-r--r--sci-astronomy/swarp/metadata.xml3
-rw-r--r--sci-astronomy/swarp/swarp-2.41.5.ebuild34
3 files changed, 38 insertions, 0 deletions
diff --git a/sci-astronomy/swarp/Manifest b/sci-astronomy/swarp/Manifest
index 0f01ec9b2be7..017cb5129a19 100644
--- a/sci-astronomy/swarp/Manifest
+++ b/sci-astronomy/swarp/Manifest
@@ -1 +1,2 @@
DIST swarp-2.38.0.tar.gz 2063462 BLAKE2B 589429b714d3e0bec78a613285f09422f7aa53093436bb6c9215bdff87ac701558d6e76438c1efc773f17b595ea9f3c50b7f70c1f1b38dfad759a10df5b5d528 SHA512 80f4ade59738df3d4c9b47bda04148b53c6ba995d523fa8d1e02fb5d952b6078a53cc7d273849a033505de127a4f318b95adf2bf5a2dc38e8cc9bdaf5658487a
+DIST swarp-2.41.5.tar.gz 444035 BLAKE2B a76f9a68c9668c33f578262ec360234f2aebd5fe1ac1708c57819d63b3d4c70fbaa8442b1d025811d024321cb580a212854049ecba53a714cc84e4c7f20334ba SHA512 f397abb9c1a8a22c3bde2d1f5337492f8264df3bb43d4e263dbf175c8845d8cfea44bdfc977f2481ae8a1644722a56c82b818d40e4539d9f895fd91718d8aafe
diff --git a/sci-astronomy/swarp/metadata.xml b/sci-astronomy/swarp/metadata.xml
index 4f4367037c18..57aacfb6f10e 100644
--- a/sci-astronomy/swarp/metadata.xml
+++ b/sci-astronomy/swarp/metadata.xml
@@ -5,4 +5,7 @@
<email>sci-astronomy@gentoo.org</email>
<name>Gentoo Astronomy Project</name>
</maintainer>
+ <use>
+ <flag name="cfitsio">Link with <pkg>sci-libs/cfitsio</pkg></flag>
+ </use>
</pkgmetadata>
diff --git a/sci-astronomy/swarp/swarp-2.41.5.ebuild b/sci-astronomy/swarp/swarp-2.41.5.ebuild
new file mode 100644
index 000000000000..87ae8276154d
--- /dev/null
+++ b/sci-astronomy/swarp/swarp-2.41.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Resample and coadd astronomical FITS images"
+HOMEPAGE="http://www.astromatic.net/software/swarp"
+SRC_URI="https://github.com/astromatic/swarp/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cfitsio doc threads"
+
+RDEPEND="cfitsio? ( sci-libs/cfitsio )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with cfistio) \
+ $(use_enable threads)
+}
+
+src_install() {
+ default
+ use doc && dodoc -r doc/.
+}