summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2024-06-24 23:36:58 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-06-29 17:18:18 +0300
commitea02b0311a94fa2d98f4e30698d39205a39112a3 (patch)
tree92b0a195791548d91b67cb691747942553217bb8 /sci-astronomy
parentsec-keys/openpgp-keys-jiatan: treeclean (diff)
downloadgentoo-ea02b0311a94fa2d98f4e30698d39205a39112a3.tar.gz
gentoo-ea02b0311a94fa2d98f4e30698d39205a39112a3.tar.bz2
gentoo-ea02b0311a94fa2d98f4e30698d39205a39112a3.zip
sci-astronomy/scamp: add 2.10.0
Bug: https://bugs.gentoo.org/934756 Closes: https://bugs.gentoo.org/924303 Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/scamp/Manifest1
-rw-r--r--sci-astronomy/scamp/files/scamp-2.10.0-spread_bits64.patch18
-rw-r--r--sci-astronomy/scamp/scamp-2.10.0.ebuild50
3 files changed, 69 insertions, 0 deletions
diff --git a/sci-astronomy/scamp/Manifest b/sci-astronomy/scamp/Manifest
index aff93ed5068a..f30f685620df 100644
--- a/sci-astronomy/scamp/Manifest
+++ b/sci-astronomy/scamp/Manifest
@@ -1 +1,2 @@
DIST scamp-2.0.4.tar.gz 4876618 BLAKE2B 4dc513bee48ec0c3bc8e90febc46e86d78f59a78fdbca0ee3efd2c0d39b5b32f2c4fb8655b3d4be74ca211deafb16645c295dd272c8fa9c426ba82ab1b97f36a SHA512 ed0a824ddcc3f9c791121323bb59969e89f509a2c429c0abb45655e6852bc452bd46c539dbebfd23097af1c7dbef9d3d905030083828974f75233ea4af4484d5
+DIST scamp-2.10.0.tar.gz 56354286 BLAKE2B b31d292413160f85f8086d848d81f36adde3bc560c737adfe77245d23eb6eab19e5f73a343669b462453542a140d89fb3d12b5d6a481949205722c6e2f5234cd SHA512 7c7a4ab167a3c03b7fd862f39ccd9368d6ac31270a86b336f1ee2a52f8e4324e29e6324047416159c0b73bb54b05f12b7b70c2de3cb4197999cb848fc5ce4c0d
diff --git a/sci-astronomy/scamp/files/scamp-2.10.0-spread_bits64.patch b/sci-astronomy/scamp/files/scamp-2.10.0-spread_bits64.patch
new file mode 100644
index 000000000000..e126dc6e8c79
--- /dev/null
+++ b/sci-astronomy/scamp/files/scamp-2.10.0-spread_bits64.patch
@@ -0,0 +1,18 @@
+--- a/src/chealpix.c
++++ b/src/chealpix.c
+@@ -532,7 +532,6 @@
+ return (long) res;
+ }
+
+-#ifndef __BMI2__
+ static int64_t spread_bits64(int v) {
+ return (int64_t) (utab[v & 0xff])
+ | ((int64_t) (utab[(v >> 8) & 0xff]) << 16)
+@@ -548,6 +547,7 @@
+ | (ctab[(raw >> 40) & 0xff] << 20);
+ }
+
++#ifndef __BMI2__
+ static int64_t xyf2nest64(int64_t nside, int ix, int iy, int face_num) {
+ return (face_num * nside * nside) + spread_bits64(ix)
+ + (spread_bits64(iy) << 1);
diff --git a/sci-astronomy/scamp/scamp-2.10.0.ebuild b/sci-astronomy/scamp/scamp-2.10.0.ebuild
new file mode 100644
index 000000000000..d64241c9cb76
--- /dev/null
+++ b/sci-astronomy/scamp/scamp-2.10.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Astrometric and photometric solutions for astronomical images"
+HOMEPAGE="http://www.astromatic.net/software/scamp https://github.com/astromatic/scamp"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/astromatic/${PN}.git"
+else
+ SRC_URI="https://github.com/astromatic/scamp/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="plplot threads"
+
+RDEPEND="
+ sci-astronomy/cdsclient
+ sci-libs/atlas[lapack,threads=]
+ sci-libs/fftw:3.0
+ plplot? ( sci-libs/plplot:= )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.10.0-spread_bits64.patch"
+)
+
+src_prepare() {
+ default
+
+ sed -e "s/lapack_atlas/atlclapack/g" -i m4/acx_atlas.m4 || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-atlas-incdir="${EPREFIX}/usr/include/atlas"
+ $(use_enable plplot)
+ $(use_enable threads)
+ )
+
+ econf "${myeconfargs[@]}"
+}