summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@gentoo.org>2024-07-22 21:54:35 -0400
committerEli Schwartz <eschwartz@gentoo.org>2024-07-22 23:32:33 -0400
commitf3c5431cca1dc92d84e699248aa3bd1a7820031a (patch)
tree95142a780056e54c829023d8b6d4ab8abf79c6df /sci-astronomy
parentsci-astronomy/wcslib: use ver_cut to produce SLOT (diff)
downloadgentoo-f3c5431cca1dc92d84e699248aa3bd1a7820031a.tar.gz
gentoo-f3c5431cca1dc92d84e699248aa3bd1a7820031a.tar.bz2
gentoo-f3c5431cca1dc92d84e699248aa3bd1a7820031a.zip
sci-astronomy/wcslib: add 8.3
The big documented change w.r.t. fortran wrappers is the implementation of my bug report regarding LTO. There is now a configure option which enables the use of BIND(C) to be compatible with Fortan <-> C. As such, the filter-lto can be removed. Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/wcslib/Manifest1
-rw-r--r--sci-astronomy/wcslib/wcslib-8.3.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/sci-astronomy/wcslib/Manifest b/sci-astronomy/wcslib/Manifest
index 72b89b7ef156..0d7ad7558a57 100644
--- a/sci-astronomy/wcslib/Manifest
+++ b/sci-astronomy/wcslib/Manifest
@@ -3,3 +3,4 @@ DIST wcslib-7.12.tar.bz2 2989693 BLAKE2B 8070cdddb9e89478464443411d165706d44593e
DIST wcslib-7.3.1.tar.bz2 2434274 BLAKE2B 9789a8eb34fe37c96b52e20efe3c14368499058e5c46aad4853b2be5f32a31df26525ec2c38d0ce87bcb7891b91a3ec3ac537e3c662c716a7c4381f26cd715e4 SHA512 753e0e202fb4250d321c36a0df9cd45ed88697111a06e108bc3e5397ddecc60d460cda2b4d45b5311dd72b88b66d4c70ff150b03e2da46c834b024f15304779b
DIST wcslib-7.3.tar.bz2 2435669 BLAKE2B c0f641b4c2fdd9d332816195f399eb2ab3c5aa585f08c4857af77bd5ed4074e653663f7cbddc6d7678cd85bed2c0bd95719cd83a5138d21ad24841396d4c11b9 SHA512 8c98c4b575056e2d966b77a4bc951256d02ecee3a11847e140fd38d93afd0f76b3e906d590c952dc9fc58ceeb1ba062b19d8e1e676ee0032f5b7ed13a9dfa892
DIST wcslib-8.2.2.tar.bz2 3187577 BLAKE2B cd75652eac5777bce4a66ea1de03796b12c77f7269c6050eda95518d28a17be2ad8ae46b57e0a21f8d03dcf3a0144316d06d16aac7a37a42150e713113cc7edc SHA512 cf540fdac03d2868902c9d4c2f1cd5919e878e79de635b01006b61f4d95f727659033d0d05172a7bcd00287ecc395609a643cf95a6498fbc3ff2d3fb26c136b4
+DIST wcslib-8.3.tar.bz2 3245293 BLAKE2B 0f420d1c6e3b4a7e97b3227971f745d70f5c51e907f0315b7f57e79a34ef32446bbd7fa29ffd25c800e888b8aab6227b774375ed8d89d21f7315916fdd06d788 SHA512 248518489431cbcba7a5df9e34a747e2a007128639d8ab655ceee35250e609d952fe466b67cdca5defe16d3e926730d00bfc5c362c369f74851cd88973b506ba
diff --git a/sci-astronomy/wcslib/wcslib-8.3.ebuild b/sci-astronomy/wcslib/wcslib-8.3.ebuild
new file mode 100644
index 000000000000..942d8b59a872
--- /dev/null
+++ b/sci-astronomy/wcslib/wcslib-8.3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+FORTRAN_NEEDED=fortran
+
+inherit flag-o-matic fortran-2
+
+DESCRIPTION="Astronomical World Coordinate System transformations library"
+HOMEPAGE="https://www.atnf.csiro.au/people/mcalabre/WCS/"
+SRC_URI="ftp://ftp.atnf.csiro.au/pub/software/${PN}/${P}.tar.bz2"
+
+SLOT="0/$(ver_cut 1)"
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc fortran fits pgplot static-libs +tools"
+
+RDEPEND="
+ fits? ( sci-libs/cfitsio:0= )
+ pgplot? ( sci-libs/pgplot:0= )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-alternatives/lex
+ virtual/pkgconfig"
+
+src_configure() {
+ # workaround until upstream fix it properly
+ append-fflags $(test-flags-FC -fallow-argument-mismatch)
+
+ local myconf=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ --htmldir="${EPREFIX}"/usr/share/doc/${PF}
+ $(use_enable fortran)
+ $(use_enable tools utils)
+ --with-bindc
+ )
+ # hacks because cfitsio and pgplot directories are hard-coded
+ if use fits; then
+ myconf+=(
+ --with-cfitsioinc="${EPREFIX}/usr/include"
+ --with-cfitsiolib="${EPREFIX}/usr/$(get_libdir)"
+ )
+ else
+ myconf+=( --without-cfitsio )
+ fi
+ if use pgplot; then
+ myconf+=(
+ --with-pgplotinc="${EPREFIX}/usr/include"
+ --with-pgplotlib="${EPREFIX}/usr/$(get_libdir)"
+ )
+ else
+ myconf+=( --without-pgplot )
+ fi
+ econf "${myconf[@]}"
+ sed -i -e 's/COPYING\*//' GNUmakefile || die
+}
+
+src_install () {
+ default
+ # static libs share the same symbols as shared (i.e. compiled with PIC)
+ # so they are not compiled twice
+ if ! use static-libs; then
+ rm "${ED}"/usr/$(get_libdir)/lib*.a || die
+ fi
+
+ if ! use doc; then
+ rm -r \
+ "${ED}"/usr/share/doc/${PF}/html \
+ "${ED}"/usr/share/doc/${PF}/*.pdf || die
+ fi
+ # always creates this symlink
+ rm "${ED}"/usr/share/doc/${PN} || die
+}