summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/clustal-omega
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/clustal-omega')
-rw-r--r--sci-biology/clustal-omega/Manifest2
-rw-r--r--sci-biology/clustal-omega/clustal-omega-1.2.0.ebuild38
-rw-r--r--sci-biology/clustal-omega/clustal-omega-1.2.1.ebuild38
-rw-r--r--sci-biology/clustal-omega/metadata.xml5
4 files changed, 83 insertions, 0 deletions
diff --git a/sci-biology/clustal-omega/Manifest b/sci-biology/clustal-omega/Manifest
new file mode 100644
index 000000000000..2394b3a452f6
--- /dev/null
+++ b/sci-biology/clustal-omega/Manifest
@@ -0,0 +1,2 @@
+DIST clustal-omega-1.2.0.tar.gz 1156741 SHA256 cbf5ad4e1ce88641cca307be1edfe95d3882997d71c11b43c8e1fcd6e388c61d SHA512 d207699e1158178e2d7122620026b199251ab86bcc3f72a08d58f23e2dd5c2961340e872a13c34f1d6832c5eef5ff8ab09c43f0cb51a81d6c4ef554f936434e2 WHIRLPOOL 41505b42829d440fd312f1538ef78fb7d0f668008cd00bcc52022139eb2ff21d05d89519af2a18e5a2f845e24a5d374a81eb4163c2720a32f71ead7ce40e4eac
+DIST clustal-omega-1.2.1.tar.gz 1164492 SHA256 0ef32727aa25c6ecf732083e668a0f45bc17085c28a5c7b4459f4750419f2b0a SHA512 1aa69e319f999f7cd746e2d2ffcafeafc0eb15ed4777abb5b32df63a39a23fa2091977efccfcf9428468103b8e48c4ab0a3ce3967b9c55daaadf3a6a3b57e8de WHIRLPOOL b079dcd659839a85e7772b717ef5dce25b816f2c96eb0f6eea5a4a53f2abd25fb4435291f2a7b739d72d94c06fdbd9c85300ff4cbb03b2861d31d1ad3d196577
diff --git a/sci-biology/clustal-omega/clustal-omega-1.2.0.ebuild b/sci-biology/clustal-omega/clustal-omega-1.2.0.ebuild
new file mode 100644
index 000000000000..ccded19116cd
--- /dev/null
+++ b/sci-biology/clustal-omega/clustal-omega-1.2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils
+
+DESCRIPTION="Scalable multiple alignment of protein sequences"
+HOMEPAGE="http://www.clustal.org/omega/"
+SRC_URI="http://www.clustal.org/omega/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND="dev-libs/argtable"
+RDEPEND="${DEPEND}"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_prepare() {
+ sed \
+ -e "s:-O3::g" \
+ -i configure.ac || die
+ autotools-utils_src_prepare
+}
+
+src_install() {
+ autotools-utils_src_install
+ if ! use static-libs; then
+ rm -f "${ED}"/usr/$(get_libdir)/*.a || die
+ rm -fr "${ED}"/usr/$(get_libdir)/pkgconfig || die
+ fi
+}
diff --git a/sci-biology/clustal-omega/clustal-omega-1.2.1.ebuild b/sci-biology/clustal-omega/clustal-omega-1.2.1.ebuild
new file mode 100644
index 000000000000..e56766f9416e
--- /dev/null
+++ b/sci-biology/clustal-omega/clustal-omega-1.2.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils
+
+DESCRIPTION="Scalable multiple alignment of protein sequences"
+HOMEPAGE="http://www.clustal.org/omega/"
+SRC_URI="http://www.clustal.org/omega/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND="dev-libs/argtable"
+RDEPEND="${DEPEND}"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_prepare() {
+ sed \
+ -e "s:-O3::g" \
+ -i configure.ac || die
+ autotools-utils_src_prepare
+}
+
+src_install() {
+ autotools-utils_src_install
+ if ! use static-libs; then
+ rm -f "${ED}"/usr/$(get_libdir)/*.a || die
+ rm -fr "${ED}"/usr/$(get_libdir)/pkgconfig || die
+ fi
+}
diff --git a/sci-biology/clustal-omega/metadata.xml b/sci-biology/clustal-omega/metadata.xml
new file mode 100644
index 000000000000..f17a827e3101
--- /dev/null
+++ b/sci-biology/clustal-omega/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+</pkgmetadata>