summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/rnaview/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/rnaview/files')
-rw-r--r--sci-biology/rnaview/files/rnaview-20040713-implicit.patch13
-rw-r--r--sci-biology/rnaview/files/rnaview-20040713-makefile.patch87
2 files changed, 100 insertions, 0 deletions
diff --git a/sci-biology/rnaview/files/rnaview-20040713-implicit.patch b/sci-biology/rnaview/files/rnaview-20040713-implicit.patch
new file mode 100644
index 000000000000..009f6e79ae86
--- /dev/null
+++ b/sci-biology/rnaview/files/rnaview-20040713-implicit.patch
@@ -0,0 +1,13 @@
+Fix implicit function declaration
+
+--- src/xml2ps.c
++++ src/xml2ps.c
+@@ -36,7 +36,7 @@
+ void read_sugar_syn(char *inpfile, long **sugar_syn);
+ void get_sugar_syn(FILE *inp, char *value_ch);
+ void get_chain_broken(long nres, double **a, double **b, long *chain_broken);
+-
++extern void get_BDIR(char *BDIR, char *filename);
+
+
+ FILE *psfile;
diff --git a/sci-biology/rnaview/files/rnaview-20040713-makefile.patch b/sci-biology/rnaview/files/rnaview-20040713-makefile.patch
new file mode 100644
index 000000000000..1af72f581fbf
--- /dev/null
+++ b/sci-biology/rnaview/files/rnaview-20040713-makefile.patch
@@ -0,0 +1,87 @@
+ Makefile | 20 +++++++++++++++++---
+ rnaml2ps/Makefile | 19 ++++++++++++-------
+ 2 files changed, 29 insertions(+), 10 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 452e6c4..00d35f0 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,4 +1,4 @@
+-CC = cc
++CC ?= cc
+
+
+
+@@ -56,12 +56,17 @@ OBJ_FILE = $(OBJ)/rnaview.o \
+ $(OBJ)/multiple.o \
+ $(OBJ)/statistics.o
+
++.PHONY: clean all install
++
++SUBDIRS = rnaml2ps
++
+ all: $(RNAVIEW)
++ for dir in ${SUBDIRS} ; do ( cd $$dir ; ${MAKE} all ) ; done
+
+-CFLAGS = $(LINCLUDES)
++CFLAGS += $(LINCLUDES)
+
+ $(RNAVIEW) : $(HFILES) $(OBJ_FILE)
+- $(CC) $(CFLAGS) -o $@ $(OBJ_FILE) $(LDFLAGS) -lm $(MALLOCLIB)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(OBJ_FILE) -lm $(MALLOCLIB)
+
+
+
+@@ -111,6 +116,15 @@ $(OBJ)/statistics.o : $(SRC)/statistics.c
+ clean:
+ @rm -f $(OBJ)/*.o
+ @rm -f $(ALLTARGETS)
++ for dir in ${SUBDIRS} ; do ( cd $$dir ; ${MAKE} clean ) ; done
++
++install:
++ install -D -m 0755 bin/rnaview $(DESTDIR)/usr/bin/rnaview
++ mkdir -p $(DESTDIR)/usr/share/rnaview/BASEPARS
++ install -m 0644 BASEPARS/* $(DESTDIR)/usr/share/rnaview/BASEPARS
++ mkdir -p $(DESTDIR)/usr/share/rnaview/test
++ install -m 0644 test/* $(DESTDIR)/usr/share/rnaview/test
++ for dir in ${SUBDIRS} ; do ( cd $$dir ; ${MAKE} install ) ; done
+
+ export:
+ mkdir -p $(EXPORT_DIR)
+diff --git a/rnaml2ps/Makefile b/rnaml2ps/Makefile
+index d207655..2278ccc 100644
+--- a/rnaml2ps/Makefile
++++ b/rnaml2ps/Makefile
+@@ -1,20 +1,25 @@
+-CFLAGS = -O
+-CC = cc
++CFLAGS ?= -O
++CC ?= cc
+
+ # ++++++++++++++++++++++++++++ Program RNADRAW
+ RNADRAW = rnaml2ps
+ OBJS_RNADRAW = rnaml2ps.o nrutil.o
+
++all: $(RNADRAW)
++
+ $(RNADRAW): $(OBJS_RNADRAW)
+- $(CC) -o $(RNADRAW) $(OBJS_RNADRAW) -lm
++ $(CC) $(LDFLAGS) -o $(RNADRAW) $(OBJS_RNADRAW) -lm
+
+ nrutil.o : nrutil.c
+- cc -c nrutil.c
++ $(CC) $(CFLAGS) -c nrutil.c
+
+ rnaml2ps.o : rnaml2ps.c
+- cc -c rnaml2ps.c
++ $(CC) $(CFLAGS) -c rnaml2ps.c
+
+
+-.PHONY : clean
++.PHONY : clean all install
+ clean:
+- rm *.o
++ rm -f *.o
++
++install:
++ install -D -m 0755 $(RNADRAW) $(DESTDIR)/usr/bin/$(RNADRAW)