summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-02-25 16:46:24 +0100
committerDavid Seifert <soap@gentoo.org>2017-02-25 16:49:01 +0100
commite5ce74fb32afe018ef0d58ff9bfb8192abb62019 (patch)
treebd8225e6d1ae5c813e229d0af9fd7c9da6648a05 /sci-biology
parentdev-haskell/skylighting: bump up to 0.3 (diff)
downloadgentoo-e5ce74fb32afe018ef0d58ff9bfb8192abb62019.tar.gz
gentoo-e5ce74fb32afe018ef0d58ff9bfb8192abb62019.tar.bz2
gentoo-e5ce74fb32afe018ef0d58ff9bfb8192abb62019.zip
sci-biology/exonerate: Modernise to EAPI 6
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/exonerate/exonerate-2.2.0-r2.ebuild (renamed from sci-biology/exonerate/exonerate-2.2.0-r1.ebuild)38
-rw-r--r--sci-biology/exonerate/files/exonerate-2.2.0-asneeded.patch4
2 files changed, 20 insertions, 22 deletions
diff --git a/sci-biology/exonerate/exonerate-2.2.0-r1.ebuild b/sci-biology/exonerate/exonerate-2.2.0-r2.ebuild
index 966f7c2f8e01..567b906ca21d 100644
--- a/sci-biology/exonerate/exonerate-2.2.0-r1.ebuild
+++ b/sci-biology/exonerate/exonerate-2.2.0-r2.ebuild
@@ -1,50 +1,48 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=6
-AUTOTOOLS_AUTORECONF=true
-
-inherit autotools-utils toolchain-funcs
+inherit autotools toolchain-funcs
DESCRIPTION="Generic tool for pairwise sequence comparison"
-HOMEPAGE="http://www.ebi.ac.uk/~guy/exonerate/"
-SRC_URI="http://www.ebi.ac.uk/~guy/exonerate/${P}.tar.gz"
+HOMEPAGE="https://www.ebi.ac.uk/about/vertebrate-genomics/software/exonerate"
+SRC_URI="http://ftp.ebi.ac.uk/pub/software/vertebrategenomics/exonerate/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos"
-IUSE="utils test threads"
-
+IUSE="test threads utils"
REQUIRED_USE="test? ( utils )"
DEPEND="dev-libs/glib:2"
RDEPEND="${DEPEND}"
-AUTOTOOLS_IN_SOURCE_BUILD=1
-
PATCHES=( "${FILESDIR}"/${P}-asneeded.patch )
src_prepare() {
- tc-export CC
+ default
sed \
-e 's: -O3 -finline-functions::g' \
-i configure.in || die
- autotools-utils_src_prepare
+ mv configure.{in,ac} || die
+
+ eautoreconf
}
src_configure() {
- local myeconfargs=(
- $(use_enable utils utilities)
+ tc-export CC
+
+ econf \
+ --enable-glib2 \
+ --enable-largefile \
+ $(use_enable utils utilities) \
$(use_enable threads pthreads)
- --enable-largefile
- --enable-glib2
- )
- autotools-utils_src_configure
}
src_install() {
- autotools-utils_src_install
+ default
+
doman doc/man/man1/*.1
}
diff --git a/sci-biology/exonerate/files/exonerate-2.2.0-asneeded.patch b/sci-biology/exonerate/files/exonerate-2.2.0-asneeded.patch
index 3268055cd544..5c428979a1af 100644
--- a/sci-biology/exonerate/files/exonerate-2.2.0-asneeded.patch
+++ b/sci-biology/exonerate/files/exonerate-2.2.0-asneeded.patch
@@ -2,8 +2,8 @@ Fix build with --as-needed
https://bugs.gentoo.org/268094
---- configure.in
-+++ configure.in
+--- a/configure.in
++++ b/configure.in
@@ -289,7 +289,7 @@
if test "$enable_pthreads" = yes; then
echo "Using PTHREADS"