summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-12-26 16:48:40 +0100
committerDavid Seifert <soap@gentoo.org>2022-12-26 16:48:40 +0100
commitea510208f6da75d9e87b6f7ac7305645ac04dbb1 (patch)
tree97cb4e0dca50d8d35c2eb77dc7e73ca9815f5627 /sci-calculators
parentsci-calculators/calcoo: update EAPI 6 -> 8 (diff)
downloadgentoo-ea510208f6da75d9e87b6f7ac7305645ac04dbb1.tar.gz
gentoo-ea510208f6da75d9e87b6f7ac7305645ac04dbb1.tar.bz2
gentoo-ea510208f6da75d9e87b6f7ac7305645ac04dbb1.zip
sci-calculators/tilp2: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-calculators')
-rw-r--r--sci-calculators/tilp2/tilp2-1.18-r1.ebuild (renamed from sci-calculators/tilp2/tilp2-1.18.ebuild)26
1 files changed, 12 insertions, 14 deletions
diff --git a/sci-calculators/tilp2/tilp2-1.18.ebuild b/sci-calculators/tilp2/tilp2-1.18-r1.ebuild
index 5cad6f355541..ff566c357e29 100644
--- a/sci-calculators/tilp2/tilp2-1.18.ebuild
+++ b/sci-calculators/tilp2/tilp2-1.18-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit autotools xdg
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/tilp/tilp2-linux/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="nls static-libs"
+IUSE="nls"
RDEPEND="
dev-libs/glib:2
@@ -22,32 +22,30 @@ RDEPEND="
>=sci-libs/libtifiles2-1.1.7
>=sci-libs/libticonv-1.1.5
x11-libs/gtk+:2
- nls? ( virtual/libintl )
-"
-DEPEND="${RDEPEND}
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="
virtual/pkgconfig
nls? ( sys-devel/gettext )"
-PATCHES=(
- "${FILESDIR}"/${PN}-1.18-nonbash.patch
-)
+PATCHES=( "${FILESDIR}"/${PN}-1.18-nonbash.patch )
src_prepare() {
default
# The ac macro AC_PATH_KDE was provided by "acinclude.m4" in 1.17.
# This file is missing in the current version which will cause an autoconf error.
# But since we don't build with kde support, we may safely remove all its reverse dependencies.
- sed -i -e '/AC_PATH_KDE/d' configure.ac
+ sed -i -e '/AC_PATH_KDE/d' configure.ac || die
sed -i \
-e 's/@[^@]*\(KDE\|QT\|KIO\)[^@]*@//g' \
-e 's/@X_LDFLAGS@//g' \
- src/Makefile.am
+ src/Makefile.am || die
eautoreconf
}
src_configure() {
# kde seems to be kde3 only
- econf --without-kde \
- $(use_enable nls) \
- $(use_enable static-libs static)
+ econf \
+ --without-kde \
+ $(use_enable nls)
}