summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/freeon
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/freeon')
-rw-r--r--sci-chemistry/freeon/Manifest2
-rw-r--r--sci-chemistry/freeon/files/freeon-1.0.8-blas.patch165
-rw-r--r--sci-chemistry/freeon/freeon-1.0.10.ebuild27
-rw-r--r--sci-chemistry/freeon/freeon-1.0.8-r1.ebuild29
-rw-r--r--sci-chemistry/freeon/metadata.xml12
5 files changed, 235 insertions, 0 deletions
diff --git a/sci-chemistry/freeon/Manifest b/sci-chemistry/freeon/Manifest
new file mode 100644
index 000000000000..39a7e4aedcc1
--- /dev/null
+++ b/sci-chemistry/freeon/Manifest
@@ -0,0 +1,2 @@
+DIST freeon-1.0.10.tar.bz2 5872019 SHA256 01f0086a53930afb3078a2794baa1fccdacdc4a23082725cb016068d5a10ec38 SHA512 5bae89d6421600792bf986f6fb7504d321d5d51782587237ecba35191e54c1ec6c5ea1fdc50ed2d339551c527e4efcc5421048ccce0404c4b06875cbd0800862 WHIRLPOOL 84fcf7ca4d62e5a2407f2920f9a13fd2a4930f2637d098954b3be81f540e4a10344d17053a1d05046c2743f317a8898886148439d51364ce10dc66a313eadb8b
+DIST freeon-1.0.8.tar.bz2 5957707 SHA256 ae14c1b640e4dcd9f18d2807f2debf9fc005b7451401e3e5d7b9dc76919f381d SHA512 1227f670a73b4ea39beb26e4136ad535e126ad17d66171c31b3bd403a3886eee150cda865806a2d9dad85646ccb086a6be4f645455eab24603cb064fb725efbd WHIRLPOOL b41a3b1e4bb152309a12ac0c4fec07c932809bb465af4b08cb76f6e0bf089c4d91682e1428c47d1adb449d153a1338cd3d540e860ca22774a299e21da44a16c1
diff --git a/sci-chemistry/freeon/files/freeon-1.0.8-blas.patch b/sci-chemistry/freeon/files/freeon-1.0.8-blas.patch
new file mode 100644
index 000000000000..46fca7fa2a52
--- /dev/null
+++ b/sci-chemistry/freeon/files/freeon-1.0.8-blas.patch
@@ -0,0 +1,165 @@
+ FreeON/Makefile.am | 2 +-
+ HiCu/Makefile.am | 2 +-
+ ONX/Makefile.am | 1 +
+ OneE/Makefile.am | 2 +-
+ QCTC/Makefile.am | 2 +-
+ SCFeqs/Makefile.am | 2 +-
+ configure.ac | 12 ++++++++----
+ make.inc | 2 +-
+ tests/Makefile.am | 8 ++++----
+ tools/Makefile.am | 2 +-
+ 10 files changed, 20 insertions(+), 15 deletions(-)
+
+diff --git a/FreeON/Makefile.am b/FreeON/Makefile.am
+index 18e0283..12db056 100644
+--- a/FreeON/Makefile.am
++++ b/FreeON/Makefile.am
+@@ -50,7 +50,7 @@ FreeON_DEPENDENCIES = $(LIBRARY_DEPENDENCY_FILES)
+
+ SOURCES_DEPCHECK = $(FreeON_SOURCES)
+
+-FreeON_LDADD = $(LDADD_MODULES)
++FreeON_LDADD = $(LDADD_MODULES) $(LAPACK_LIBS)
+
+ AM_CPPFLAGS += \
+ -DFREEON_BASISSETS=\"$(datadir)/$(PACKAGE)/BasisSets\" \
+diff --git a/HiCu/Makefile.am b/HiCu/Makefile.am
+index 1847354..cc4ebef 100644
+--- a/HiCu/Makefile.am
++++ b/HiCu/Makefile.am
+@@ -27,7 +27,7 @@ EXTRA_DIST = \
+ MMA/CubeRules/RuleD.Inc \
+ MMA/CubeRules/RuleE.Inc
+
+-LDADD = $(LDADD_MODULES)
++LDADD = $(LDADD_MODULES) $(LAPACK_LIBS)
+
+ EXTRA_INCLUDES = -I$(top_srcdir)/Modules/MMA/Functionals
+ AM_CPPFLAGS += -DRULE7 -DEXPLICIT_SOURCE
+diff --git a/ONX/Makefile.am b/ONX/Makefile.am
+index 4d25029..b27b149 100644
+--- a/ONX/Makefile.am
++++ b/ONX/Makefile.am
+@@ -61,6 +61,7 @@ EXTRA_INCLUDES = \
+
+ LDADD = \
+ $(LDADD_MODULES) \
++ $(LAPACK_LIBS) \
+ $(builddir)/../TwoE/libfreeonTwoE.la
+
+ # In case we have ctags installed, make the necessary tags files.
+diff --git a/OneE/Makefile.am b/OneE/Makefile.am
+index 784bede..ea86ae7 100644
+--- a/OneE/Makefile.am
++++ b/OneE/Makefile.am
+@@ -46,7 +46,7 @@ EXTRA_DIST = \
+ MMA/QQuad32.Inc \
+ MMA/QQuad64.Inc
+
+-LDADD = $(LDADD_MODULES)
++LDADD = $(LDADD_MODULES) $(LAPACK_LIBS)
+
+ EXTRA_INCLUDES = -I$(srcdir)/MMA
+
+diff --git a/QCTC/Makefile.am b/QCTC/Makefile.am
+index 3ec39f0..53c358c 100644
+--- a/QCTC/Makefile.am
++++ b/QCTC/Makefile.am
+@@ -105,7 +105,7 @@ EXTRA_DIST = \
+ PBCTensor/Majik_Kubic_WS2.Inc
+
+ EXTRA_INCLUDES = -I$(top_builddir)/OneE -I$(top_srcdir)/Modules/MMA/LookUpTables_800_6x
+-LDADD = $(LDADD_MODULES) libktrax.la
++LDADD = $(LDADD_MODULES) libktrax.la $(LAPACK_LIBS)
+
+ # In case we have ctags installed, make the necessary tags files.
+ .PHONY : tags
+diff --git a/SCFeqs/Makefile.am b/SCFeqs/Makefile.am
+index 2ee640f..709f220 100644
+--- a/SCFeqs/Makefile.am
++++ b/SCFeqs/Makefile.am
+@@ -57,7 +57,7 @@ SOURCES_DEPCHECK = \
+ $(P2Use_SOURCES) \
+ $(DIIS_SOURCES)
+
+-LDADD = $(LDADD_MODULES)
++LDADD = $(LDADD_MODULES) $(LAPACK_LIBS)
+
+ # In case we have ctags installed, make the necessary tags files.
+ .PHONY : tags
+diff --git a/configure.ac b/configure.ac
+index e0c6a77..726c880 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -784,12 +784,16 @@ END PROGRAM test_compiler
+ you use a version >= 4.2.0])])
+
+ # Check for BLAS.
+-AC_SEARCH_LIBS([dgemm], [blas], [],
+- [AC_MSG_FAILURE([specify the location of dgemm()])])
++PKG_CHECK_MODULES([BLAS],[blas],[],
++ AC_SEARCH_LIBS([dgemm], [blas], [],
++ [AC_MSG_FAILURE([specify the location of dgemm()])])
++ )
+
+ # Check for LAPACK.
+-AC_SEARCH_LIBS([dsyev], [lapack], [],
+- [AC_MSG_FAILURE([specify the library that contains dsyev()])])
++PKG_CHECK_MODULES([LAPACK],[lapack],[],
++ AC_SEARCH_LIBS([dsyev], [lapack], [],
++ [AC_MSG_FAILURE([specify the library that contains dsyev()])])
++ )
+
+ AC_ARG_VAR([H5CC], [h5cc compiler wrapper command])
+
+diff --git a/make.inc b/make.inc
+index cf35e40..5766ff9 100644
+--- a/make.inc
++++ b/make.inc
+@@ -9,7 +9,7 @@ AM_CPPFLAGS = @AM_CPPFLAGS@
+ # Fix for bug in autoconf-2.59
+ builddir = .
+
+-LDADD_MODULES = $(top_builddir)/Modules/libfreeonmodules.la
++LDADD_MODULES = $(top_builddir)/Modules/libfreeonmodules.la $(LAPACK_MODULES)
+
+ # On filesystems which are case-insensitive (which really means HFS+ on OS X)
+ # we can not preprocess into a filename that differs by the case only, i.e. .C
+diff --git a/tests/Makefile.am b/tests/Makefile.am
+index 6bd89f2..ae9da60 100644
+--- a/tests/Makefile.am
++++ b/tests/Makefile.am
+@@ -7,16 +7,16 @@ noinst_PROGRAMS = \
+ sendReceive_HGRho
+
+ sleeper_SOURCES = sleeper.F90
+-sleeper_LDADD = $(LDADD_MODULES)
++sleeper_LDADD = $(LDADD_MODULES) $(LAPACK_LIBS)
+
+ lock_SOURCES = lock.F90
+-lock_LDADD = $(LDADD_MODULES)
++lock_LDADD = $(LDADD_MODULES) $(LAPACK_LIBS)
+
+ sendReceive_DBL_RNK2_SOURCES = sendReceive_DBL_RNK2.F90
+-sendReceive_DBL_RNK2_LDADD = $(LDADD_MODULES)
++sendReceive_DBL_RNK2_LDADD = $(LDADD_MODULES) $(LAPACK_LIBS)
+
+ sendReceive_HGRho_SOURCES = sendReceive_HGRho.F90
+-sendReceive_HGRho_LDADD = $(LDADD_MODULES)
++sendReceive_HGRho_LDADD = $(LDADD_MODULES) $(LAPACK_LIBS)
+
+ if HAVE_MPIRUN
+ MPI_TESTS = locktest
+diff --git a/tools/Makefile.am b/tools/Makefile.am
+index e0baaff..a6b18b2 100644
+--- a/tools/Makefile.am
++++ b/tools/Makefile.am
+@@ -19,7 +19,7 @@ python_PYTHON = \
+ bin_PROGRAMS = printBCSR convertBCSR
+
+ printBCSR_SOURCES = printBCSR.F90
+-printBCSR_LDADD = $(top_builddir)/Modules/libfreeonmodules.la
++printBCSR_LDADD = $(top_builddir)/Modules/libfreeonmodules.la $(LAPACK_LIBS)
+
+ convertBCSR_SOURCES = \
+ convertBCSR.cc \
diff --git a/sci-chemistry/freeon/freeon-1.0.10.ebuild b/sci-chemistry/freeon/freeon-1.0.10.ebuild
new file mode 100644
index 000000000000..f19ae3f6fb89
--- /dev/null
+++ b/sci-chemistry/freeon/freeon-1.0.10.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+FORTRAN_STANDARD=90
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit autotools-utils fortran-2 python-any-r1
+
+DESCRIPTION="An experimental suite of programs for linear scaling quantum chemistry"
+HOMEPAGE="http://www.freeon.org"
+SRC_URI="http://download.savannah.gnu.org/releases/${PN}/${PN}-${PV}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ sci-libs/hdf5
+ virtual/blas
+ virtual/lapack"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}"
diff --git a/sci-chemistry/freeon/freeon-1.0.8-r1.ebuild b/sci-chemistry/freeon/freeon-1.0.8-r1.ebuild
new file mode 100644
index 000000000000..9a847d58768e
--- /dev/null
+++ b/sci-chemistry/freeon/freeon-1.0.8-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+FORTRAN_STANDARD=90
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit autotools-utils fortran-2 python-any-r1
+
+DESCRIPTION="An experimental suite of programs for linear scaling quantum chemistry"
+HOMEPAGE="http://www.freeon.org"
+SRC_URI="http://download.savannah.gnu.org/releases/${PN}/${PN}-${PV}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ sci-libs/hdf5
+ virtual/blas
+ virtual/lapack"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}"
+
+PATCHES=( "${FILESDIR}"/${P}-blas.patch )
diff --git a/sci-chemistry/freeon/metadata.xml b/sci-chemistry/freeon/metadata.xml
new file mode 100644
index 000000000000..eba82069680b
--- /dev/null
+++ b/sci-chemistry/freeon/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription lang="en">
+ FreeON is an experimental, open source (GPL) suite of programs for linear scaling quantum chemistry.
+ </longdescription>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>nicolasbock@gentoo.org</email>
+ <name>Nicolas Bock</name>
+ </maintainer>
+</pkgmetadata>