summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@gentoo.org>2024-08-05 18:04:37 -0400
committerEli Schwartz <eschwartz@gentoo.org>2024-08-05 20:18:31 -0400
commit08a8d3cde15e8323329cd3394572322f95c25653 (patch)
treeae32a70bcb8bc86cdd4921ad8646670a11252585 /sci-chemistry
parentsci-libs/gsl: mark as LTO-unsafe (diff)
downloadgentoo-08a8d3cde15e8323329cd3394572322f95c25653.tar.gz
gentoo-08a8d3cde15e8323329cd3394572322f95c25653.tar.bz2
gentoo-08a8d3cde15e8323329cd3394572322f95c25653.zip
sci-chemistry/tinker: mark as LTO-unsafe
At least, the tests fail if you use LTO. So it is apparently unsafe, though unsafe here means the results you get are wrong! Closes: https://bugs.gentoo.org/878059 Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/tinker/tinker-8.2.1-r1.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/sci-chemistry/tinker/tinker-8.2.1-r1.ebuild b/sci-chemistry/tinker/tinker-8.2.1-r1.ebuild
index 9964b16b549f..8689a962c2fd 100644
--- a/sci-chemistry/tinker/tinker-8.2.1-r1.ebuild
+++ b/sci-chemistry/tinker/tinker-8.2.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -50,6 +50,11 @@ src_prepare() {
}
src_compile() {
+ # tests fail with weird results under LTO
+ # https://bugs.gentoo.org/878059
+ # https://github.com/TinkerTools/tinker/issues/159
+ filter-lto
+
local javalib= _omplib _fftwlib
for i in $(java-config -g LDPATH | sed 's|:| |g'); do
[[ -f ${i}/libjvm.so ]] && javalib=${i}