summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/beagle
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/beagle')
-rw-r--r--sci-libs/beagle/Manifest1
-rw-r--r--sci-libs/beagle/beagle-3.0.3.ebuild55
-rw-r--r--sci-libs/beagle/files/beagle-3.0.3-gcc43.patch89
-rw-r--r--sci-libs/beagle/files/beagle-3.0.3-gcc47.patch10
-rw-r--r--sci-libs/beagle/metadata.xml11
5 files changed, 166 insertions, 0 deletions
diff --git a/sci-libs/beagle/Manifest b/sci-libs/beagle/Manifest
new file mode 100644
index 000000000000..6e60f608bfcf
--- /dev/null
+++ b/sci-libs/beagle/Manifest
@@ -0,0 +1 @@
+DIST beagle-3.0.3.tar.gz 5002994 SHA256 2e481dc180bc1f665ade82f0568db4d67f4b8b3f32bc155f1358fd48630e2935 SHA512 2f8f027f3f24d0fd287e27a80fe5b24e18550144add06fb8157dd03f734f5ce212f62889720c81fd33246fa7086e9b913802ec0c5155df5bd801c36888b346cb WHIRLPOOL 7902d2bf149afb9c2dc1f89fbb6754250950d6df90e63b445939b9c7fdc21b59835ac840d3babb7b56056c24e1f159da9aef27105ff9e05e0298f283e6697bbb
diff --git a/sci-libs/beagle/beagle-3.0.3.ebuild b/sci-libs/beagle/beagle-3.0.3.ebuild
new file mode 100644
index 000000000000..52ba7e8f86b2
--- /dev/null
+++ b/sci-libs/beagle/beagle-3.0.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="Open BEAGLE, a versatile EC/GA/GP framework"
+SRC_URI="mirror://sourceforge/beagle/${P}.tar.gz"
+HOMEPAGE="http://beagle.gel.ulaval.ca/"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 x86"
+IUSE="doc static-libs"
+
+RDEPEND="
+ sys-libs/zlib
+ !app-misc/beagle
+ !dev-libs/libbeagle"
+DEPEND="${DEPEND}
+ doc? ( app-doc/doxygen )"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.0.3-gcc43.patch "${FILESDIR}"/${PN}-3.0.3-gcc47.patch )
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_prepare() {
+ autotools-utils_src_prepare
+ sed -e "s:@LIBS@:@LIBS@ -lpthread:" \
+ -i PACC/Threading/Makefile.in || \
+ die "Failed to fix threading libs makefile."
+}
+
+src_configure() {
+ local myeconfargs=( --enable-optimization )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+
+ use doc && autotools-utils_src_compile doc
+}
+
+src_install () {
+ autotools-utils_src_install
+
+ if use doc; then
+ cp -pPR examples "${D}"/usr/share/doc/${PF} || \
+ die "Failed to install examples."
+ dohtml -r refman/*
+ fi
+}
diff --git a/sci-libs/beagle/files/beagle-3.0.3-gcc43.patch b/sci-libs/beagle/files/beagle-3.0.3-gcc43.patch
new file mode 100644
index 000000000000..608ce388e793
--- /dev/null
+++ b/sci-libs/beagle/files/beagle-3.0.3-gcc43.patch
@@ -0,0 +1,89 @@
+diff -rupN beagle-3.0.3b/PACC/Math/Matrix.cpp beagle-3.0.3/PACC/Math/Matrix.cpp
+--- beagle-3.0.3b/PACC/Math/Matrix.cpp 2009-01-20 23:38:39.000000000 -0400
++++ beagle-3.0.3/PACC/Math/Matrix.cpp 2009-01-21 00:26:46.000000000 -0400
+@@ -40,6 +40,7 @@
+ #include <stdexcept>
+ #include <iomanip>
+ #include <cmath>
++#include <climits>
+
+ using namespace std;
+ using namespace PACC;
+diff -rupN beagle-3.0.3b/PACC/Math/Vector.hpp beagle-3.0.3/PACC/Math/Vector.hpp
+--- beagle-3.0.3b/PACC/Math/Vector.hpp 2009-01-20 23:38:39.000000000 -0400
++++ beagle-3.0.3/PACC/Math/Vector.hpp 2009-01-21 00:26:29.000000000 -0400
+@@ -42,6 +42,7 @@
+ #include "XML/Document.hpp"
+ #include "XML/Streamer.hpp"
+ #include <cmath>
++#include <algorithm>
+
+ namespace PACC {
+
+diff -rupN beagle-3.0.3b/PACC/Socket/Cafe.cpp beagle-3.0.3/PACC/Socket/Cafe.cpp
+--- beagle-3.0.3b/PACC/Socket/Cafe.cpp 2009-01-20 23:38:39.000000000 -0400
++++ beagle-3.0.3/PACC/Socket/Cafe.cpp 2009-01-21 00:31:09.000000000 -0400
+@@ -35,6 +35,7 @@
+
+ #include "Socket/Cafe.hpp"
+ #include <iostream>
++#include <cstring>
+
+ #ifdef WIN32
+ ///////////// specifics for windows /////////////
+diff -rupN beagle-3.0.3b/PACC/Socket/Port.cpp beagle-3.0.3/PACC/Socket/Port.cpp
+--- beagle-3.0.3b/PACC/Socket/Port.cpp 2009-01-20 23:38:39.000000000 -0400
++++ beagle-3.0.3/PACC/Socket/Port.cpp 2009-01-21 00:30:54.000000000 -0400
+@@ -34,6 +34,7 @@
+ */
+
+ #include "Socket/Port.hpp"
++#include <cstring>
+
+ #ifdef WIN32
+ ///////////// specifics for windows /////////////
+diff -rupN beagle-3.0.3b/PACC/Threading/Thread.cpp beagle-3.0.3/PACC/Threading/Thread.cpp
+--- beagle-3.0.3b/PACC/Threading/Thread.cpp 2009-01-20 23:38:39.000000000 -0400
++++ beagle-3.0.3/PACC/Threading/Thread.cpp 2009-01-21 00:28:02.000000000 -0400
+@@ -35,6 +35,7 @@
+
+ #include "Threading/Thread.hpp"
+ #include "Util/Assert.hpp"
++#include <cstdlib>
+
+ #ifdef WIN32
+ #include <windows.h>
+diff -rupN beagle-3.0.3b/PACC/Util/SignalHandler.cpp beagle-3.0.3/PACC/Util/SignalHandler.cpp
+--- beagle-3.0.3b/PACC/Util/SignalHandler.cpp 2009-01-20 23:38:39.000000000 -0400
++++ beagle-3.0.3/PACC/Util/SignalHandler.cpp 2009-01-20 23:44:20.000000000 -0400
+@@ -37,6 +37,7 @@
+ #include "Util/Assert.hpp"
+ #include <signal.h>
+ #include <stdexcept>
++#include <cstdlib>
+
+ using namespace std;
+ using namespace PACC;
+diff -rupN beagle-3.0.3b/PACC/Util/Tokenizer.cpp beagle-3.0.3/PACC/Util/Tokenizer.cpp
+--- beagle-3.0.3b/PACC/Util/Tokenizer.cpp 2009-01-20 23:38:39.000000000 -0400
++++ beagle-3.0.3/PACC/Util/Tokenizer.cpp 2009-01-20 23:44:10.000000000 -0400
+@@ -36,6 +36,8 @@
+ #include "Util/Tokenizer.hpp"
+ #include "Util/Assert.hpp"
+ #include <stdexcept>
++#include <cstring>
++#include <cstdlib>
+
+ using namespace std;
+ using namespace PACC;
+diff -rupN beagle-3.0.3b/PACC/XML/Node.cpp beagle-3.0.3/PACC/XML/Node.cpp
+--- beagle-3.0.3b/PACC/XML/Node.cpp 2009-01-20 23:38:39.000000000 -0400
++++ beagle-3.0.3/PACC/XML/Node.cpp 2009-01-20 23:45:09.000000000 -0400
+@@ -39,6 +39,7 @@
+ #include "Util/Assert.hpp"
+ #include <sstream>
+ #include <stdexcept>
++#include <cstring>
+
+ using namespace std;
+ using namespace PACC;
diff --git a/sci-libs/beagle/files/beagle-3.0.3-gcc47.patch b/sci-libs/beagle/files/beagle-3.0.3-gcc47.patch
new file mode 100644
index 000000000000..cb3546c68a5c
--- /dev/null
+++ b/sci-libs/beagle/files/beagle-3.0.3-gcc47.patch
@@ -0,0 +1,10 @@
+--- beagle/include/beagle/RouletteT.hpp
++++ beagle/include/beagle/RouletteT.hpp
+@@ -87,7 +87,7 @@
+ Beagle_StackTraceBeginM();
+ Beagle_AssertM(inWeight>=0.0);
+ if(VectorType::empty()==false) inWeight += VectorType::back().first;
+- push_back(std::make_pair(inWeight,inValue));
++ this->push_back(std::make_pair(inWeight,inValue));
+ Beagle_StackTraceEndM("void RouletteT<T>::insert(const T& inValue, double inWeight)");
+ }
diff --git a/sci-libs/beagle/metadata.xml b/sci-libs/beagle/metadata.xml
new file mode 100644
index 000000000000..4b2a7479afe8
--- /dev/null
+++ b/sci-libs/beagle/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription>
+ Open BEAGLE is a C++ Evolutionary Computation (EC) framework. It provides an high-level software environment to do any kind of EC, with support for tree-based genetic programming, bit string and real-valued genetic algorithms, and evolution strategy.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">beagle</remote-id>
+ </upstream>
+</pkgmetadata>