summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/ccfits
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/ccfits')
-rw-r--r--sci-libs/ccfits/Manifest1
-rw-r--r--sci-libs/ccfits/ccfits-2.4.ebuild38
-rw-r--r--sci-libs/ccfits/files/ccfits-2.2-makefile.patch26
-rw-r--r--sci-libs/ccfits/metadata.xml12
4 files changed, 77 insertions, 0 deletions
diff --git a/sci-libs/ccfits/Manifest b/sci-libs/ccfits/Manifest
new file mode 100644
index 000000000000..13e11de12311
--- /dev/null
+++ b/sci-libs/ccfits/Manifest
@@ -0,0 +1 @@
+DIST CCfits-2.4.tar.gz 1792643 SHA256 ba6c5012b260adf7633f92581279ea582e331343d8c973981aa7de07242bd7f8 SHA512 b12d455bb6dd631056e02a12e996d3bf0b6169f8922011e4b64f979b08d2ab8f405e14947c6f5d26ad18bf2f5764854a84987ae105944515f533fe6b0b4ef7be WHIRLPOOL 7f0ca6f0e684f7d66d7272a89dbeb8fa95e3907f358ec624f5f817311288fdfb6467ec915d0ab9f2eee753fcaee3f4b68f497c2dffcf7a38bdce9a7f97681e2a
diff --git a/sci-libs/ccfits/ccfits-2.4.ebuild b/sci-libs/ccfits/ccfits-2.4.ebuild
new file mode 100644
index 000000000000..f309dc2c30d7
--- /dev/null
+++ b/sci-libs/ccfits/ccfits-2.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils autotools
+
+MYPN=CCfits
+MYP=${MYPN}-${PV}
+
+DESCRIPTION="C++ interface for cfitsio"
+HOMEPAGE="http://heasarc.gsfc.nasa.gov/fitsio/CCfits/"
+SRC_URI="${HOMEPAGE}/${MYP}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc static-libs"
+
+RDEPEND=">=sci-libs/cfitsio-3.080"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MYPN}"
+
+src_prepare() {
+ # avoid building cookbook by default and no rpath
+ epatch "${FILESDIR}"/${PN}-2.2-makefile.patch
+ AT_M4DIR=config/m4 eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install () {
+ default
+ use doc && dodoc *.pdf && dohtml -r html/*
+}
diff --git a/sci-libs/ccfits/files/ccfits-2.2-makefile.patch b/sci-libs/ccfits/files/ccfits-2.2-makefile.patch
new file mode 100644
index 000000000000..e92d9306900c
--- /dev/null
+++ b/sci-libs/ccfits/files/ccfits-2.2-makefile.patch
@@ -0,0 +1,26 @@
+--- Makefile.am.orig 2010-01-20 02:52:22.000000000 +0000
++++ Makefile.am 2010-01-20 02:50:34.000000000 +0000
+@@ -26,12 +26,11 @@
+ EXTRA_DIST = config CHANGES README.INSTALL License.txt file1.pha $(MSVC_FILES)
+
+
+-bin_PROGRAMS = cookbook
++check_PROGRAMS = cookbook
+
+ cookbook_SOURCES = cookbook.cxx
+
+ cookbook_LDADD = libCCfits.la
+-cookbook_LDFLAGS = -R $(R_LIB_PATH) -R $(CXX_LIB_PATH)
+
+ pkgconfigdir = $(libdir)/pkgconfig
+ pkgconfig_DATA = CCfits.pc
+@@ -64,8 +63,7 @@
+
+ # This will tell shared library which STD C++ library to use without
+ # needing the user to use LD_LIBRARY_PATH environment variable
+-libCCfits_la_LIBADD = $(LIBSTDCPP)
+-libCCfits_la_LDFLAGS = -R $(R_LIB_PATH) -R $(CXX_LIB_PATH)
++#libCCfits_la_LIBADD = $(LIBSTDCPP)
+
+ libCCfits_ladir = $(pkgincludedir)
+
diff --git a/sci-libs/ccfits/metadata.xml b/sci-libs/ccfits/metadata.xml
new file mode 100644
index 000000000000..b4532406f703
--- /dev/null
+++ b/sci-libs/ccfits/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ CCfits is an object oriented interface to the cfitsio library. It is
+ designed to make the capabilities of cfitsio available to
+ programmers working in C++. It is written in ANSI C++ and
+ implemented using the C++ Standard Library with namespaces,
+ exception handling, and member template functions.
+</longdescription>
+</pkgmetadata>