summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2022-08-02 12:25:22 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2022-08-02 12:25:59 +0200
commitae706e6aa468e81c88198f805c9a441b42f3d838 (patch)
tree15360665f7ee775a241421de02a9166d20773d25 /sci-libs/linux-gpib-modules
parentdev-java/maven-bin: bump to 3.8.6 (diff)
downloadgentoo-ae706e6aa468e81c88198f805c9a441b42f3d838.tar.gz
gentoo-ae706e6aa468e81c88198f805c9a441b42f3d838.tar.bz2
gentoo-ae706e6aa468e81c88198f805c9a441b42f3d838.zip
sci-libs/linux-gpib-modules: Fix build if modules dir does not exist yet
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'sci-libs/linux-gpib-modules')
-rw-r--r--sci-libs/linux-gpib-modules/files/linux-gpib-modules-4.3.4-depmod.patch21
-rw-r--r--sci-libs/linux-gpib-modules/linux-gpib-modules-4.3.4-r1.ebuild3
2 files changed, 24 insertions, 0 deletions
diff --git a/sci-libs/linux-gpib-modules/files/linux-gpib-modules-4.3.4-depmod.patch b/sci-libs/linux-gpib-modules/files/linux-gpib-modules-4.3.4-depmod.patch
new file mode 100644
index 000000000000..e858b974324c
--- /dev/null
+++ b/sci-libs/linux-gpib-modules/files/linux-gpib-modules-4.3.4-depmod.patch
@@ -0,0 +1,21 @@
+Depmod fails here since we're still in DESTDIR and the actual target path may
+not exist...
+
+
+diff -ruN linux-gpib-kernel-4.3.4.orig/Makefile linux-gpib-kernel-4.3.4/Makefile
+--- linux-gpib-kernel-4.3.4.orig/Makefile 2020-12-29 10:42:34.000000000 +0100
++++ linux-gpib-kernel-4.3.4/Makefile 2022-08-02 12:21:38.097344102 +0200
+@@ -20,13 +20,9 @@
+ M="$(GPIB_SRCDIR)/drivers/gpib" \
+ GPIB_TOP_DIR=$(GPIB_SRCDIR)
+
+-#We run depmod explicitly because the depmod.sh script run
+-#by modules_install fails on Debian due to it failing to find
+-#the System.map file.
+ install:
+ $(MAKE) -C $(LINUX_SRCDIR) V=$(VERBOSE) modules_install\
+ M="$(GPIB_SRCDIR)/drivers/gpib" \
+ GPIB_TOP_DIR=$(GPIB_SRCDIR) \
+ INSTALL_MOD_DIR=gpib
+- /sbin/depmod -A
+
diff --git a/sci-libs/linux-gpib-modules/linux-gpib-modules-4.3.4-r1.ebuild b/sci-libs/linux-gpib-modules/linux-gpib-modules-4.3.4-r1.ebuild
index deba2dcfbbd1..40897bc634f4 100644
--- a/sci-libs/linux-gpib-modules/linux-gpib-modules-4.3.4-r1.ebuild
+++ b/sci-libs/linux-gpib-modules/linux-gpib-modules-4.3.4-r1.ebuild
@@ -25,6 +25,9 @@ BDEPEND="virtual/pkgconfig"
PATCHES=(
# https://sourceforge.net/p/linux-gpib/code/1998/
"${FILESDIR}/${P}-kernel-5.17.patch"
+
+ # don't fix debian bugs if they break gentoo
+ "${FILESDIR}/${P}-depmod.patch"
)
pkg_setup() {