summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2018-04-24 10:46:49 -0500
committerMatthias Maier <tamiko@gentoo.org>2018-04-24 10:57:50 -0500
commitbd84cce2dfe50850ea463a41a04521919eb4dfce (patch)
treec5608eae7d9844b70588bdd23d082ec2980f9a2c /sci-libs/netcdf-cxx/netcdf-cxx-4.3.0.ebuild
parentsci-libs/netcdf: version bump to 4.6.1 (diff)
downloadgentoo-bd84cce2dfe50850ea463a41a04521919eb4dfce.tar.gz
gentoo-bd84cce2dfe50850ea463a41a04521919eb4dfce.tar.bz2
gentoo-bd84cce2dfe50850ea463a41a04521919eb4dfce.zip
sci-libs/netcdf-cxx: version bump to 4.3.0:0
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'sci-libs/netcdf-cxx/netcdf-cxx-4.3.0.ebuild')
-rw-r--r--sci-libs/netcdf-cxx/netcdf-cxx-4.3.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-libs/netcdf-cxx/netcdf-cxx-4.3.0.ebuild b/sci-libs/netcdf-cxx/netcdf-cxx-4.3.0.ebuild
new file mode 100644
index 000000000000..3b997cf9c659
--- /dev/null
+++ b/sci-libs/netcdf-cxx/netcdf-cxx-4.3.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+MYP=${PN}4-${PV}
+
+DESCRIPTION="C++ library for netCDF"
+HOMEPAGE="http://www.unidata.ucar.edu/software/netcdf/"
+SRC_URI="https://github.com/Unidata/netcdf-cxx4/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="UCAR-Unidata"
+SLOT="0/1"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples static-libs"
+
+RDEPEND=">=sci-libs/netcdf-4.2:=[hdf5]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MYP}"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use examples && dodoc -r examples
+ prune_libtool_files
+}