summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-13 18:40:23 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-13 18:40:23 +0100
commit7043fcf71d39c109aafc7a53d0f83344a0d7ad18 (patch)
tree96e33a1b82d8878c0ed127ce3b5ee7dd86394288 /sci-libs/oc
parentapp-backup/backup-manager: fix path in purge command (diff)
downloadgentoo-7043fcf71d39c109aafc7a53d0f83344a0d7ad18.tar.gz
gentoo-7043fcf71d39c109aafc7a53d0f83344a0d7ad18.tar.bz2
gentoo-7043fcf71d39c109aafc7a53d0f83344a0d7ad18.zip
sci-libs/oc: Port to EAPI 7
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs/oc')
-rw-r--r--sci-libs/oc/oc-2.0.ebuild25
1 files changed, 16 insertions, 9 deletions
diff --git a/sci-libs/oc/oc-2.0.ebuild b/sci-libs/oc/oc-2.0.ebuild
index f44b5451489a..24434e06661f 100644
--- a/sci-libs/oc/oc-2.0.ebuild
+++ b/sci-libs/oc/oc-2.0.ebuild
@@ -1,26 +1,33 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-inherit autotools-utils
+EAPI=7
DESCRIPTION="Network Data Access Protocol client C library"
HOMEPAGE="http://opendap.org/"
SRC_URI="http://opendap.org/pub/OC/source/${P}.tar.gz"
LICENSE="LGPL-2"
-
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc static-libs"
+IUSE="doc"
+# tests need network
+RESTRICT="test"
RDEPEND="net-misc/curl"
DEPEND="${RDEPEND}"
-# tests need network
-#PROPERTIES=network
+src_configure() {
+ econf --disable-static
+}
src_install() {
- autotools-utils_src_install
- use doc; dodoc docs/oc*html && dohtml docs/html/*
+ if use doc; then
+ dodoc docs/oc*html
+ HTML_DOCS=( docs/html/. )
+ fi
+ default
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
}