summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2023-10-03 13:54:08 -0400
committerRick Farina <zerochaos@gentoo.org>2023-10-03 13:54:16 -0400
commit0e3a9f091c0d6b501f9eeb5ec2044b54a6700c6c (patch)
treef7560142c1cb11760012c9978039a14d5adbb515 /sci-libs
parentapp-editors/ghex: keyword for ~arm64 (diff)
downloadgentoo-0e3a9f091c0d6b501f9eeb5ec2044b54a6700c6c.tar.gz
gentoo-0e3a9f091c0d6b501f9eeb5ec2044b54a6700c6c.tar.bz2
gentoo-0e3a9f091c0d6b501f9eeb5ec2044b54a6700c6c.zip
sci-libs/volk: add 9999
I needed this to test a bug fix, so I'm keeping it. Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/volk/volk-9999.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/sci-libs/volk/volk-9999.ebuild b/sci-libs/volk/volk-9999.ebuild
new file mode 100644
index 000000000000..f86ccd6d99f6
--- /dev/null
+++ b/sci-libs/volk/volk-9999.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+
+#https://github.com/gnuradio/volk/issues/383
+CMAKE_BUILD_TYPE="None"
+inherit cmake python-single-r1
+
+DESCRIPTION="vector optimized library of kernels"
+HOMEPAGE="http://libvolk.org"
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gnuradio/volk.git"
+else
+ SRC_URI="https://github.com/gnuradio/volk/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~riscv ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0/$(ver_cut 1-2)"
+IUSE="orc test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RDEPEND="${PYTHON_DEPS}
+ orc? ( dev-lang/orc )"
+DEPEND="${RDEPEND}
+ $(python_gen_cond_dep 'dev-python/mako[${PYTHON_USEDEP}]')"
+
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_ORC=$(usex orc)
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ -DENABLE_TESTING="$(usex test)"
+ -DENABLE_PROFILING=OFF
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ # Remove stray python files generated by the build system
+ find "${ED}" -name '*.pyc' -exec rm -f {} \; || die
+ find "${ED}" -name '*.pyo' -exec rm -f {} \; || die
+ python_optimize
+}
+
+src_test() {
+ local myctestargs=(
+ -E "(check_lgpl)"
+ )
+ cmake_src_test
+}