summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorband-a-prend <torokhov-s-a@yandex.ru>2019-07-18 13:08:02 +0300
committerMichał Górny <mgorny@gentoo.org>2019-07-19 18:44:58 +0200
commit960d18cd7146b2462d7b1eaf09b5cb46ab6072c5 (patch)
tree075788cce2b17450dbe6d8104ecb5065b83fc07d /sci-libs
parentsci-libs/cantera: 2.4.0-r1. Update/merge cantera_* patches (diff)
downloadgentoo-960d18cd7146b2462d7b1eaf09b5cb46ab6072c5.tar.gz
gentoo-960d18cd7146b2462d7b1eaf09b5cb46ab6072c5.tar.bz2
gentoo-960d18cd7146b2462d7b1eaf09b5cb46ab6072c5.zip
sci-libs/cantera: 2.4.0-r1. Switch to EAPI 7
Closes: https://github.com/gentoo/gentoo/pull/12303 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/cantera/cantera-2.4.0-r1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sci-libs/cantera/cantera-2.4.0-r1.ebuild b/sci-libs/cantera/cantera-2.4.0-r1.ebuild
index 99d4566ae1e1..15cb1776f092 100644
--- a/sci-libs/cantera/cantera-2.4.0-r1.ebuild
+++ b/sci-libs/cantera/cantera-2.4.0-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python3_{5,6,7} )
@@ -100,12 +100,12 @@ src_test() {
}
src_install() {
- escons install stage_dir="${D%/}" libdirname="$(get_libdir)"
+ escons install stage_dir="${D}" libdirname="$(get_libdir)"
if ! use cti ; then
- rm -r "${D%/}/usr/share/man" || die "Can't remove man files."
+ rm -r "${D}/usr/share/man" || die "Can't remove man files."
else
# Run the byte-compile of modules
- python_optimize "${D%/}/$(python_get_sitedir)/${PN}"
+ python_optimize "${D}/$(python_get_sitedir)/${PN}"
fi
}