summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-02-26 10:28:22 +0100
committerDavid Seifert <soap@gentoo.org>2017-02-26 10:29:39 +0100
commit3a5dd6e856ca85aecc1edce3d87b9cf86ed2a56b (patch)
treec59708b17222a540c30c5b7809ab0a4a21faccec /sci-mathematics/octave
parentprefix/package.mask: add upstream bug for libidn2 mask (diff)
downloadgentoo-3a5dd6e856ca85aecc1edce3d87b9cf86ed2a56b.tar.gz
gentoo-3a5dd6e856ca85aecc1edce3d87b9cf86ed2a56b.tar.bz2
gentoo-3a5dd6e856ca85aecc1edce3d87b9cf86ed2a56b.zip
sci-mathematics/octave: Update USE=im/gm semantics to match #314431
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sci-mathematics/octave')
-rw-r--r--sci-mathematics/octave/octave-3.6.4-r1.ebuild (renamed from sci-mathematics/octave/octave-3.6.4.ebuild)17
-rw-r--r--sci-mathematics/octave/octave-3.8.2-r3.ebuild (renamed from sci-mathematics/octave/octave-3.8.2-r2.ebuild)17
-rw-r--r--sci-mathematics/octave/octave-4.2.0-r4.ebuild (renamed from sci-mathematics/octave/octave-4.2.0-r3.ebuild)19
3 files changed, 18 insertions, 35 deletions
diff --git a/sci-mathematics/octave/octave-3.6.4.ebuild b/sci-mathematics/octave/octave-3.6.4-r1.ebuild
index f25a0fdee2c2..d3a25179a677 100644
--- a/sci-mathematics/octave/octave-3.6.4.ebuild
+++ b/sci-mathematics/octave/octave-3.6.4-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -17,7 +17,6 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
SLOT="0/${PV}"
IUSE="curl doc fftw +glpk gnuplot graphicsmagick hdf5 +imagemagick opengl postscript
+qhull +qrupdate readline +sparse static-libs X zlib"
-REQUIRED_USE="?? ( graphicsmagick imagemagick )"
KEYWORDS="amd64 ~arm hppa ppc ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux"
RDEPEND="
@@ -30,8 +29,10 @@ RDEPEND="
glpk? ( sci-mathematics/glpk )
gnuplot? ( sci-visualization/gnuplot )
hdf5? ( sci-libs/hdf5 )
- graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
- imagemagick? ( media-gfx/imagemagick:=[cxx] )
+ imagemagick? (
+ !graphicsmagick? ( media-gfx/imagemagick:=[cxx] )
+ graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
+ )
opengl? (
media-libs/freetype:2
media-libs/fontconfig
@@ -99,6 +100,7 @@ src_configure() {
$(use_with fftw fftw3f)
$(use_with glpk)
$(use_with hdf5)
+ $(use_with imagemagick magick $(usex graphicsmagick GraphicsMagick ImageMagick))
$(use_with opengl)
$(use_with qhull)
$(use_with qrupdate)
@@ -111,13 +113,6 @@ src_configure() {
$(use_with X x)
$(use_with zlib z)
)
- if use graphicsmagick; then
- myeconfargs+=( "--with-magick=GraphicsMagick" )
- elif use imagemagick; then
- myeconfargs+=( "--with-magick=ImageMagick" )
- else
- myeconfargs+=( "--without-magick" )
- fi
autotools-utils_src_configure
}
diff --git a/sci-mathematics/octave/octave-3.8.2-r2.ebuild b/sci-mathematics/octave/octave-3.8.2-r3.ebuild
index aa4c3f0c493e..1db0b9dc4d70 100644
--- a/sci-mathematics/octave/octave-3.8.2-r2.ebuild
+++ b/sci-mathematics/octave/octave-3.8.2-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -17,7 +17,6 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
SLOT="0/${PV}"
IUSE="curl doc fftw +glpk gnuplot graphicsmagick gui hdf5 +imagemagick java opengl
postscript +qhull +qrupdate readline +sparse static-libs X zlib"
-REQUIRED_USE="?? ( graphicsmagick imagemagick )"
KEYWORDS="amd64 ~arm hppa ppc ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux"
RDEPEND="
@@ -31,8 +30,10 @@ RDEPEND="
gnuplot? ( sci-visualization/gnuplot )
gui? ( x11-libs/qscintilla:=[qt4(-)] )
hdf5? ( sci-libs/hdf5:0= )
- graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
- imagemagick? ( media-gfx/imagemagick:=[cxx] )
+ imagemagick? (
+ !graphicsmagick? ( media-gfx/imagemagick:=[cxx] )
+ graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
+ )
java? ( >=virtual/jre-1.6.0:* )
opengl? (
media-libs/freetype:2=
@@ -117,6 +118,7 @@ src_configure() {
$(use_enable fftw fftw-threads)
$(use_with glpk)
$(use_with hdf5)
+ $(use_with imagemagick magick $(usex graphicsmagick GraphicsMagick ImageMagick))
$(use_with opengl)
$(use_with qhull)
$(use_with qrupdate)
@@ -129,13 +131,6 @@ src_configure() {
$(use_with X x)
$(use_with zlib z)
)
- if use graphicsmagick; then
- myeconfargs+=( "--with-magick=GraphicsMagick" )
- elif use imagemagick; then
- myeconfargs+=( "--with-magick=ImageMagick" )
- else
- myeconfargs+=( "--without-magick" )
- fi
autotools-utils_src_configure
}
diff --git a/sci-mathematics/octave/octave-4.2.0-r3.ebuild b/sci-mathematics/octave/octave-4.2.0-r4.ebuild
index 32bcf4c71384..4570c991f586 100644
--- a/sci-mathematics/octave/octave-4.2.0-r3.ebuild
+++ b/sci-mathematics/octave/octave-4.2.0-r4.ebuild
@@ -14,7 +14,6 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
SLOT="0/${PV}"
IUSE="curl doc fftw +glpk gnuplot graphicsmagick gui hdf5 +imagemagick java opengl openssl
portaudio postscript +qhull +qrupdate readline sndfile +sparse static-libs X zlib"
-REQUIRED_USE="?? ( graphicsmagick imagemagick )"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
RDEPEND="
@@ -30,8 +29,10 @@ RDEPEND="
glpk? ( sci-mathematics/glpk:0= )
gnuplot? ( sci-visualization/gnuplot )
hdf5? ( sci-libs/hdf5:0= )
- graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
- imagemagick? ( media-gfx/imagemagick:=[cxx] )
+ imagemagick? (
+ !graphicsmagick? ( media-gfx/imagemagick:=[cxx] )
+ graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
+ )
java? ( >=virtual/jre-1.6.0:* )
opengl? (
media-libs/freetype:2=
@@ -115,16 +116,7 @@ src_configure() {
use hdf5 && has_version sci-libs/hdf5[mpi] && \
export CXX=mpicxx CC=mpicc FC=mpif77 F77=mpif77
- local myconf=()
- if use graphicsmagick; then
- myconf+=( --with-magick=GraphicsMagick )
- elif use imagemagick; then
- myconf+=( --with-magick=ImageMagick )
- else
- myconf+=( --without-magick )
- fi
-
- econf "${myconf[@]}" \
+ econf \
--localstatedir="${EPREFIX}/var/state/octave" \
--with-blas="$($(tc-getPKG_CONFIG) --libs blas)" \
--with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)" \
@@ -144,6 +136,7 @@ src_configure() {
$(use_enable fftw fftw-threads) \
$(use_with glpk) \
$(use_with hdf5) \
+ $(use_with imagemagick magick $(usex graphicsmagick GraphicsMagick ImageMagick)) \
$(use_with opengl) \
$(use_with opengl fltk) \
$(use_with openssl) \