summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2019-07-27 20:41:54 +0200
committerTupone Alfredo <tupone@gentoo.org>2019-07-27 20:41:54 +0200
commit225867b2a2585985159c833ba3d819e35da1860e (patch)
treea00e39148a6fd332bf7d33beb4057c250049d607 /sci-mathematics
parentdev-tex/dvipost: remove old (diff)
downloadgentoo-225867b2a2585985159c833ba3d819e35da1860e.tar.gz
gentoo-225867b2a2585985159c833ba3d819e35da1860e.tar.bz2
gentoo-225867b2a2585985159c833ba3d819e35da1860e.zip
sci-mathematics/alt-ergo: bump to 2.3.0
Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/alt-ergo/Manifest1
-rw-r--r--sci-mathematics/alt-ergo/alt-ergo-2.3.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/sci-mathematics/alt-ergo/Manifest b/sci-mathematics/alt-ergo/Manifest
index 9650afa0fb74..32a72ea3d18f 100644
--- a/sci-mathematics/alt-ergo/Manifest
+++ b/sci-mathematics/alt-ergo/Manifest
@@ -1 +1,2 @@
DIST alt-ergo-1.30.tar.gz 380329 BLAKE2B fab16757ed110474cf8f9d01ab53f76b6a300eb478b32bbfd6bb79d7603b1f5c2fc5c97bf44358eb138283f3487ef90febd23865723a4721b01bd870cfdd6507 SHA512 6ac6abdc6602b0ba89ee58eb96c66ac93e8195e0b4f75595381eded86365c2dd881251de2b77e2f1137684651ddc7fd94f922509de0be2964d81f52a6fb0f2f2
+DIST alt-ergo-2.3.0.tar.gz 455577 BLAKE2B 1836782be452df5147fc3041517fd267f3ce7facd15ad460c3e1dfba2b6ea455fee79ad8264ccb12cf21622c21a54c186c9943e7bffb392daab15d046ff93863 SHA512 a2f209b62b8494bfefe84328cdc786185e0534c5e224e212b83045b078352a51d2ab02622f72c22c74c7de95c7a554cbdae2a9a8a0c41f3f26c841f8c72f6b21
diff --git a/sci-mathematics/alt-ergo/alt-ergo-2.3.0.ebuild b/sci-mathematics/alt-ergo/alt-ergo-2.3.0.ebuild
new file mode 100644
index 000000000000..69ade990ba8f
--- /dev/null
+++ b/sci-mathematics/alt-ergo/alt-ergo-2.3.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Automatic theorem prover"
+HOMEPAGE="https://alt-ergo.ocamlpro.com"
+SRC_URI="https://alt-ergo.ocamlpro.com/http/${P}/${P}.tar.gz"
+
+LICENSE="CeCILL-C"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples gtk +ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-3.12.1[ocamlopt?]
+ dev-ml/zarith
+ gtk? ( >=dev-ml/lablgtk-2.14[sourceview,ocamlopt?] )
+ dev-ml/camlzip
+ >=dev-ml/ocplib-simplex-0.4
+ >=dev-ml/menhir-20181006
+ dev-ml/dune"
+RDEPEND="${DEPEND}"
+
+DOCS=( CHANGES INSTALL.md README.md )
+
+src_configure() {
+ ./configure --prefix /usr --libdir=/usr/$(get_libdir)
+}
+
+src_compile() {
+ emake
+ use gtk && emake gui
+}
+
+src_install() {
+ default
+ use gtk && emake DESTDIR="${D}" install-gui
+ insinto /usr/share/doc/${PF}
+ use examples && doins -r examples
+ mv "${D}"/usr/doc/* "${D}"/usr/share/doc/${PF}/ || die
+ rmdir "${D}"/usr/doc || die
+}