summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-misc/apertium
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-misc/apertium')
-rw-r--r--sci-misc/apertium/Manifest1
-rw-r--r--sci-misc/apertium/apertium-3.2.0.ebuild35
-rw-r--r--sci-misc/apertium/files/3.2.0-datadir.patch35
-rw-r--r--sci-misc/apertium/files/3.2.0-flags.patch72
-rw-r--r--sci-misc/apertium/files/apertium-3.2.0-libpcre.patch43
-rw-r--r--sci-misc/apertium/metadata.xml12
6 files changed, 198 insertions, 0 deletions
diff --git a/sci-misc/apertium/Manifest b/sci-misc/apertium/Manifest
new file mode 100644
index 000000000000..676f259b7e51
--- /dev/null
+++ b/sci-misc/apertium/Manifest
@@ -0,0 +1 @@
+DIST apertium-3.2.0.tar.gz 767311 SHA256 6ce2fdc85da5d1e50d69da2e50cc97a87b689476f2c83417765636d9a4b7e9ac SHA512 ec80d72480e414eb9a169241d0921b21009dde7c1da9a773f500f16ac785741be1f4a221c25b3b32e7847405f76e93b5feadb6f541170c0742718e27dfa1fb25 WHIRLPOOL 44b8c6fcda7abe363540d1b3ce344322bec60ff1b822ffb5f228a50b156f9660798a9aafa3c9ccf25652cf858be32efb41b06d5d05e7d8fd3284db7d81aac4a4
diff --git a/sci-misc/apertium/apertium-3.2.0.ebuild b/sci-misc/apertium/apertium-3.2.0.ebuild
new file mode 100644
index 000000000000..1cce57a6fe7e
--- /dev/null
+++ b/sci-misc/apertium/apertium-3.2.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils
+
+DESCRIPTION="Shallow-transfer machine Translation engine and toolbox"
+HOMEPAGE="http://apertium.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RDEPEND="
+ dev-libs/libxslt
+ dev-libs/libpcre[cxx]
+ >=sci-misc/lttoolbox-3.2
+ virtual/libiconv"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-flags.patch
+ "${FILESDIR}"/${PV}-datadir.patch
+ "${FILESDIR}"/${P}-libpcre.patch
+ )
+
+MAKEOPTS+=" -j1"
+AUTOTOOLS_IN_SOURCE_BUILD=1
diff --git a/sci-misc/apertium/files/3.2.0-datadir.patch b/sci-misc/apertium/files/3.2.0-datadir.patch
new file mode 100644
index 000000000000..d081cd50bc79
--- /dev/null
+++ b/sci-misc/apertium/files/3.2.0-datadir.patch
@@ -0,0 +1,35 @@
+diff -Nur apertium-3.2.0.orig/apertium/Makefile.am apertium-3.2.0/apertium/Makefile.am
+--- apertium-3.2.0.orig/apertium/Makefile.am 2011-07-29 06:55:49.000000000 +0100
++++ apertium-3.2.0/apertium/Makefile.am 2011-07-29 07:03:58.000000000 +0100
+@@ -66,10 +66,10 @@
+
+ instdir = apertium
+
+-apertiumdir = $(prefix)/share/apertium
++apertiumdir = $(datadir)/
+ apertiuminclude = $(prefix)/include/apertium-$(GENERIC_API_VERSION)
+ apertiumlib = $(prefix)/lib
+-apertiumsysconf = $(prefix)/etc/apertium
++apertiumsysconf = $(sysconfdir)/apertium
+
+ apertium_DATA = deformat.xsl reformat.xsl new2old.xsl lexchoice.xsl \
+ lexchoicebil.xsl tagger.dtd interchunk.dtd format.dtd \
+diff -Nur apertium-3.2.0.orig/Makefile.am apertium-3.2.0/Makefile.am
+--- apertium-3.2.0.orig/Makefile.am 2011-07-29 06:55:49.000000000 +0100
++++ apertium-3.2.0/Makefile.am 2011-07-29 07:08:39.000000000 +0100
+@@ -1,13 +1,10 @@
+ SUBDIRS = $(GENERIC_LIBRARY_NAME)
+ DIST_SUBDIRS = $(GENERIC_LIBRARY_NAME)
+
+-modesdir=$(prefix)/share/apertium/modes
++modesdir = $(datadir)/apertium/modes
++modes_DATA = README-MODES
+
+ pkgconfigdir = $(libdir)/pkgconfig
+ pkgconfig_DATA = apertium-$(GENERIC_RELEASE).pc
+
+ EXTRA_DIST=autogen.sh README-MODES
+-
+-install-data-local:
+- mkdir -p $(modesdir)
+- $(INSTALL_DATA) README-MODES $(modesdir)/README
diff --git a/sci-misc/apertium/files/3.2.0-flags.patch b/sci-misc/apertium/files/3.2.0-flags.patch
new file mode 100644
index 000000000000..9bdc4a34c117
--- /dev/null
+++ b/sci-misc/apertium/files/3.2.0-flags.patch
@@ -0,0 +1,72 @@
+diff -Nur apertium-3.2.0.orig/configure.ac apertium-3.2.0/configure.ac
+--- apertium-3.2.0.orig/configure.ac 2011-07-29 06:43:38.000000000 +0100
++++ apertium-3.2.0/configure.ac 2011-07-29 06:46:26.000000000 +0100
+@@ -54,68 +54,6 @@
+
+ # Checks for programs.
+
+-AC_MSG_CHECKING([Compilation architecture: PPC, i686, x86_64, Other])
+-if test x$(which arch) = x
+-then ARCH=$($(which uname) -m)
+-else ARCH=$($(which arch))
+-fi
+-
+-case "${target_os}" in
+- mingw*)
+- MinGW=yes
+- ;;
+- cygwin*)
+- Cygwin=yes
+- ;;
+-esac
+-
+-if test x$ARCH = xppc
+-then
+- AC_MSG_RESULT([PowerPC])
+- CFLAGS="$CFLAGS -Wall -ansi -fomit-frame-pointer"
+- CXXFLAGS="$CXXFLAGS -Wall -ansi -fomit-frame-pointer"
+-else
+- if test x$MinGW = xyes
+- then
+- AC_MSG_RESULT([MinGW])
+- CFLAGS="$CFLAGS -Wall -march=i686 -O3 -DMINGW -fomit-frame-pointer \
+- -funroll-loops -I/include -L/lib"
+- CXXFLAGS="$CXXFLAGS -Wall -march=i686 -O3 \
+- -fomit-frame-pointer -funroll-loops -I/include -L/lib"
+- CPPFLAGS="$CPPFLAGS -I/include"
+- else
+- if test x$Cygwin = xyes
+- then
+- AC_MSG_RESULT([Cygwin])
+- CFLAGS="$CFLAGS -Wall -march=i686 -O3 -fomit-frame-pointer \
+- -funroll-loops"
+- CXXFLAGS="$CXXFLAGS -Wall -march=i686 -O3 \
+- -fomit-frame-pointer -funroll-loops"
+- CPPFLAGS="$CPPFLAGS"
+- else
+- if test x$ARCH = xi686
+- then
+- AC_MSG_RESULT([i686])
+- CFLAGS="$CFLAGS -Wall -ansi -march=i686 -O3 -fomit-frame-pointer -funroll-loops"
+- CXXFLAGS="$CXXFLAGS -Wall -ansi -march=i686 -O3 \
+- -fomit-frame-pointer -funroll-loops"
+- else
+- if test x$ARCH = xx86_64
+- then
+- AC_MSG_RESULT([x86_64])
+- CFLAGS="-Wall -ansi -O3 -mtune=nocona -fomit-frame-pointer -funroll-loops $CFLAGS"
+- CXXFLAGS="-Wall -ansi -O3 -mtune=nocona \
+- -fomit-frame-pointer -funroll-loops $CXXFLAGS"
+- else
+- AC_MSG_RESULT([Other])
+- CFLAGS="-Wall -ansi -O3 $CFLAGS"
+- CXXFLAGS="-Wall -ansi -O3 $CXXFLAGS"
+- fi
+- fi
+- fi
+- fi
+-fi
+-
+ AC_PROG_CXX
+ AC_PROG_LIBTOOL
+ AM_SANITY_CHECK
diff --git a/sci-misc/apertium/files/apertium-3.2.0-libpcre.patch b/sci-misc/apertium/files/apertium-3.2.0-libpcre.patch
new file mode 100644
index 000000000000..29a6a5483bb8
--- /dev/null
+++ b/sci-misc/apertium/files/apertium-3.2.0-libpcre.patch
@@ -0,0 +1,43 @@
+ configure.ac | 28 ++++++++++++++++------------
+ 1 file changed, 16 insertions(+), 12 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 0bfca01..2d8ec3b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -183,19 +183,23 @@ AC_CHECK_FUNCS(strcasecmp)
+
+ if test x$(uname) != xDarwin;
+ then
+-AC_CHECK_HEADER(pcreposix.h,
+- AC_CHECK_LIB(pcre, pcre_info,[
+- LIBS="$LIBS -lpcreposix -lpcre"
+- no_comp_check=yes],
+- AC_MSG_ERROR([*** unable to locate pcre library ***])),
+- AC_MSG_ERROR([*** unable to locate pcreposix.h include file ***]))
++PKG_CHECK_MODULES([PCRE],
++ [libpcre libpcreposix libpcrecpp],
++ [LIBS="${LIBS} ${PCRE_LIBS}" no_comp_check=yes], [
++ AC_CHECK_HEADER(pcreposix.h,
++ AC_CHECK_LIB(pcre, pcre_version,[
++ LIBS="$LIBS -lpcreposix -lpcre"
++ no_comp_check=yes],
++ AC_MSG_ERROR([*** unable to locate pcre library ***])),
++ AC_MSG_ERROR([*** unable to locate pcreposix.h include file ***]))
+
+-AC_CHECK_HEADER(pcrecpp.h,
+- AC_CHECK_LIB(pcrecpp,pcre_compile,[
+- LIBS="$LIBS -lpcrecpp"
+- no_comp_check=yes],
+- AC_MSG_ERROR([*** unable to locate pcrecpp library ***])),
+- AC_MSG_ERROR([*** unable to locate pcrecpp.h include file ***]))
++ AC_CHECK_HEADER(pcrecpp.h,
++ AC_CHECK_LIB(pcrecpp,pcre_compile,[
++ LIBS="$LIBS -lpcrecpp"
++ no_comp_check=yes],
++ AC_MSG_ERROR([*** unable to locate pcrecpp library ***])),
++ AC_MSG_ERROR([*** unable to locate pcrecpp.h include file ***]))
++ ])
+ fi
+
+
diff --git a/sci-misc/apertium/metadata.xml b/sci-misc/apertium/metadata.xml
new file mode 100644
index 000000000000..4b8ef8827ae3
--- /dev/null
+++ b/sci-misc/apertium/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription lang="en">
+ Apertium is an open-source shallow-transfer machine translation
+ engine and toolbox.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">apertium</remote-id>
+ </upstream>
+</pkgmetadata>