summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-11-28 13:00:12 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-11-28 13:06:28 +0100
commit2f381ca2c55b16caf4a811d6a163c039d2402ca6 (patch)
tree3883f6589588a40dfa09ffa4cafe464e8f0518ea /sci-misc/jupyterlab-desktop-bin
parentsci-misc/jupyterlab-desktop: add version 3.2.4.3 (diff)
downloadgentoo-2f381ca2c55b16caf4a811d6a163c039d2402ca6.tar.gz
gentoo-2f381ca2c55b16caf4a811d6a163c039d2402ca6.tar.bz2
gentoo-2f381ca2c55b16caf4a811d6a163c039d2402ca6.zip
sci-misc/jupyterlab-desktop: rename to jupyterlab-desktop-bin
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-misc/jupyterlab-desktop-bin')
-rw-r--r--sci-misc/jupyterlab-desktop-bin/Manifest2
-rw-r--r--sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-3.2.4.1.ebuild65
-rw-r--r--sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-3.2.4.3.ebuild65
-rw-r--r--sci-misc/jupyterlab-desktop-bin/metadata.xml12
4 files changed, 144 insertions, 0 deletions
diff --git a/sci-misc/jupyterlab-desktop-bin/Manifest b/sci-misc/jupyterlab-desktop-bin/Manifest
new file mode 100644
index 000000000000..6658970bf533
--- /dev/null
+++ b/sci-misc/jupyterlab-desktop-bin/Manifest
@@ -0,0 +1,2 @@
+DIST jupyterlab-desktop-bin-3.2.4.1.rpm 254701500 BLAKE2B efe593518cec942d122edd3ad58c3def25db658ae1ca8b5af05f702fd08bc8614d05f3f379323462f05a616075ccac403981645329615cc9138cea2f82100755 SHA512 ea3efea857a65b7a0e8a409dcbafcc840f924fe9fea073f127dcf31d01a86b6832803a3b67f03cd1f9968c058c792ff9d1650550a44e5cb1e77cc4ab4bf0a813
+DIST jupyterlab-desktop-bin-3.2.4.3.rpm 269019824 BLAKE2B cc4acde522b3cab06e1d4b26ed21352cb20396e766c71da889fb19fae52af0df7c8acd4e9b91083ab944995fdc2f3acf3af28c7320e0da951505ea75e2c70b63 SHA512 6eb5220e149cd2f61cbaf35e377bdd02fefa292eb0145936da6d7b875f68779a47f5a99be12bf57b44840f6b5bdfd3e9923bf0947cbe3c2e155cd5f5e2c64317
diff --git a/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-3.2.4.1.ebuild b/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-3.2.4.1.ebuild
new file mode 100644
index 000000000000..c83878c8b02f
--- /dev/null
+++ b/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-3.2.4.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit rpm xdg
+
+DESCRIPTION="JupyterLab desktop application, based on Electron"
+HOMEPAGE="https://jupyter.org/"
+SRC_URI="https://github.com/jupyterlab/${PN%%-bin}/releases/download/v$(ver_rs 3 -)/JupyterLab-Setup-Fedora.rpm -> ${P}.rpm"
+
+KEYWORDS="-* ~amd64"
+LICENSE="BSD MIT"
+SLOT="0"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk
+ app-accessibility/at-spi2-core
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/glib
+ dev-libs/nspr
+ dev-libs/nss
+ dev-python/jupyterlab
+ media-libs/alsa-lib
+ media-libs/mesa
+ net-print/cups
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libxshmfence
+ x11-libs/pango
+"
+
+QA_PREBUILT="/opt/JupyterLab/*"
+
+S="${WORKDIR}"
+
+src_install() {
+ # remove files useless for Gentoo
+ rm -r usr/lib || die
+ mv "${S}"/* "${ED}" || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ elog ""
+ elog "On initial startup you will be prompted to select the python environment of"
+ elog "your choice. Either select a specific python version, e.g. /usr/bin/pythonX.Y,"
+ elog "or choose /usr/bin/python to follow the system wide setting in"
+ elog "/etc/python-exec/python-exec.conf."
+ elog "Please note that only python environments corresponding to the enabled"
+ elog "PYTHON_TARGETS on dev-python/jupyterlab will work."
+ elog ""
+}
diff --git a/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-3.2.4.3.ebuild b/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-3.2.4.3.ebuild
new file mode 100644
index 000000000000..c83878c8b02f
--- /dev/null
+++ b/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-3.2.4.3.ebuild
@@ -0,0 +1,65 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit rpm xdg
+
+DESCRIPTION="JupyterLab desktop application, based on Electron"
+HOMEPAGE="https://jupyter.org/"
+SRC_URI="https://github.com/jupyterlab/${PN%%-bin}/releases/download/v$(ver_rs 3 -)/JupyterLab-Setup-Fedora.rpm -> ${P}.rpm"
+
+KEYWORDS="-* ~amd64"
+LICENSE="BSD MIT"
+SLOT="0"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk
+ app-accessibility/at-spi2-core
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/glib
+ dev-libs/nspr
+ dev-libs/nss
+ dev-python/jupyterlab
+ media-libs/alsa-lib
+ media-libs/mesa
+ net-print/cups
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libxshmfence
+ x11-libs/pango
+"
+
+QA_PREBUILT="/opt/JupyterLab/*"
+
+S="${WORKDIR}"
+
+src_install() {
+ # remove files useless for Gentoo
+ rm -r usr/lib || die
+ mv "${S}"/* "${ED}" || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ elog ""
+ elog "On initial startup you will be prompted to select the python environment of"
+ elog "your choice. Either select a specific python version, e.g. /usr/bin/pythonX.Y,"
+ elog "or choose /usr/bin/python to follow the system wide setting in"
+ elog "/etc/python-exec/python-exec.conf."
+ elog "Please note that only python environments corresponding to the enabled"
+ elog "PYTHON_TARGETS on dev-python/jupyterlab will work."
+ elog ""
+}
diff --git a/sci-misc/jupyterlab-desktop-bin/metadata.xml b/sci-misc/jupyterlab-desktop-bin/metadata.xml
new file mode 100644
index 000000000000..af73f75812c1
--- /dev/null
+++ b/sci-misc/jupyterlab-desktop-bin/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="github">jupyterlab/jupyterlab-desktop</remote-id>
+ <bugs-to>https://github.com/jupyterlab/jupyterlab-desktop/issues</bugs-to>
+ </upstream>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+</pkgmetadata>