summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-physics/harminv
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-physics/harminv')
-rw-r--r--sci-physics/harminv/Manifest1
-rw-r--r--sci-physics/harminv/files/harminv-1.3.1-configure.ac.patch31
-rw-r--r--sci-physics/harminv/harminv-1.3.1.ebuild32
-rw-r--r--sci-physics/harminv/metadata.xml12
4 files changed, 76 insertions, 0 deletions
diff --git a/sci-physics/harminv/Manifest b/sci-physics/harminv/Manifest
new file mode 100644
index 000000000000..9b56d7c6c959
--- /dev/null
+++ b/sci-physics/harminv/Manifest
@@ -0,0 +1 @@
+DIST harminv-1.3.1.tar.gz 327832 SHA256 245778c16390c22850de3fb716c3db19514d40415ee3693293bfe59c66536583 SHA512 7dc1c2f658d9722cd64558a702f04409d10b87cb4ff7247c2fbd7f8d9a24387fef1b8ba4b7b183727bef21891c32d27d83aaa3607d063f8ad60702be4bfe5c3c WHIRLPOOL 31e3e0c6a5a01431a2d6daf4fdab362576f2f72617e5d89ccb0f04cde147c59185697bfc40c35ca09168bc4a2281468e41b978b091f2445f6eea203cf8aa7a12
diff --git a/sci-physics/harminv/files/harminv-1.3.1-configure.ac.patch b/sci-physics/harminv/files/harminv-1.3.1-configure.ac.patch
new file mode 100644
index 000000000000..2830d5b586f3
--- /dev/null
+++ b/sci-physics/harminv/files/harminv-1.3.1-configure.ac.patch
@@ -0,0 +1,31 @@
+--- configure.ac.orig 2007-09-27 09:27:28.731439558 +0100
++++ configure.ac 2007-09-27 09:37:45.755835491 +0100
+@@ -9,7 +9,7 @@
+ # *not* the same as the "public" version number. CURRENT:REVISION:AGE
+ SHARED_VERSION_INFO="2:4:0"
+ AC_SUBST(SHARED_VERSION_INFO)
+-AM_ENABLE_SHARED(no) dnl shared libs cause too many headaches to be default
++AM_ENABLE_SHARED(yes) dnl shared libs cause too many headaches to be default
+
+ ##############################################################################
+
+@@ -123,9 +123,16 @@
+ ###########################################################################
+
+ # Checks for BLAS/LAPACK libraries:
+-
+-ACX_BLAS([], [AC_MSG_ERROR([BLAS library not found])])
+-ACX_LAPACK([], [AC_MSG_ERROR([LAPACK library not found])])
++sinclude(acx_blas.m4)
++ACX_BLAS
++if test x"$BLAS_LIBS" = x ; then
++ AC_MSG_ERROR([BLAS library not found])
++fi
++sinclude(acx_lapack.m4)
++ACX_LAPACK
++if test x"$LAPACK_LIBS" = x ; then
++ AC_MSG_ERROR([LAPACK library not found])
++fi
+
+ LIBS="$LAPACK_LIBS $BLAS_LIBS $LIBS $FLIBS"
+
diff --git a/sci-physics/harminv/harminv-1.3.1.ebuild b/sci-physics/harminv/harminv-1.3.1.ebuild
new file mode 100644
index 000000000000..8889bc6c4698
--- /dev/null
+++ b/sci-physics/harminv/harminv-1.3.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils eutils toolchain-funcs
+
+DESCRIPTION="Extraction of complex frequencies and amplitudes from time series"
+HOMEPAGE="http://ab-initio.mit.edu/harminv/"
+SRC_URI="http://ab-initio.mit.edu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+RDEPEND="virtual/lapack"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-configure.ac.patch )
+
+src_configure() {
+ local myeconfargs=(
+ --with-blas="$($(tc-getPKG_CONFIG) --libs blas)"
+ --with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)"
+ )
+ autotools-utils_src_configure
+}
diff --git a/sci-physics/harminv/metadata.xml b/sci-physics/harminv/metadata.xml
new file mode 100644
index 000000000000..1d4bdde16401
--- /dev/null
+++ b/sci-physics/harminv/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-physics</herd>
+ <longdescription lang="en">
+ Harminv is a program to solve the problem of harmonic inversion,
+ given a discrete-time, finite-length signal that consists of a sum of
+ finitely-many sinusoids (possibly exponentially decaying) in a given
+ bandwidth, it determines the frequencies, decay constants, amplitudes,
+ and phases of those sinusoids.
+</longdescription>
+</pkgmetadata>