summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2020-06-20 17:40:41 +0200
committerGuilherme Amadio <amadio@gentoo.org>2020-06-20 19:29:00 +0200
commit288a0ff21c8e70296b485441d4d45fc9d09ed1e2 (patch)
tree73b303f902f93c7b9d85e382652bd2f230153a54 /sci-physics/root
parentprofiles/package.mask: remove dev-util/uftrace (diff)
downloadgentoo-288a0ff21c8e70296b485441d4d45fc9d09ed1e2.tar.gz
gentoo-288a0ff21c8e70296b485441d4d45fc9d09ed1e2.tar.bz2
gentoo-288a0ff21c8e70296b485441d4d45fc9d09ed1e2.zip
sci-physics/root: remove unused patches
Closes: https://github.com/gentoo/gentoo/pull/16346 Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'sci-physics/root')
-rw-r--r--sci-physics/root/files/root-6.11.02-hsimple.patch34
-rw-r--r--sci-physics/root/files/root-6.12.04-no-ocaml.patch49
-rw-r--r--sci-physics/root/files/root-6.12.04-no-opengl.patch23
-rw-r--r--sci-physics/root/files/root-6.12.04-z3.patch39
-rw-r--r--sci-physics/root/files/root-6.14.06-oracle.patch24
5 files changed, 0 insertions, 169 deletions
diff --git a/sci-physics/root/files/root-6.11.02-hsimple.patch b/sci-physics/root/files/root-6.11.02-hsimple.patch
deleted file mode 100644
index c1e88bd55b7d..000000000000
--- a/sci-physics/root/files/root-6.11.02-hsimple.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index aa05c02568..ef2b5e3f52 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -354,28 +354,6 @@ add_dependencies(onepcm ${__allTargets})
- install(FILES ${CMAKE_BINARY_DIR}/etc/allDict.cxx.pch DESTINATION ${CMAKE_INSTALL_SYSCONFDIR})
- install(DIRECTORY ${CMAKE_BINARY_DIR}/etc/dictpch DESTINATION ${CMAKE_INSTALL_SYSCONFDIR})
-
--#---hsimple.root---------(use the executable for clearer dependencies and proper return code)---
--if(NOT WIN32)
--add_custom_target(hsimple ALL DEPENDS tutorials/hsimple.root)
--add_dependencies(hsimple onepcm)
--if(WIN32)
-- add_custom_command(OUTPUT tutorials/hsimple.root
-- COMMAND set PATH=${CMAKE_RUNTIME_OUTPUT_DIRECTORY} &&
-- set ROOTIGNOREPREFIX=1 &&
-- $<TARGET_FILE:root.exe> -l -q -b -n -x hsimple.C -e return
-- WORKING_DIRECTORY tutorials
-- DEPENDS $<TARGET_FILE:root.exe> Cling Hist Tree Gpad Graf HistPainter move_artifacts)
--else()
-- add_custom_command(OUTPUT tutorials/hsimple.root
-- COMMAND ${ld_library_path}=${CMAKE_LIBRARY_OUTPUT_DIRECTORY}:$ENV{${ld_library_path}}
-- ROOTIGNOREPREFIX=1
-- $<TARGET_FILE:root.exe> -l -q -b -n -x hsimple.C -e return
-- WORKING_DIRECTORY tutorials
-- DEPENDS $<TARGET_FILE:root.exe> Cling Hist Tree Gpad Graf HistPainter move_artifacts)
--endif()
--install(FILES ${CMAKE_BINARY_DIR}/tutorials/hsimple.root DESTINATION ${CMAKE_INSTALL_TUTDIR} COMPONENT tests)
--endif()
--
- #---version--------------------------------------------------------------------------------------
- if(NOT WIN32)
- add_custom_target(version COMMAND ${CMAKE_SOURCE_DIR}/build/unix/makeversion.sh ${CMAKE_BINARY_DIR}
-
diff --git a/sci-physics/root/files/root-6.12.04-no-ocaml.patch b/sci-physics/root/files/root-6.12.04-no-ocaml.patch
deleted file mode 100644
index 1d91739f01a0..000000000000
--- a/sci-physics/root/files/root-6.12.04-no-ocaml.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-From 7405b8848e7c0d5ddcaa1f27b905b6931dc262e2 Mon Sep 17 00:00:00 2001
-From: Guilherme Amadio <amadio@cern.ch>
-Date: Mon, 18 Dec 2017 13:08:14 +0100
-Subject: [PATCH] Disable OCaml bindings in LLVM
-
----
- interpreter/llvm/src/cmake/config-ix.cmake | 28 ----------------------------
- 1 file changed, 28 deletions(-)
-
-diff --git a/interpreter/llvm/src/cmake/config-ix.cmake b/interpreter/llvm/src/cmake/config-ix.cmake
-index 6fb589cfd3..d1c9a70d10 100644
---- a/interpreter/llvm/src/cmake/config-ix.cmake
-+++ b/interpreter/llvm/src/cmake/config-ix.cmake
-@@ -575,32 +575,4 @@ if(CMAKE_HOST_APPLE AND APPLE)
- endif()
- endif()
-
--# Keep the version requirements in sync with bindings/ocaml/README.txt.
--include(FindOCaml)
--include(AddOCaml)
--if(WIN32)
-- message(STATUS "OCaml bindings disabled.")
--else()
-- find_package(OCaml)
-- if( NOT OCAML_FOUND )
-- message(STATUS "OCaml bindings disabled.")
-- else()
-- if( OCAML_VERSION VERSION_LESS "4.00.0" )
-- message(STATUS "OCaml bindings disabled, need OCaml >=4.00.0.")
-- else()
-- find_ocamlfind_package(ctypes VERSION 0.4 OPTIONAL)
-- if( HAVE_OCAML_CTYPES )
-- message(STATUS "OCaml bindings enabled.")
-- find_ocamlfind_package(oUnit VERSION 2 OPTIONAL)
-- set(LLVM_BINDINGS "${LLVM_BINDINGS} ocaml")
--
-- set(LLVM_OCAML_INSTALL_PATH "${OCAML_STDLIB_PATH}" CACHE STRING
-- "Install directory for LLVM OCaml packages")
-- else()
-- message(STATUS "OCaml bindings disabled, need ctypes >=0.4.")
-- endif()
-- endif()
-- endif()
--endif()
--
- string(REPLACE " " ";" LLVM_BINDINGS_LIST "${LLVM_BINDINGS}")
---
-2.15.1
-
diff --git a/sci-physics/root/files/root-6.12.04-no-opengl.patch b/sci-physics/root/files/root-6.12.04-no-opengl.patch
deleted file mode 100644
index 319020222e53..000000000000
--- a/sci-physics/root/files/root-6.12.04-no-opengl.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-diff --git a/cmake/modules/SearchInstalledSoftware.cmake b/cmake/modules/SearchInstalledSoftware.cmake
-index a68c462eb3..1e82e57241 100644
---- a/cmake/modules/SearchInstalledSoftware.cmake
-+++ b/cmake/modules/SearchInstalledSoftware.cmake
-@@ -499,7 +499,7 @@ if(opengl)
- endif()
-
- #---Check for gl2ps ------------------------------------------------------------------
--if(NOT builtin_gl2ps)
-+if(gl2ps AND NOT builtin_gl2ps)
- message(STATUS "Looking for gl2ps")
- find_Package(gl2ps)
- if(NOT GL2PS_FOUND)
-@@ -999,7 +999,7 @@ if(globus)
- endif()
-
- #---Check for ftgl if needed----------------------------------------------------------
--if(NOT builtin_ftgl)
-+if(ftgl AND NOT builtin_ftgl)
- find_package(FTGL)
- if(NOT FTGL_FOUND)
- if(fail-on-missing)
-
diff --git a/sci-physics/root/files/root-6.12.04-z3.patch b/sci-physics/root/files/root-6.12.04-z3.patch
deleted file mode 100644
index 04f6edf2c6d5..000000000000
--- a/sci-physics/root/files/root-6.12.04-z3.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From 4445e05660493841b5fb683c7e8a8dc6c08564ac Mon Sep 17 00:00:00 2001
-From: Guilherme Amadio <amadio@cern.ch>
-Date: Mon, 18 Dec 2017 11:49:55 +0100
-Subject: [PATCH] Only look for Z3 if necessary
-
----
- interpreter/llvm/src/tools/clang/CMakeLists.txt | 9 ++-------
- 1 file changed, 2 insertions(+), 7 deletions(-)
-
-diff --git a/interpreter/llvm/src/tools/clang/CMakeLists.txt b/interpreter/llvm/src/tools/clang/CMakeLists.txt
-index 2667b1d689..a1559d9b15 100644
---- a/interpreter/llvm/src/tools/clang/CMakeLists.txt
-+++ b/interpreter/llvm/src/tools/clang/CMakeLists.txt
-@@ -186,8 +186,6 @@ if (LIBXML2_FOUND)
- set(CLANG_HAVE_LIBXML 1)
- endif()
-
--find_package(Z3 4.5)
--
- include(CheckIncludeFile)
- check_include_file(sys/resource.h CLANG_HAVE_RLIMITS)
-
-@@ -381,11 +379,8 @@ if(NOT CLANG_ENABLE_STATIC_ANALYZER AND (CLANG_ENABLE_ARCMT OR CLANG_ANALYZER_BU
- endif()
-
- if(CLANG_ANALYZER_BUILD_Z3)
-- if(Z3_FOUND)
-- set(CLANG_ANALYZER_WITH_Z3 1)
-- else()
-- message(FATAL_ERROR "Cannot find Z3 header file or shared library")
-- endif()
-+ find_package(Z3 4.5 REQUIRED)
-+ set(CLANG_ANALYZER_WITH_Z3 1)
- endif()
-
- if(CLANG_ENABLE_ARCMT)
---
-2.15.1
-
diff --git a/sci-physics/root/files/root-6.14.06-oracle.patch b/sci-physics/root/files/root-6.14.06-oracle.patch
deleted file mode 100644
index 232d3b08cfa3..000000000000
--- a/sci-physics/root/files/root-6.14.06-oracle.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From: Guilherme Amadio <amadio@cern.ch>
-Date: Wed, 14 Nov 2018 11:36:49 +0100
-Subject: Fix FindOracle.cmake to find version 18.x
-
----
- cmake/modules/FindOracle.cmake | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/cmake/modules/FindOracle.cmake b/cmake/modules/FindOracle.cmake
-index b7c8cfbb99..6672cb1bbd 100644
---- a/cmake/modules/FindOracle.cmake
-+++ b/cmake/modules/FindOracle.cmake
-@@ -55,7 +55,7 @@ FIND_LIBRARY(
- )
- FIND_LIBRARY(
- ORACLE_LIBRARY_LNNZ
-- NAMES libnnz10 nnz10 libnnz11 nnz11 libnnz12 nnz12 ociw32
-+ NAMES libnnz10 nnz10 libnnz11 nnz11 libnnz12 nnz12 nnz18 ociw32
- PATHS ${ORACLE_LIB_LOCATION}
- )
-
---
-2.19.1
-