summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-visualization/mayavi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-visualization/mayavi')
-rw-r--r--sci-visualization/mayavi/Manifest1
-rw-r--r--sci-visualization/mayavi/files/mayavi-4.1.0-vtkQt.patch25
-rw-r--r--sci-visualization/mayavi/files/mayavi-4.2.0-doc.patch37
-rw-r--r--sci-visualization/mayavi/mayavi-4.3.0.ebuild76
-rw-r--r--sci-visualization/mayavi/metadata.xml24
5 files changed, 163 insertions, 0 deletions
diff --git a/sci-visualization/mayavi/Manifest b/sci-visualization/mayavi/Manifest
new file mode 100644
index 000000000000..466a71a2aed3
--- /dev/null
+++ b/sci-visualization/mayavi/Manifest
@@ -0,0 +1 @@
+DIST mayavi-4.3.0.tar.gz 7669453 SHA256 ebad81222809d18ad443cd11d62e768998467064628f8c13786ac692dd858b8d SHA512 1530c194ba5f94d7a2767dbc0e704892520c24c2af5ea8977c791922fa8a1ddf780d1589bf38b4efe4b5bc779c1ef6358d9664963fa9d4c5a1e75f6500f4a974 WHIRLPOOL 4f187ce7c4c6e8f040ef49a9586b6ab796382fa20f04c0f5ddf0870f9418f3622a4ad9bc846e4dd390f9dcf4482df84fa6673d5a76de643886e87954622ada58
diff --git a/sci-visualization/mayavi/files/mayavi-4.1.0-vtkQt.patch b/sci-visualization/mayavi/files/mayavi-4.1.0-vtkQt.patch
new file mode 100644
index 000000000000..6f5834ce1317
--- /dev/null
+++ b/sci-visualization/mayavi/files/mayavi-4.1.0-vtkQt.patch
@@ -0,0 +1,25 @@
+From 2fece6b29c9f3eefa523c8131cce02f724e437f3 Mon Sep 17 00:00:00 2001
+Message-Id: <2fece6b29c9f3eefa523c8131cce02f724e437f3.1330934918.git.jlec@gentoo.org>
+From: martin <martin@think.(none)>
+Date: Sun, 19 Feb 2012 10:43:39 -0500
+Subject: [PATCH] FIX: don't wrap vtkQt classes
+
+---
+ tvtk/code_gen.py | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/tvtk/code_gen.py b/tvtk/code_gen.py
+index f0b0b60..377801e 100644
+--- a/tvtk/code_gen.py
++++ b/tvtk/code_gen.py
+@@ -92,6 +92,7 @@ class TVTKGenerator:
+ #classes = dir(vtk)
+ classes = [x.name for x in wrap_gen.get_tree() \
+ if x.name.startswith('vtk') and \
++ not x.name.startswith('vtkQt') and \
+ not issubclass(getattr(vtk, x.name), object) ]
+ for nodes in tree:
+ for node in nodes:
+--
+1.7.8.5
+
diff --git a/sci-visualization/mayavi/files/mayavi-4.2.0-doc.patch b/sci-visualization/mayavi/files/mayavi-4.2.0-doc.patch
new file mode 100644
index 000000000000..1cdb129871e3
--- /dev/null
+++ b/sci-visualization/mayavi/files/mayavi-4.2.0-doc.patch
@@ -0,0 +1,37 @@
+ setup.py | 16 ++++++++--------
+ 1 file changed, 8 insertions(+), 8 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 0177c44..58d13b0 100644
+--- a/setup.py
++++ b/setup.py
+@@ -300,14 +300,14 @@ class MyBuild(build.build):
+ """
+
+ def run(self):
+- build_tvtk_classes_zip()
++# build_tvtk_classes_zip()
+ build.build.run(self)
+- self.run_command('gen_docs')
+- try:
+- self.run_command('build_docs')
+- except:
+- log.warn("Couldn't build documentation:\n%s" %
+- traceback.format_exception(*sys.exc_info()))
++# self.run_command('gen_docs')
++# try:
++# self.run_command('build_docs')
++# except:
++# log.warn("Couldn't build documentation:\n%s" %
++# traceback.format_exception(*sys.exc_info()))
+
+
+
+@@ -494,6 +494,6 @@ numpy.distutils.core.setup(
+ license = "BSD",
+ long_description = '\n'.join(DOCLINES[3:]),
+ platforms = ["Windows", "Linux", "Mac OS-X", "Unix", "Solaris"],
+- zip_safe = False,
++ zip_safe = True,
+ **config
+ )
diff --git a/sci-visualization/mayavi/mayavi-4.3.0.ebuild b/sci-visualization/mayavi/mayavi-4.3.0.ebuild
new file mode 100644
index 000000000000..c02d00125ebc
--- /dev/null
+++ b/sci-visualization/mayavi/mayavi-4.3.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Enthought Tool Suite: Scientific data 3-dimensional visualizer"
+HOMEPAGE="
+ http://code.enthought.com/projects/mayavi/
+ http://pypi.python.org/pypi/mayavi/"
+SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="2"
+KEYWORDS="amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+RDEPEND="
+ >=dev-python/apptools-4[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ >=dev-python/envisage-4[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pyface[${PYTHON_USEDEP}]
+ >=dev-python/traitsui-4[${PYTHON_USEDEP}]
+ dev-python/wxpython[${PYTHON_USEDEP}]"
+CDEPEND="sci-libs/vtk[python]"
+DEPEND="
+ ${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/wxpython[opengl]
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ )"
+
+#DOCS="docs/*.txt"
+
+# testsuite is a trainwreck; https://github.com/enthought/mayavi/issues/66
+#RESTRICT="test"
+
+PATCHES=( "${FILESDIR}"/${PN}-4.2.0-doc.patch )
+
+python_compile_all() {
+ if use doc; then
+ ${PYTHON} setup.py gen_docs || die
+ ${PYTHON} setup.py build_docs || die
+ fi
+}
+
+python_test() {
+
+ VIRTUALX_COMMAND="nosetests" virtualmake
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use doc && dohtml -r docs/build/mayavi/html/
+
+ if use examples; then
+ docompress -x usr/share/doc/${PF}/examples/
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+
+ newicon mayavi/core/ui/images/m2.png mayavi2.png
+ make_desktop_entry ${PN}2 \
+ "Mayavi2 2D/3D Scientific Visualization" ${PN}2
+}
diff --git a/sci-visualization/mayavi/metadata.xml b/sci-visualization/mayavi/metadata.xml
new file mode 100644
index 000000000000..54bc70ee9f0d
--- /dev/null
+++ b/sci-visualization/mayavi/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ Mayavi2 is a general purpose, cross-platform tool for 3-D scientific
+ data visualization. Its features include:
+ * Visualization of scalar, vector and tensor data in 2 and 3 dimensions.
+ * Easy scriptability using Python.
+ * Easy extendibility via custom sources, modules, and data filters.
+ * Reading several file formats: VTK (legacy and XML), PLOT3D, etc.
+ * Saving of visualizations.
+ * Saving rendered visualization in a variety of image formats.
+ * Convenient functionality for rapid scientific plotting via mlab
+
+ Mayavi2 has been designed with scriptability and extensibility in
+ mind. Mayavi2 provides a mayavi2 application which is usable by
+ itself. However, Mayavi2 may also be used as a plotting engine, in
+ scripts, like with matplotlib or gnuplot, as well as a library for
+ interactive visualizations in any other application. It may also be
+ used as an Envisage plug-in which allows it to be embedded in other
+ Envisage based applications natively.
+</longdescription>
+</pkgmetadata>