summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/agedu
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/agedu')
-rw-r--r--sys-apps/agedu/Manifest2
-rw-r--r--sys-apps/agedu/agedu-20141024.10297.ebuild34
-rw-r--r--sys-apps/agedu/agedu-20150422.3922.ebuild34
-rw-r--r--sys-apps/agedu/files/agedu-r9671-fix-automagic.patch44
-rw-r--r--sys-apps/agedu/metadata.xml8
5 files changed, 122 insertions, 0 deletions
diff --git a/sys-apps/agedu/Manifest b/sys-apps/agedu/Manifest
new file mode 100644
index 000000000000..84b6b426f987
--- /dev/null
+++ b/sys-apps/agedu/Manifest
@@ -0,0 +1,2 @@
+DIST agedu-20141024.r10297.tar.gz 164175 SHA256 2760df3b2e37ec0a472a1630fcd53f61443e76ddb7daabb907ada77d3a580ce0 SHA512 1fe2344b5542f9c2b316ef294e25364590384723c0d56f1fcf1d1518d18dcb34daa1ba35bc23be5cb0723e0d2e278e05d21852e075bc656b6df51d94b8c3a08d WHIRLPOOL 0f59bd5f7d652f429788677fed2cf6e223223a227533434719be6aab5638b2d082989274656b2ef41adc754884fe7aa2f89447114e2dd17e51dbd8fb2ceb0597
+DIST agedu-20150422.3922.tar.gz 164771 SHA256 4314c8f991bb6a9bf8d0792737be4f51141a87627ad867f515e07d8b7f0922eb SHA512 77833c369e4647b00eebe671152345b2a4adc01b40fe1f51f1d8f9e1258b11b55dc3441997aa135ecfe5f36598afbb6566108caa1178a94f5a34d9b7904f14f4 WHIRLPOOL 7b84a775bd4af3c3b59039af880bcdb0363ffbf4f40e49396659d21ba5bab14865bae84c1b1890341a34ed1bf48c7a5d383053ec904ccf9e67e39c485c03f625
diff --git a/sys-apps/agedu/agedu-20141024.10297.ebuild b/sys-apps/agedu/agedu-20141024.10297.ebuild
new file mode 100644
index 000000000000..f1aca36a19e8
--- /dev/null
+++ b/sys-apps/agedu/agedu-20141024.10297.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit autotools eutils versionator
+
+MY_COMP=( $(get_all_version_components) )
+MY_P="${PN}-${MY_COMP[0]}.r${MY_COMP[2]}"
+
+DESCRIPTION="A utility for tracking down wasted disk space"
+HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/agedu/"
+SRC_URI="http://www.chiark.greenend.org.uk/~sgtatham/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc ipv6"
+
+DEPEND="doc? ( app-doc/halibut )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-r9671-fix-automagic.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf --enable-ipv4 \
+ $(use_enable doc halibut) \
+ $(use_enable ipv6)
+}
diff --git a/sys-apps/agedu/agedu-20150422.3922.ebuild b/sys-apps/agedu/agedu-20150422.3922.ebuild
new file mode 100644
index 000000000000..a9472ed6e8d0
--- /dev/null
+++ b/sys-apps/agedu/agedu-20150422.3922.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit autotools eutils versionator
+
+MY_COMP=( $(get_all_version_components) )
+MY_P="${PN}-${MY_COMP[0]}.${MY_COMP[2]}"
+
+DESCRIPTION="A utility for tracking down wasted disk space"
+HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/agedu/"
+SRC_URI="http://www.chiark.greenend.org.uk/~sgtatham/${PN}/${MY_P}ffe.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}ffe"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc ipv6"
+
+DEPEND="doc? ( app-doc/halibut )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-r9671-fix-automagic.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf --enable-ipv4 \
+ $(use_enable doc halibut) \
+ $(use_enable ipv6)
+}
diff --git a/sys-apps/agedu/files/agedu-r9671-fix-automagic.patch b/sys-apps/agedu/files/agedu-r9671-fix-automagic.patch
new file mode 100644
index 000000000000..8e0c6ea2969e
--- /dev/null
+++ b/sys-apps/agedu/files/agedu-r9671-fix-automagic.patch
@@ -0,0 +1,44 @@
+diff -Naur agedu-r9671.orig/configure.ac agedu-r9671/configure.ac
+--- agedu-r9671.orig/configure.ac 2012-10-20 21:20:47.000000000 -0400
++++ agedu-r9671/configure.ac 2012-10-21 15:13:08.000000000 -0400
+@@ -10,8 +10,6 @@
+ AC_PROG_CC
+ AC_PROG_CC_C99
+ AC_PROG_INSTALL
+-AC_CHECK_PROG([HALIBUT],[halibut],[yes],[no])
+-AM_CONDITIONAL([HAVE_HALIBUT],[test "x$HALIBUT" = "xyes"])
+
+ # Checks for libraries.
+
+@@ -43,13 +41,28 @@
+
+ AC_CHECK_FUNCS([ftruncate fdopendir lstat64 stat64 memchr munmap select socket strcasecmp strchr strcspn strerror strrchr strspn strtoul strtoull connect inet_ntoa inet_addr gethostbyname getaddrinfo])
+
++AC_ARG_ENABLE([halibut],
++ AS_HELP_STRING([--disable-halibut],
++ [disable documentation with halibut (default off)]),
++ [halibut=$enableval],[halibut=no])
++
++if test "$halibut" = "no"; then
++ AM_CONDITIONAL([HAVE_HALIBUT],[false])
++else
++ AC_CHECK_PROG([have_halibut],[halibut],[yes],[no])
++ if test "$have_halibut" = "no"; then
++ AC_MSG_ERROR([halibut configured but not found])
++ fi
++ AM_CONDITIONAL([HAVE_HALIBUT],[true])
++fi
++
+ AC_ARG_ENABLE([ipv6],
+ AS_HELP_STRING([--disable-ipv6],
+- [disable IPv6 in the built-in web server]),
+- [ipv6=$enableval],[ipv6=$ac_cv_func_getaddrinfo])
++ [disable IPv6 in the built-in web server (default off)]),
++ [ipv6=$enableval],[ipv6=no])
+ AC_ARG_ENABLE([ipv4],
+ AS_HELP_STRING([--disable-ipv4],
+- [disable IPv4 in the built-in web server]),
++ [disable IPv4 in the built-in web server (default on)]),
+ [ipv4=$enableval],[ipv4=yes])
+ if test "$ipv6" = "no"; then
+ AC_DEFINE([NO_IPV6], [1], [define if IPv6 is disabled at configure time])
diff --git a/sys-apps/agedu/metadata.xml b/sys-apps/agedu/metadata.xml
new file mode 100644
index 000000000000..1e7587374fdf
--- /dev/null
+++ b/sys-apps/agedu/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+</pkgmetadata>