summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-15 19:18:50 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-15 19:18:50 +0100
commitb3f1a4d6918e7f07a3f78567bcd7d5b2136cae1e (patch)
tree7e733adcfb1ff24afa81d567d7876c3d4fbdd137 /sys-apps/i2c-tools
parentros-meta/ament_cmake: Remove py3.8-only versions (diff)
downloadgentoo-b3f1a4d6918e7f07a3f78567bcd7d5b2136cae1e.tar.gz
gentoo-b3f1a4d6918e7f07a3f78567bcd7d5b2136cae1e.tar.bz2
gentoo-b3f1a4d6918e7f07a3f78567bcd7d5b2136cae1e.zip
sys-apps/i2c-tools: Remove py3.8-only versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-apps/i2c-tools')
-rw-r--r--sys-apps/i2c-tools/Manifest1
-rw-r--r--sys-apps/i2c-tools/i2c-tools-4.1-r1.ebuild81
2 files changed, 0 insertions, 82 deletions
diff --git a/sys-apps/i2c-tools/Manifest b/sys-apps/i2c-tools/Manifest
index cad813324a0a..7d5824b262f6 100644
--- a/sys-apps/i2c-tools/Manifest
+++ b/sys-apps/i2c-tools/Manifest
@@ -1,3 +1,2 @@
-DIST i2c-tools-4.1.tar.xz 83576 BLAKE2B 0a9ed3bb335b61f6c17a6b6c705502ff008b4fb8bab6a5fde63163a32528b5214d92affc4b8d6cca29676dc7ba82dfa84be5f14943b7e81c8612a7d9419ac628 SHA512 83262bcfd94c2adf74517cc50095dd78221fa4d16a62397245d4a538de7463272abf4f6727024be8ab1ca8ecbfe647af85ba2a553e5b5e68a53e50dfcad20248
DIST i2c-tools-4.2.tar.xz 87600 BLAKE2B 89f84ad07f4c042f67c308d48a402aa9ed46352062ddad3456d048730019e099e6eef626d487d802e07b100ae2c836e9aa6b2345950ff8744cbc0fe1a22616fb SHA512 5e230be4983c5c9c5718491d3ce9ee2e6205edea75c4097735eb32a25e522e37a074ef4cb61d2492707efebf0cb1b75ff65f1b2ae8c0bc1684a169526809a096
DIST i2c-tools-4.3.tar.xz 81276 BLAKE2B c7300224c8d32785cd067b632bf0e9591f05264b1572f44aebda5f30a95164732d606710c13739ccb7899476219ceb3033beaf95b718ed7e18122f9181dc13fc SHA512 8a6cc12d927d6291b9baf407bc15807280539a7048ec5c2edf77414432eab43b28353c42bc0e45b7b481502aa4c5588def08f130d97fc275f635d1f77488f501
diff --git a/sys-apps/i2c-tools/i2c-tools-4.1-r1.ebuild b/sys-apps/i2c-tools/i2c-tools-4.1-r1.ebuild
deleted file mode 100644
index 9900e3bbff0e..000000000000
--- a/sys-apps/i2c-tools/i2c-tools-4.1-r1.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{3_7,3_8} )
-DISTUTILS_OPTIONAL="1"
-
-inherit distutils-r1 flag-o-matic toolchain-funcs
-
-DESCRIPTION="I2C tools for bus probing, chip dumping, EEPROM decoding, and more"
-HOMEPAGE="https://www.kernel.org/pub/software/utils/i2c-tools"
-SRC_URI="https://www.kernel.org/pub/software/utils/${PN}/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm ~arm64 ~mips ~ppc ~ppc64 ~sparc x86"
-IUSE="perl python static-libs"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="
- python? ( ${PYTHON_DEPS} )"
-DEPEND="${RDEPEND}"
-RDEPEND+="
- perl? ( dev-lang/perl )"
-
-src_prepare() {
- default
- use python && distutils-r1_src_prepare
-
- # Cut out the eeprom/ & stub/ dirs as only perl scripts live there.
- if ! use perl ; then
- sed -i '/^SRCDIRS/s: eeprom stub : :g' Makefile || die
- fi
-}
-
-src_configure() {
- use python && distutils-r1_src_configure
-
- # Always build & use dynamic libs if possible.
- if tc-is-static-only ; then
- export BUILD_DYNAMIC_LIB=0
- export USE_STATIC_LIB=1
- export BUILD_STATIC_LIB=1
- else
- export BUILD_DYNAMIC_LIB=1
- export USE_STATIC_LIB=0
- export BUILD_STATIC_LIB=$(usex static-libs 1 0)
- fi
-}
-
-src_compile() {
- emake AR="$(tc-getAR)" CC="$(tc-getCC)" all-lib # parallel make
- emake CC="$(tc-getCC)"
- emake -C eepromer CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
-
- if use python ; then
- cd py-smbus || die
- append-cppflags -I../include
- distutils-r1_src_compile
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" libdir="/usr/$(get_libdir)" PREFIX="/usr" install-lib install
- dosbin eepromer/eeprom{,er}
- rm -rf "${D}"/usr/include || die # part of linux-headers
- dodoc CHANGES README
- local d
- for d in $(usex perl eeprom '') eepromer ; do
- docinto "${d}"
- dodoc "${d}"/README*
- done
-
- if use python ; then
- cd py-smbus || die
- docinto py-smbus
- dodoc README*
- distutils-r1_src_install
- fi
-}